Facebook  Twitter 

SMFHacks.com

+- +-

SMFHacks.com

+- User Information

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Forum Stats

Members
Total Members: 11173
Latest: Christopherjohn9
New This Month: 44
New This Week: 13
New Today: 1
Stats
Total Posts: 35097
Total Topics: 6200
Most Online Today: 105
Most Online Ever: 2482
(April 09, 2011, 06:02:45 pm)
Users Online
Members: 1
Guests: 63
Total: 64

Author Topic: Gallery mod links cause 501 error.  (Read 2133 times)

0 Members and 1 Guest are viewing this topic.

Offline JeffP

  • Newbie
  • *
  • Posts: 1
    • View Profile
Gallery mod links cause 501 error.
« on: January 03, 2012, 05:39:58 pm »
Hi Guys
Not sure if this is a bug or just something I have not setup correctly.
I have SMF 2.0.2 with Simple Portal 2.3.4 and SMF Gallery Lite 3.1.1a.
Site is http://www.shorkietalk.com.
You will see a gallery on the front page of a couple of images. If you click on the image or title you will get a 501 error, but a click on the members name is fine.
Any help would be appreciated.
Thanks

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 12904
    • View Profile
Re: Gallery mod links cause 501 error.
« Reply #1 on: January 03, 2012, 05:46:21 pm »
That is caused by mod_security since it does not like ;id= in the url

Check out this link or ask your hosting provider to disable it
http://wiki.simplemachines.org/smf/Mod_security_-_Having_problems_with_mod_security


The issue you are having is the portal block which appears to be part of Simple Portal.

Generally what I suggest if you can't disable it via hosting is do search and replace on the gallery files
for
Code: [Select]
;id=
And replace with
Code: [Select]
&id=
You would need to the same with the Simple Portal files as well in your case.
Get your Forum Ranked! at http://www.forumrankings.net - find out how your forum compares with others! Also contests/promotions for verified sites.

 

+- Recent Topics

TopMessageIndex by SMFHacks
March 27, 2015, 05:31:35 pm

Can't install by SMFHacks
March 27, 2015, 12:54:45 pm

When installing doesn't create a gallery folder in SMF by SMFHacks
March 26, 2015, 05:12:35 pm

User Galleries by lonewood
March 26, 2015, 03:24:04 pm

Only half done. by DenDen60
March 25, 2015, 04:36:00 pm

Copyright Removal does not work by werner_hampel
March 25, 2015, 06:39:30 am

Bug In Line (1666) by SMFHacks
March 24, 2015, 11:27:19 am

Additional fields (for size i.e.) seems doesn't work properly by testJL
March 23, 2015, 12:03:53 pm

Bypass Download Limit Bug by elbeer
March 23, 2015, 09:17:09 am

Upgrading from 2.0 to 2.5 - Manual Edits by SMFHacks
March 22, 2015, 10:20:30 pm

Powered by EzPortal