Facebook  Twitter 

SMFHacks.com

+- +-

SMFHacks.com

+- User Information

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Forum Stats

Members
Total Members: 11912
Latest: tom789
New This Month: 13
New This Week: 1
New Today: 0
Stats
Total Posts: 37890
Total Topics: 6667
Most Online Today: 80
Most Online Ever: 2482
(April 09, 2011, 07:02:45 pm)
Users Online
Members: 0
Guests: 62
Total: 62

Author Topic: Gallery Lite menu problem  (Read 2982 times)

0 Members and 1 Guest are viewing this topic.

Offline annedi

  • SMF Gallery Pro Customer
  • Newbie
  • *****
  • Posts: 6
    • View Profile
Gallery Lite menu problem
« on: November 15, 2016, 09:22:59 am »
We are running SMF 2.0.12 for nikongear.net.
I installed Gallery Lite 5.6.1.
No installation problems.

However, I cannot see the Gallery > Gallery Configuration menu item in Admin.
And also cannot see the Gallery menu item on the main page.

I've read through other (somewhat old) posts about this problem.
But I cannot see where to fix anything in index.template.php as you suggest.
The code in 2.0.12 does not list the buttons by name in index.template.php.

Any help you can provide would be welcome. Thanks!
Added later:  We are probably going with Gallery Pro.
But we wanted to simply have a quick look first using Gallery Lite.

Andrea B.
Admin at nikongear.net


Here is the current menu code for the main page.

Code: [Select]
// Show the menu up top. Something like [home] [help] [profile] [logout]...
function template_menu()
{
global $context, $settings, $options, $scripturl, $txt;

echo '
<div id="main_menu">
<ul class="dropmenu" id="menu_nav">';

foreach ($context['menu_buttons'] as $act => $button)
{
echo '<li id="button_', $act, '">

<a class="', $button['active_button'] ? 'active ' : '', 'firstlevel" href="', $button['href'], '"', isset($button['target']) ? ' target="' . $button['target'] . '"' : '', '>

<span class="', isset($button['is_last']) ? 'last ' : '', 'firstlevel">', $button['title'], '</span>
</a>';

if (!empty($button['sub_buttons']))
{
echo '<ul>';

foreach ($button['sub_buttons'] as $childbutton)
{
echo '<li>
<a href="', $childbutton['href'], '"', isset($childbutton['target']) ? ' target="' . $childbutton['target'] . '"' : '', '>
<span', isset($childbutton['is_last']) ? ' class="last"' : '', '>', $childbutton['title'], !empty($childbutton['sub_buttons']) ? '...' : '', '</span>
</a>';

// 3rd level menus :)
if (!empty($childbutton['sub_buttons']))
{
echo '<ul>';

foreach ($childbutton['sub_buttons'] as $grandchildbutton)
echo '<li>
<a href="', $grandchildbutton['href'], '"', isset($grandchildbutton['target']) ? ' target="' . $grandchildbutton['target'] . '"' : '', '>
<span', isset($grandchildbutton['is_last']) ? ' class="last"' : '', '>', $grandchildbutton['title'], '</span>
</a></li>';
echo '</ul>';
}
echo '</li>';
}
echo '</ul>';
}
echo '</li>';
}
echo '</ul>
</div>';
}
« Last Edit: November 15, 2016, 10:06:24 am by annedi »

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 14029
    • View Profile
Re: Gallery Lite menu problem
« Reply #1 on: November 15, 2016, 10:38:20 am »
The menu button code is actually in sources/subs.php there should be a gallery entry
You  can upload gallery lite to
http://www.smfhacks.com/smf-package-parser.html
And make sure all the edits are made to the files.

Also make sure the text from the gallery from themes/default/languages/modifications.english.php  is in any modifications.*.php file and also in other themes if that modifications.*.php file exists.
Get your Forum Ranked! at http://www.forumrankings.net - find out how your forum compares with others! Also contests/promotions for verified sites.

Offline annedi

  • SMF Gallery Pro Customer
  • Newbie
  • *****
  • Posts: 6
    • View Profile
Re: Gallery Lite menu problem
« Reply #2 on: November 15, 2016, 11:37:11 am »
The XML installation search position code fails for index.template.php (from SMF 2.0.12) ??
So index.template.php does not get updated ??
And it cannot be manually updated because apparently some of the code has been rewritten.
I cannot find where to add a gallery button.
I posted the function template_menu() in my first post to show you.


argh. Sorry. got installation scripts mixed up!

I ran the parser and got no errors for Gallery Lite 5.6.1 and SMF 2.0.12.
« Last Edit: November 15, 2016, 11:49:44 am by annedi »

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 14029
    • View Profile
Re: Gallery Lite menu problem
« Reply #3 on: November 15, 2016, 11:46:09 am »
For SMF 2.0.x it doesn't make any changes to the index.template.php make sure you chose an SMF 2.0 version
Get your Forum Ranked! at http://www.forumrankings.net - find out how your forum compares with others! Also contests/promotions for verified sites.

Offline annedi

  • SMF Gallery Pro Customer
  • Newbie
  • *****
  • Posts: 6
    • View Profile
Re: Gallery Lite menu problem
« Reply #4 on: November 15, 2016, 11:51:10 am »
Yes. Sorry! (my error)
I just edited my post but will repeat:

I ran the parser and got no errors for Gallery Lite 5.6.1 and SMF 2.0.12.

So still puzzled why nothing is showing up.

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 14029
    • View Profile
Re: Gallery Lite menu problem
« Reply #5 on: November 15, 2016, 11:59:01 am »

Also make sure the text from the gallery from themes/default/languages/modifications.english.php  is in any modifications.*.php file and also in other themes if that modifications.*.php file exists.
Get your Forum Ranked! at http://www.forumrankings.net - find out how your forum compares with others! Also contests/promotions for verified sites.

Offline annedi

  • SMF Gallery Pro Customer
  • Newbie
  • *****
  • Posts: 6
    • View Profile
Re: Gallery Lite menu problem
« Reply #6 on: November 15, 2016, 12:04:53 pm »
Found it !!!!

It was a simple permissions problem. I am one of two Admins on Nikongear.net but not "the Admin", who of course would have immediately seen the Gallery menu items. All I needed to do was check my "Use SMF Gallery" permission checkbox under my admin General Permissions and the Gallery menu items turned on.
DUH !!!!

Thank you for your prompt response. Sorry I didn't figure that one out right away. :D  :D :D

Andrea B.

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 14029
    • View Profile
Re: Gallery Lite menu problem
« Reply #7 on: November 15, 2016, 12:09:48 pm »
Glad you have it figured out.
Get your Forum Ranked! at http://www.forumrankings.net - find out how your forum compares with others! Also contests/promotions for verified sites.

 

Related Topics

  Subject / Started by Replies Last post
15 Replies
13444 Views
Last post January 27, 2007, 07:47:56 pm
by SMFHacks
3 Replies
3771 Views
Last post April 21, 2008, 10:17:18 pm
by SMFHacks
2 Replies
3388 Views
Last post May 03, 2008, 06:56:02 pm
by Bec
5 Replies
5424 Views
Last post February 02, 2011, 01:05:44 pm
by SMFHacks
6 Replies
2855 Views
Last post November 24, 2013, 03:03:34 pm
by dan42101

+- Recent Topics

RSS Feed killed my forum by hippieboy123
April 18, 2017, 07:39:26 am

Is there a converter than converts all files found in topics of a specific board by SMFHacks
April 13, 2017, 02:46:18 pm

Sidebar Image width by hippieboy123
April 12, 2017, 01:32:00 pm

I run a Custom Theme and have many Test Failed - What to do? by SMFHacks
April 11, 2017, 05:12:15 pm

Daughter menus by Labradoodle-360
April 08, 2017, 05:37:22 pm

Lost my copyright removal when I converted forum to SSL by Nova
April 08, 2017, 01:19:50 pm

With .htaccess, how do I redirect an action to another action by shuban
April 06, 2017, 11:45:50 pm

Newsletter Pro errors in log by SMFHacks
April 03, 2017, 04:54:40 pm

Random Image Block code by landyvlad
March 30, 2017, 02:54:32 am

Upgrade Account - Download SMF Gallery Pro by mrsclaudio
March 29, 2017, 10:14:11 am

Powered by EzPortal