Facebook  Twitter 

SMFHacks.com

+- +-

SMFHacks.com

+- User Information

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Forum Stats

Members
Total Members: 12324
Latest: videorepair
New This Month: 11
New This Week: 1
New Today: 1
Stats
Total Posts: 39696
Total Topics: 6993
Most Online Today: 30
Most Online Ever: 2482
(April 09, 2011, 07:02:45 pm)
Users Online
Members: 0
Guests: 25
Total: 25

Author Topic: Download button doesn't initiate a download the first time  (Read 375 times)

0 Members and 1 Guest are viewing this topic.

Offline tfs

  • Downloads Pro Customer
  • Newbie
  • *****
  • Posts: 18
    • View Profile
Download button doesn't initiate a download the first time
« on: November 23, 2018, 09:19:27 pm »
First of all, sorry about the formatting but the WYSIWYG editor is stripping my carriage returns for some reason. I'll try typing html carriage returns in to fix it.

Download button doesn't initiate a download the first time.

I just downloaded and installed 5.0beta, filename DownloadsPro5.0beta.zip

Unrelated to this bug report, it says the following in the Settings area:

Your Version: 5.0beta Latest Version: 4.1.11 Your downloads system version is not up to date!

Now, on to the bug...

I believe this also happened with the previous version 4.1.11

I have it set to Show Download Link in the Category Display Settings. But I have noticed that the first time a user clicks on the download button it doesn't download but enters the file properties as if they clicked on the filename. All subsequent clicks of the Download button in the Category Display initiates an immediate download as it should.

After the user logs out and back in the behavior repeats.

Edit: Apparently just the preview stripped carriage returns and the final message displayed all of my "br" html tags. Edited and removed.
« Last Edit: November 23, 2018, 09:21:00 pm by tfs »

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 14867
    • View Profile
Re: Download button doesn't initiate a download the first time
« Reply #1 on: November 23, 2018, 09:35:51 pm »
Odd does it happen to you on this site here?
https://www.smfhacks.com/index.php?action=downloads;cat=1
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline tfs

  • Downloads Pro Customer
  • Newbie
  • *****
  • Posts: 18
    • View Profile
Re: Download button doesn't initiate a download the first time
« Reply #2 on: November 23, 2018, 09:53:26 pm »
I can't make it happen here on your site. But it happens on mine with latest FireFox and IE.

Also happens with 4.1.11 after a downgrade due to errors in the log after the 5.0 beta. (Will post that on another thread)

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 14867
    • View Profile
Re: Download button doesn't initiate a download the first time
« Reply #3 on: November 24, 2018, 09:08:55 pm »
Strange I tried another one of my test sites. Haven't sen the issue. Can you pm a link to view.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

 

Related Topics

  Subject / Started by Replies Last post
2 Replies
2832 Views
Last post May 21, 2009, 09:27:05 pm
by SMFHacks
4 Replies
3020 Views
Last post May 23, 2009, 09:58:59 am
by Vincent Volmer
1 Replies
2118 Views
Last post December 06, 2009, 12:09:44 pm
by SMFHacks
11 Replies
6865 Views
Last post October 26, 2013, 08:06:38 am
by SMFHacks
4 Replies
1179 Views
Last post January 17, 2017, 11:15:23 am
by shuban

+- Recent Topics

Which Options To Disable If I Don't Want Auction Listings by ajac63
May 19, 2019, 11:03:42 pm

About Layout Options by ajac63
May 18, 2019, 07:22:19 am

Lost images by pete
May 17, 2019, 04:41:51 am

Q's on Integrating SMF Classifieds with current theme by ajac63
May 08, 2019, 01:46:06 pm

Just a hello by SMFHacks
May 06, 2019, 10:30:20 pm

Contact Page Problem by Acans
May 06, 2019, 01:54:08 am

Trying to install 8.0.5a after upgrade to RC2 by SMFHacks
April 30, 2019, 06:04:34 am

Classified Ads Mod by SMFHacks
April 29, 2019, 07:44:44 pm

Video Player by SMFHacks
April 24, 2019, 03:38:50 am

Seller View Log.. Can I delete? by SMFHacks
April 22, 2019, 07:54:29 am

Powered by EzPortal