SMFHacks.com

Modifications/Themes => General SMF Forum => Topic started by: jacci on February 02, 2007, 07:47:16 am

Title: Link Mod
Post by: jacci on February 02, 2007, 07:47:16 am
I have just installed the link mod and noticed that the link option only displays if your are logged in.

is there a way i can get this to show for guests as well?

I have copied the mod into my theme and not sure if i stuffed it up or that is just the way it is written.

http://www.pretendercentre.com/pretenderforum/index.php

tahnks

jacci
Title: Re: Link Mod
Post by: SMFHacks on February 02, 2007, 09:40:18 am
Which option? Check permissions for the links mod. Admin -> Permissions they need to be set for every group.
Title: Re: Link Mod
Post by: jacci on February 02, 2007, 09:55:30 am
Okay, i am not sure if i am just doign this wrong, just installed it and not all that familiar with mods.

I have set all the categories wiht all groups defined permissions, basically allowing everything except for guests to post a link.

Everything seems to be working very well, but if you go to the index page, in my row of buttons: Home, profile, gallery etc etc
the Link button only shows up when you are logged in. So no guests can actually get to the links.

the coding i used in my skin index.template.php, which seems to work fine for gallery (that button is showing up when not logged in) is:

Code: [Select]
// the [links] button
if ($context['allow_view_smflinks'])
echo '
<a href="', $scripturl, '?action=links">' , ($settings['use_image_buttons'] ? '<img src="' . $settings['images_url'] . '/' . $context['user']['language'] . '/links.gif" alt="' . $txt['smflinks_menu'] . '" style="margin: 2px 0;" border="0" />' : $txt['smflinks_menu']), '</a>', $context['menu_separator'];

for the gallery:
Code: [Select]
// the [SMF Gallery] button
if ($context['allow_smfgallery_view'])
echo '
<a href="', $scripturl, '?action=gallery">' , ($settings['use_image_buttons'] ? '<img src="' . $settings['images_url'] . '/' . $context['user']['language'] . '/gallery.gif" alt="' . $txt['smfgallery_menu'] . '" style="margin: 2px 0;" border="0" />' : $txt['smfgallery_menu']), '</a>', $context['menu_separator'];

thanks your help is greatly appreciated
jacci
Title: Re: Link Mod
Post by: SMFHacks on February 02, 2007, 09:57:31 am
You need to give guests permissions to view the links and gallery.
Goto Admin -> Permissions Then modify each group and give them View Links and View Gallery permissions.
Title: Re: Link Mod
Post by: jacci on February 02, 2007, 10:13:53 am
LMAO, *head desk*
thanks

now i feel like a complete idiot....  didnt even think to check in that permission setting area

that fixed it just fine

my excuse, poor as it is, is it is about 3am here and i have been doing this WAY too long today.

thank you sooooo much for your help.
Title: Re: Link Mod
Post by: avidum on February 14, 2007, 02:36:31 pm
oops ignore.