SMFHacks.com

SMF Gallery Pro => Support => Bugs => Topic started by: rumboogy on June 12, 2007, 03:17:32 pm

Title: Version 1.3 Beta Bug
Post by: rumboogy on June 12, 2007, 03:17:32 pm
Mr. SMFHacks...

I have a member that uploaded two photos which were waiting for approval. When I went to approve them...I get the following error:

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND approved = 1' at line 1
File: /usr/home/mk1579/public_html/1d/Sources/Gallery.php
Line: 4445

Any help or hotfix you can provide would be appreciated. Thanks.

Wally
Title: Re: Version 1.3 Beta Bug
Post by: rumboogy on June 13, 2007, 09:07:00 am
Just got this error with more photos that were uploaded.

Wally
Title: Re: Version 1.3 Beta Bug
Post by: SMFHacks on June 13, 2007, 07:32:51 pm
Fixed I believe check out the latest beta version
http://www.smfhacks.com/index.php/topic,787.msg4807.html#msg4807
Title: Re: Version 1.3 Beta Bug
Post by: rumboogy on June 13, 2007, 09:01:44 pm
Unfortunately, it did not work. I uninstalled the previous version, then uploaded the new one...when I tried to approve the photos...I got this:

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND approved = 1' at line 1
File: /usr/home/mk1579/public_html/1d/Sources/Gallery.php
Line: 4450

Thanks...I will try again when you load another version.

Wally
Title: Re: Version 1.3 Beta Bug
Post by: SMFHacks on June 13, 2007, 09:27:44 pm
What kind of photos are they? Member gallery? Main gallery?
Title: Re: Version 1.3 Beta Bug
Post by: rumboogy on June 13, 2007, 09:38:45 pm
Member Gallery

If need be...I can provide an admin account...if necessary.

http://www.1dseries.com/1d/index.php?action=gallery;sa=approvelist

Thanks again.

Wally
Title: Re: Version 1.3 Beta Bug
Post by: SMFHacks on June 13, 2007, 09:43:39 pm
Reuploaded the beta with a fix.
Title: Re: Version 1.3 Beta Bug
Post by: rumboogy on June 13, 2007, 10:02:26 pm
Bingo...worked. I was able to approve the images...THANK YOU.

Although there is a smaller bug now...(But no hurry on this one)...

http://www.1dseries.com/1d/index.php?action=gallery;su=user;u=41 (http://www.1dseries.com/1d/index.php?action=gallery;su=user;u=41)

Says ONE total Image, but there are two images in the gallery. Incorrect count.

Wally