SMFHacks.com

Modifications/Themes => General SMF Forum => Topic started by: Rock Lee on October 06, 2019, 12:45:14 pm

Title: Problem update 1.1.21 to 2.0.15
Post by: Rock Lee on October 06, 2019, 12:45:14 pm
They tried to update this forum without success and do not have a backup copy, I was trying to get to the underlying problem that apparently could not convert the database correctly. Try to repair the errors that were appearing but I reached a point I can not move forward and I do not quite understand how I should proceed. If I run the forum in 1.1.21 the error that marks me is:

Code: [Select]
Unknown column 'b.numPosts' in 'field list'
File: /home/public_html/Sources/BoardIndex.php
Line: 84

Note: It appears that your database may require an upgrade. Your forum's files are currently at version SMF 1.1.21, while your database is at version 2.0 a. The above error might possibly go away if you execute the latest version of upgrade.php.

when I run in version 2.0 it appears to me:

Code: [Select]
Unknown column 'add_deny' in 'field list'
This is why I am doubting because he apparently made a half conversion... If someone can help me, I will appreciate it very much.


Regards!
Title: Re: Problem update 1.1.21 to 2.0.15
Post by: SMFHacks on October 06, 2019, 01:07:14 pm
Why couldn't they run the upgrade script? What errors were they getting?
Title: Re: Problem update 1.1.21 to 2.0.15
Post by: Rock Lee on October 06, 2019, 01:29:38 pm
Several errors such as the calendar date, null values, which I solved until I got caught in this error. I tried several solutions appeared in SMF but I can not view the topics although the user section appears correctly. Apparently the processes could not be completed correctly, so I was trying to repair the errors that appeared, but as for the issues, I cannot solve it (I think it is the only thing I need to run 2.0 successfully).


Regards!

Update: the affected line itself is:
Code: [Select]
WHERE $user_info[query_see_board]" . (empty($modSettings['countChildPosts']) ? "
AND b.childLevel <= 1" : ''), __FILE__, __LINE__);

From what I see the database has 34 tables so it did not start (rather it does not let me start the update to 2.0) although I did run the update to 1.1.21 because I was 1.1.18 ... I want to run 1.1.21 (install a clean one and it works as it should in my hosting) and when importing the database and fixing the errors it marked me it was solved but the latter did not manage to find the problem in particular to start the update necessary to the new branch.
Title: Re: Problem update 1.1.21 to 2.0.15
Post by: SMFHacks on October 06, 2019, 02:19:10 pm
Try this upgrader https://www.smfhacks.com/upgradetest.zip
Title: Re: Problem update 1.1.21 to 2.0.15
Post by: Rock Lee on October 06, 2019, 02:37:40 pm
Moving some codes I managed to start update 2.0 although I throw the following error:

Code: [Select]
Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /home/s0568048/public_html/forooo/upgrade.php on line 47
As soon as he tried to use the file you left me it gives me many errors but basically it sums up "Notice: Undefined index: upgrade_step in"


Regards!
Title: Re: Problem update 1.1.21 to 2.0.15
Post by: SMFHacks on October 06, 2019, 03:00:54 pm
I would try to upgrade PHP to version 7.1 if you can.
Or install the mysqli instruction.
Title: Re: Problem update 1.1.21 to 2.0.15
Post by: Rock Lee on October 06, 2019, 03:02:53 pm
I would try to upgrade PHP to version 7.1 if you can.
Or install the mysqli instruction.


Something strange happens when wanting to enter the update.php file does not open it is as if it did not exist: / I will also try the PHP now I tell you it comes out.


Regards!

Update: PHP 7.0 and 7.1
Fatal error: Uncaught Error: Call to undefined function set_magic_quotes_runtime() in /home/public_html/foro/upgrade.php:112 Stack trace: #0 /home/public_html/foro/upgrade.php(45): initialize_inputs() #1 {main} thrown in /home/public_html/foro/upgrade.php on line 112
Title: Re: Problem update 1.1.21 to 2.0.15
Post by: SMFHacks on October 06, 2019, 03:05:26 pm
K cause that is the latest file form SMF 2.0.x
Title: Re: Problem update 1.1.21 to 2.0.15
Post by: Rock Lee on October 06, 2019, 03:22:31 pm
Only the update to branch 1.1.21 is executed but it does not allow me to update to 2.0 all these errors appear to me although all the files are present.


Regards!
Title: Re: Problem update 1.1.21 to 2.0.15
Post by: SMFHacks on October 06, 2019, 03:51:49 pm
Give this one a try
https://www.smfhacks.com/upgradetest2.zip
Title: Re: Problem update 1.1.21 to 2.0.15
Post by: Rock Lee on October 06, 2019, 04:02:19 pm
Now it is displayed correctly but the following error still appears:

Code: [Select]
The upgrader found some old or outdated files.

Please make certain you uploaded the new versions of all the files included in the package.

Click here to try again.

I reloaded all the files in case there was one missing but it remains the same.


Regards!
Title: Re: Problem update 1.1.21 to 2.0.15
Post by: SMFHacks on October 06, 2019, 04:08:08 pm
What SMF version are you on?
Title: Re: Problem update 1.1.21 to 2.0.15
Post by: Rock Lee on October 06, 2019, 04:14:32 pm
Download the latest version of the page of simplemachines 2.0.15


Regards!
Title: Re: Problem update 1.1.21 to 2.0.15
Post by: SMFHacks on October 06, 2019, 04:23:03 pm
odd...that means index.php is not on SMF 2.0.15...

Try this file commented it out.
Title: Re: Problem update 1.1.21 to 2.0.15
Post by: Rock Lee on October 06, 2019, 04:40:01 pm
If it worked now but stopped on process 13 and tells me:
Code: [Select]
Removing all guest deny permissions...done
!!
Error!
Unknown column 'addDeny' in 'where clause'

And it doesn't let me continue...


Regards!
Title: Re: Problem update 1.1.21 to 2.0.15
Post by: SMFHacks on October 06, 2019, 05:01:53 pm
Try this query...
Code: [Select]

ALTER TABLE smf_permissions
ADD addDeny tinyint(4) NOT NULL default '1';
Title: Re: Problem update 1.1.21 to 2.0.15
Post by: Rock Lee on October 06, 2019, 05:45:37 pm
Tells me that
Code: [Select]
#1060 - Duplicate Column Name 'addDeny'

Regards!
Title: Re: Problem update 1.1.21 to 2.0.15
Post by: SMFHacks on October 06, 2019, 05:58:15 pm
Ok this might be beyond what I can offer. I would try asking on simplemachines.org
Title: Re: Problem update 1.1.21 to 2.0.15
Post by: Rock Lee on October 06, 2019, 06:09:16 pm
I will turn to them thank you very much he will be able to advance a lot!


Regards!

UPDATE: I could solve it, I should simply generate this sql query also in the table "smf_board_permissions" :)