Facebook  Twitter 

SMFHacks.com

+-

SMFHacks.com

+- User Information

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Forum Stats

Members
Total Members: 4257
Latest: Alex998.
New This Month: 1
New This Week: 0
New Today: 0
Stats
Total Posts: 43295
Total Topics: 7523
Most Online Today: 251
Most Online Ever: 2482
(April 09, 2011, 07:02:45 pm)
Users Online
Members: 0
Guests: 118
Total: 118

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - PapaFrizArcade

Pages: [1] 2 3 ... 5
1
Support / Re: Couple of Remaining Errors
« on: July 15, 2022, 08:14:59 am »
Well it seems my license has expired.  I guess I need to determine if fixing those little errors is worth the purchase price.  I'll likely hold off until you've started updating the Badges mod with 2.1.x stuff (like alerts, etc)...

Thanks anyway.

2
Support / Re: Couple of Remaining Errors
« on: July 14, 2022, 02:45:58 pm »
Awesome... will give it a try.  Thanks.

3
Support / Couple of Remaining Errors
« on: July 14, 2022, 08:23:19 am »
Hey there...

I've been getting these errors in my log from time to time...

Not a lot ... but this has been happening since I moved to 2.1.x FOR SURE... but could have been happening prior (to be 100% honest my last 2.0.x site was a mess and I was getting random errors from places quite frequently).

What I know:  It happens ONLY when my badgemaster is adding a new badge.  It seems to affect nothing that you can notice from a user perspective as my badgemasters have never complained about something broken ... even when asked.  Hence my extreme urgency on this matter (sarcasm evident?)...

;)

If you get a little time and are bored and want to look in to this... that would be awesome.

:D

Thanks!

Code: [Select]
osver
 67.170.23.99
 a31dde423ccb4b56b767a4822fb3c175
 https://www.aha-forums.com/index.php?action=admin;area=badgeawards;sa=givebadge2
 /home/ahaforum/public_html/Themes/default/GenericMenu.template.php (Line 269)  Backtrace information

Type of error: General
Error messageSelect
2: Invalid argument supplied for foreach()
4

 Yesterday at 04:31:29 PM
 osver
 67.170.23.99
 a31dde423ccb4b56b767a4822fb3c175
 https://www.aha-forums.com/index.php?action=admin;area=badgeawards;sa=givebadge2
 /home/ahaforum/public_html/Themes/default/GenericMenu.template.php (Line 269)  Backtrace information

Type of error: General
Error messageSelect
8: Trying to access array offset on value of type null

4
You can easily change back to the default icon by opening the zip package locally on your computer.  Within that zip package are the default icons.  You could re-load them back in.

(or you could right click and "save image as" any of the icons on this forum to save to re-upload on yours if you only have a couple you want to go back to default).

:D

5
Support / Re: Server Issues
« on: May 12, 2022, 11:50:04 am »
Found a bunch of different ways to access historical data,  unfortunately it appears to typically only go back a couple days or so.  I'll ask the server admin for more info if possible.

6
Support / Re: Server Issues
« on: May 12, 2022, 11:15:48 am »
I can ask the server admin ... or if you can direct me to where I may be able to create such a log in Cpanel (if doable) I can do it myself.


7
Support / Re: Server Issues
« on: May 12, 2022, 10:29:05 am »
Ah,  but the alerts "mod" is no longer a mod but part of SMF.  I guess I need to report this issue over there?

8
Support / Server Issues
« on: May 12, 2022, 09:01:51 am »
This last weekend we experienced some server issues...

I was told:

Quote
I found that the site was hitting PHP-FPM pool limits. I have increased those considerably which should resolve the issue.


That seemed to resolve the issue for a few hours... but then the site went down again.  I re-inquired.  After a short while everything went back online and it has been since.  A day or two later my server admin emailed me:


Quote
How have things been performing since your last reply?

We ended up increasing the limits on another setting within an hour or so of your last reply. Have things been normal since then?

Another thing they mentioned is that there was a lot of traffic to a specific query that day that seemed like a possible indicator of a code-related issue. We're not 100% positive but something wasn't adding up that day.

The overall traffic isn't what was really concerning but the amount of requests for specific things were much higher than some of the other sites on the server that have a lot more traffic (as a comparison).

For example, here's one comment from the datacenter:

"When looking at traffic from 67.XXX.112.XXX, I found quite a few of the following requests:

67.XXX.112.XXX - - [09/May/2022:16:10:24 -0400] "GET /index.php?action=profile;area=alerts_popup;counter=6;u=436 HTTP/1.1" 200 486 "https://www.NOFOLLOW.com/index.php?action=badgeawards;sa=badgedetail&id=699" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/101.0.4951.54 Safari/537.36"

You may want to run that by the site developer to see if there have been recent changes."

That particular IP (user) above had about 5000 requests in the timeframe that day we were reviewing.

The IP in question above is one of my BADGEMASTERS.  I asked him about that day... if he noticed anything... and asked what he was doing.  He replied:

Quote
That's odd for sure.

I was browsing around the master badge list looking at previous badges I have missed as I'm thinking of starting a thread of Zombie badge hunting for stuff that I may have missed being late to the AHA game.

I probably had 15 or so tabs open with various badges from the list and the threads they came from. It certainly didn't feel like much of anything excessive though.

I cannot begin to imagine how I could have generated 5000 requests for anything from the site over a particular time period though, unless that period was days to weeks long.

I had a fair number of problems on Monday when the site was having issues, but so did everyone.

Anything I can do to assist in troubleshooting though, let me know.

It seems that messing around in the MASTER BADGE list may have caused too many PHP calls or something?!? I have no idea... hence my post here.  Keep in mind we are nearly at 1000 badges now.

Any way to prevent this in the future?  Is my hypothesis correct?  Am I going to have to start DELETING badges? (say it isn't so!!!)

:D

Anyway,  whatever they did on their side seems to have worked as the site is up and we've not had any more issues since...

9
Modifications Talk / Re: SMF Gallery (FREE) Issue
« on: April 24, 2022, 07:35:30 pm »
Badgeawards were uninstalled... but sitting in the package manager.  As soon as I re-installed all is good.

Thx.

10
Modifications Talk / SMF Gallery (FREE) Issue
« on: April 24, 2022, 05:18:53 pm »
Testing SMF Gallery in my sandbox.

I installed on a site with badges as well.

I am getting this error when I attempt to upload an image...


Warning: require_once(/home/ahaforum/public_html/test/Sources/badgeawards2.php): failed to open stream: No such file or directory in /home/ahaforum/public_html/test/Sources/Gallery2.php on line 2577

The error white screens with this error above.

11
Support / Re: Dark theme that Awesome Post Ratings works with?
« on: April 23, 2022, 08:57:46 am »
BTW... I just parsed the code that is output at the link posted above for TEMPLATE ONLY in to the two template files... and the mod is now working in the SociWT theme as well.   

12
Support / Re: Dark theme that Awesome Post Ratings works with?
« on: April 23, 2022, 07:39:06 am »
Dark themes that work great with this mod out of the box:

Alien Shades
Blue Evolution
Blue Space

All work with the mod.  I did just try both of the themes mentioned above.  One won't install (2.1.1 here) and the other ... sure enough ... no post ratings.

13
Support / Re: Icon Size
« on: April 06, 2022, 07:44:20 pm »
Nevermind.  Found the line in the hooks file.

14
Support / Icon Size
« on: April 06, 2022, 12:55:13 pm »
Hello,

I've found the code where I can add a style height tag to adjust the height of an icon for both the selection section to the right... as well as the display section to the left.


[ Guests cannot view attachments ]


What I've been having difficulty finding is where I can control the size of the icon that is attached to the ALERT drop down and ALL ALERTS screen.

My idea is to use larger icons ... maybe 32x32.. they look great at this size in the messages sections... however,  they are about twice as large as they should be in the alerts drop down and in the all alerts section...


[ Guests cannot view attachments ]

[ Guests cannot view attachments ]


Where can I find the line I need to edit to reduce the size of those icons to say... 40% it's size on the drop down and 60% it's size in the all alerts section?

Thanks!

15
Support / CSS Question
« on: April 02, 2022, 02:48:12 pm »
I've posted this over on SMF site so I might get the answer there first... but I figured I'd ask here too as it has to do with this mod...

I've done some CSS work and some HTML tweaks to this mod.  The HTML tweaks are easy enough to implement in to the mod so that when I uninstall/reinstall my tweaks are included... but i am not 100% sure how to implement the CSS.

Currently I have the CSS at the bottom of the index.css for each theme.  How would I either...

(A) Inject this CSS in to the index.css of each theme (or give the option for each theme)

or

(B) Include a css stylesheet ... I'm pretty sure how to load the stylesheet in to the default themes css folder,  but I don't know how to actuall CALL that stylesheet so that the css is implemented.


In any case... here is my latest CSS tweak...

[ Guests cannot view attachments ]

Pages: [1] 2 3 ... 5

+- Recent Topics

Please Help! by SMFHacks
Today at 08:04:55 am

Rate own images by fvlog19
April 11, 2024, 10:56:53 am

Tidy Child Boards on 2.1.4 by SMFHacks
April 04, 2024, 03:54:12 pm

Problems SMF 2.0.19 > 2.1.4 SMF Gallery Pro - Recents Images to overall header by Michel68
March 30, 2024, 12:41:08 pm

Can't DROP 'id_member'; check that column/key exists Datei: by SMFHacks
March 30, 2024, 11:58:20 am

No thumbnails on new uploads by Tonyvic
March 29, 2024, 06:26:18 am

Display the Contact Page for guests by SMFHacks
March 27, 2024, 10:55:43 am

is it possible to add support for odysee.com by fvlog19
March 21, 2024, 08:47:51 am

Request for admin notification by davejo
March 10, 2024, 01:31:59 am

I need help with torrent upload by Ineedsmfhelp
March 09, 2024, 10:01:13 pm

Powered by EzPortal