Facebook  Twitter 

SMFHacks.com

+-

SMFHacks.com

+- User Information

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Forum Stats

Members
Total Members: 4260
Latest: Verrick
New This Month: 3
New This Week: 0
New Today: 0
Stats
Total Posts: 43301
Total Topics: 7525
Most Online Today: 114
Most Online Ever: 2482
(April 09, 2011, 07:02:45 pm)
Users Online
Members: 0
Guests: 83
Total: 83

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - landyvlad

Pages: [1] 2
1
Support / code for copy img bbcode link?
« on: June 07, 2023, 11:33:16 pm »
One of the great features of this gallery is the presence of an easy 'click to copy image bbcode' button next to pictures in the gallery.

I would like to implement something similar on one of my sites, any chance of providing the code that does that particular function? 


"No, go away you silly man" is an acceptable answer (but not the preferred one  ;D  )

2
Support / 500 error with gallery.
« on: June 07, 2023, 03:56:33 am »
The gallery link: https://gsx1400owners.org/forum/index.php?action=gallery
as you can see currently generates a 500 error.

HISTORY

I was getting the 500 error as above and the error log contained:
Quote
Guest
 (IP address)
 d62cd46c0b4c4ffa6255407149e35b63
 https://gsx1400owners.org/forum/index.php?action=gallery;sa=view;id=135
 /home/gsxowner/public_html/forum/index.php (Line 455)  Backtrace information

Type of error: General
Error messageSelect
2: require_once(/home/gsxowner/public_html/forum/Sources/Gallery2.php): Failed to open stream: No such file or directory

One of my fellow admins who's more conversant with the backend side of things, said:
Quote
there is a file  called Gallery2.php keeps deleting itself, I have no idea why ???
I keep putting it back, and they gallery works again. but it just goes again.

I realised I was using a previous version of gallery pro so downloaded and installed the latest version (as at the date of this post). This seemed to fix the issue. Briefly.

Presumably this reinstall meant that, once again, there was a Gallery2.php in the directory again but yes, it soon disappeared.

Ultimately tracked this down to
Quote
CPGuard is detecting Gallery2.php as possibly malicious because of some base64 string manipulations.
The match is: {HEX}Malware.Expert.php.ini.ini.ini.ini.ini.ini.chmod.base64.decode.base64.decode.php

My host added the file to the whitelist so it's not disappearing any more.
HOWEVER the 500 error persists.

I again checked with my host and they have confirmed
Quote
The file is there and permissions all look normal.
I can't see a reason for the error 500 being logged in the domlogs or in the LiteSpeed global log.
Everything looks normal on this end, nothing tripping in Mod_Sec (WAF) either.

So my questions are:
  • What might be causing this error, and how should I proceed to address it?
  • What's a base64 line? Should it be in that file?
  • Is every instance of gallery2.php identical or is it something that changes between installations?
  • What does Gallery2.php actually DO?

It was suggested that (assuming the gallery lite version) I should remove line 384-ish
Code: [Select]
die(base64_decode('UG93ZXJlZCBieSBHYWxsZXJ5IEZvciBTTUYgIG1hZGUgYnkgdmJnYW1lcjQ1IGh0dHA6Ly93d3cuc21maGFja3MuY29t'));
but what does this line do? And what would be the impact of removing it?

I'm unsure whether the same applies to the Pro version so seeking guidance here before I touch anything.


I'd like to extend my appreciation to @vbgamer for his support this far.

3
Presales for Products / Ad Seller Pro question
« on: September 10, 2021, 07:25:17 am »
Do you have any screenshots of a forum showing examples of the various types of ad actually displaying?

Alternatively a forum you know of, which uses this mod, and browse-able by guests?

4
Presales for Products / Emoji Pro question
« on: September 10, 2021, 07:22:46 am »
So to clarify what it is - it's basically a big collection of emoji images (aka smileys, aka emoticons), which are separated into tabs.
Is that correct?  If so -

Is it SMF 2.1.x ready?  (I run 2.0.17 at the moment, soon 2.0.18 and later will go to 2.1)
Is the emoji library editable?
-  add and delete emojis?
-  create, add and delete tabs in the emoji list?
-  move emoticons between various tabs?
-  customise the text equivalent for the emoji?
  By which I mean
Code: [Select]
:D for :D
and so on.

5
Support / Is SMF Gallery Pro SSI still required?
« on: September 10, 2021, 06:56:46 am »
I've had SMF Gallery Pro installed for quite a while (since 2015 I think?) Anyway back in the day when I installed it I also had to install a mod called "SMF Gallery Pro SSI"

I can't even recall what it did...except that I needed it at the time.
Is that still a thing?
If so when is it needed?
And if I do need it, where do I find it?

I've just renewed my licence, and will be installing Gallery Pro 9.0b

6
Bugs / Gallery bug in 2.1
« on: March 13, 2019, 05:46:18 am »
my forum,  https://www.droneflightforum.com/index.php?action=gallery


to which I've applied he suggested temporary (clumsy) 'fix', but unsure if working.

described here:  https://www.smfhelper.com/index.php?topic=178.msg1367#msg1367


Quote
On another note: You also have image placeholders showing all over your gallery, because the new.gif is missing from,

Themes/Drone/images/english/new.gif

Quote
There is no image folder for english that I know of?

Quote
I know Les. But that's where the gallery mod is calling it from. He'll just have to add a folder titled english, and drop the new.gif into it, then it will work..

Or mod the gallery files to suit.

Quote
there is an english folder in smf2.0.15 but not 2.1

so perhaps an oversight when making that gallery mod 2.1 compatible?

7
Support / Bulk upload image problem
« on: February 14, 2019, 10:57:25 pm »
SMF Gallery pro - users are able to upload single images no problem but as of a couple of days ago it seems that bulk uploads don't work.

Selecting bulk uplaods just results in as per the attachment.

To my knowledge there haven't been any other changes to the site in the way of either mods or manual edits.

I don't have access to the site myself and nor. at the moment does the admin who's crook - but it would help if we could figure out where the star looking?


Any ideas?

8
Support / Problem with uninstall
« on: January 17, 2018, 05:20:38 am »
I am trying to uninstall version  7.2.2 (from my SMF2/0/13 forum) in order to upgrade to 7.2.4 as my  12 month licence is about to expire...

Anyway the tests for the uninstall do not make happy reading...

Quote
      Type   Action   Description
*   1.   Execute Modification   ./Themes/default/languages/Modifications.english.php   Test successful
*   2.   Execute Modification   ./Themes/default/languages/Modifications.english-utf8.php   Test failed
   1.   Add Before   ./Themes/default/languages/Modifications.english-utf8.php   Test failed
*   3.   Execute Modification   ./Themes/default/languages/Who.english.php   Test successful
*   4.   Execute Modification   ./index.php   Test successful
*   5.   Execute Modification   ./Sources/Admin.php   Test failed
   1.   Replace   ./Sources/Admin.php   Test failed
*   6.   Execute Modification   ./Sources/Subs.php   Test failed
   1.   Replace   ./Sources/Subs.php   Test failed
   2.   Replace   ./Sources/Subs.php   Test failed
   3.   Add Before   ./Sources/Subs.php   Test successful
*   7.   Execute Modification   ./Sources/ManagePermissions.php   Test failed
   1.   Replace   ./Sources/ManagePermissions.php   Test failed
   2.   Replace   ./Sources/ManagePermissions.php   Test failed
8.   Execute Modification   ./Sources/PrettyUrls-Filters.php   Skipping file
*   9.   Execute Modification   ./Sources/Load.php   Test successful
*   10.   Execute Modification   ./Sources/Subs-Graphics.php   Test successful
:-\


please help !  :)   Thanks !

9
Support / Random Image Block code
« on: March 28, 2017, 08:51:21 am »
I know there is an EZPortal block.

Are you able to provide the appropriate code so I can accomplish the same result in TinyPortal?

Thanks   ;D

10
Support / Unable to upload MP4 video
« on: February 11, 2017, 12:39:12 am »
I have a member trying to upload Go Pro footage in MP4 format.

Keeps coming up with "Server was reset" and he is unable to do so.

Gallery Pro issue or SMF issue?

What settings do I need to look at / what can be causing this please?

11
Support / Issue with resizing of images
« on: January 29, 2017, 01:39:17 am »
I am using the Responsive Curve theme.

My users have noted that viewing the forum from a number of various devices (ipads, surface pros etc) that images don't size to fit the screen... but stay large and require 'scrolling sideways' to view - which is far from ideal.

This happens both with attachments and images from the gallery (in this case SMF Gallery pro).  Is there something I can do so that images resize to suit when being viewed from mobile devices? 

Even if it could be solved just for the gallery images that'd be a start !

Thank you !



12
Bugs / Next image doesn't refresh BB code link
« on: January 27, 2017, 06:58:38 am »
If I am going through a series of photos, copying bb code to post into a thread. WHen I choose 'next image'it refreshes the photo (with, of course, the next image) but the bb code doesn't refresh and stays as per the first photo I originally clicked into.

The only way to get fresh (correct) bb code is to go back to the gallery and the click on the picture each time.

This is an issue, obviously.  :)



13
Bugs / Bulk uploader doesn't resize pics.
« on: January 27, 2017, 06:56:28 am »
Adding one at a time resizes the images, but when I bulk upload it keeps them at the original file size.  I'd prefer they also resized please.

14
Support / Instructionals?
« on: January 26, 2017, 03:58:09 am »
Are there any step by step instructions (with pictures) to walk people (eg members) through how to use their albums?

My members seem to be having great difficulty with it....

15
Support / Member gallery permissions
« on: January 25, 2017, 08:37:49 pm »
I was having problems with members not being able to bulk upload. (no option) even though the permission was there.

Then I discovered it was something to do with the difference between galleries and categories.... an issue I still don't understand.
And if I don't, what hope have my members got?


Ultimately my question is this:

Rather than confuse members with admin rights to their own galleries and so on... can I set  it up so that each member has their main gallery and say 3 sub galleries (categories??? ) they can upload INCLUDING BULK UPLOAD to as needed ?

PLEASE help me get this sorted out its the main necessity for my forum at the moment and only real impediment to it going live....

Pages: [1] 2

+- Recent Topics

Pretty Urls extras by SMFHacks
May 13, 2024, 10:28:54 am

Mod question by Verrick
May 11, 2024, 02:42:50 pm

i have paid but cant download ad pro. by SMFHacks
May 02, 2024, 11:29:38 pm

Please Help! by SMFHacks
April 17, 2024, 08:04:55 am

Rate own images by fvlog19
April 11, 2024, 10:56:53 am

Tidy Child Boards on 2.1.4 by SMFHacks
April 04, 2024, 03:54:12 pm

Problems SMF 2.0.19 > 2.1.4 SMF Gallery Pro - Recents Images to overall header by Michel68
March 30, 2024, 12:41:08 pm

Can't DROP 'id_member'; check that column/key exists Datei: by SMFHacks
March 30, 2024, 11:58:20 am

No thumbnails on new uploads by Tonyvic
March 29, 2024, 06:26:18 am

Display the Contact Page for guests by SMFHacks
March 27, 2024, 10:55:43 am

Powered by EzPortal