Facebook  Twitter 

SMFHacks.com

+- +-

SMFHacks.com

+- User Information

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Forum Stats

Members
Total Members: 11790
Latest: ButtKoWitz
New This Month: 3
New This Week: 0
New Today: 0
Stats
Total Posts: 41408
Total Topics: 7255
Most Online Today: 103
Most Online Ever: 2482
(April 09, 2011, 07:02:45 pm)
Users Online
Members: 0
Guests: 32
Total: 32

Author Topic: Gallery Pro Delete Image  (Read 469 times)

0 Members and 1 Guest are viewing this topic.

Offline Anmer

  • SMF Gallery Pro Customer
  • Jr. Member
  • *****
  • Posts: 54
    • View Profile
Gallery Pro Delete Image
« on: July 30, 2021, 01:45:56 pm »
I was testing the Posting Option when adding a new Category to set a Board and Topic ID to post the new, approved image.

This worked OK.

Then I deleted the image and the original topic, including previous messages, has disappeared.  This may be a bug?

If I try to view the original topic I get the message:

An Error Has Occurred!
The topic or board you are looking for appears to be either missing or off limits to you.

The topic and messages are in the back-end database but I can't view them in the forum.

Two questions:

1. Is this a bug or feature, where deleting a single or multiple iamages "hides" the original topic?
2. Can I make the topic visible again, minus the messages associated with the deleted image(s)?  If so, how do I achive this?

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15662
    • View Profile
Re: Gallery Pro Delete Image
« Reply #1 on: July 30, 2021, 01:59:13 pm »
1. It is if it is the topic starter. That would delete any comments following the first post in the topic including the first post. The theory is if image is gone they won't be able to see it in the topic.
2. Only if you have recycle bin enabled in SMF.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline Anmer

  • SMF Gallery Pro Customer
  • Jr. Member
  • *****
  • Posts: 54
    • View Profile
Re: Gallery Pro Delete Image
« Reply #2 on: July 30, 2021, 02:17:26 pm »
Thanks.

The image post wasn't the topic starter, there were prior messages in the topic.

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15662
    • View Profile
Re: Gallery Pro Delete Image
« Reply #3 on: July 30, 2021, 06:44:05 pm »
So you were using a topic id?
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15662
    • View Profile
Re: Gallery Pro Delete Image
« Reply #4 on: July 30, 2021, 07:13:57 pm »
There is a settings to disable removing of the topic but the image post will remain if the image is deleted.

I might have to update logic right now the gallery picture table only stores the topic id. I should have it also store the message id. So if you are using the custom topic setting the entire topic does not disappear but only the msg from that picture.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline Anmer

  • SMF Gallery Pro Customer
  • Jr. Member
  • *****
  • Posts: 54
    • View Profile
Re: Gallery Pro Delete Image
« Reply #5 on: July 31, 2021, 01:03:01 am »
So you were using a topic id?

Yes I was.  I assumed it was a mandatory requirement.

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15662
    • View Profile
Re: Gallery Pro Delete Image
« Reply #6 on: July 31, 2021, 03:59:49 pm »
If you leave the topic id blank it just creates a new topic for that image.

Did an update so going forward for new messages added the following:
!Improved the handling of deleting a gallery item topic. Will only delete the topic if it is the first post.  Handles and stores the post msg_id
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline Anmer

  • SMF Gallery Pro Customer
  • Jr. Member
  • *****
  • Posts: 54
    • View Profile
Re: Gallery Pro Delete Image
« Reply #7 on: August 01, 2021, 02:41:16 am »
Thanks.  Installed latest Beta and the deleted image no longer deletes the topic which is great.  But it does leave the original message within the topic (created when the image was first added), also displaying the original image.

When the deleted image was the first message within the topic, the topic is deleted, as expected.

Is the intended process?  I was expecting the associated message to be deleted when it's not the first in the topic.  But it's not an issue if it's not intended.
« Last Edit: August 01, 2021, 03:11:07 am by Anmer »

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15662
    • View Profile
Re: Gallery Pro Delete Image
« Reply #8 on: August 01, 2021, 06:18:30 am »
The message should be single deleted. But this only occurs for new images uploaded if you had existing ones then it would not work.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline Anmer

  • SMF Gallery Pro Customer
  • Jr. Member
  • *****
  • Posts: 54
    • View Profile
Re: Gallery Pro Delete Image
« Reply #9 on: August 01, 2021, 11:14:42 am »
Thanks.

I have a topic that I've set for new added images to post a message.  This is set in the Category with the topic ID.

On adding a new image the topic gets updated with the new image message.

On deleting the image, I get an error message.  The Image is deleted but the message still remains in the Topic.

If I don't set a topic ID, a fresh topic is created with the new message.  Deleting the image removes the image, message and topic.  As expected.

The issue seems to be when the topic ID is set in the Category, which is necessary to add new messages to that topic.  But deleting the images doesn't delete the message.

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15662
    • View Profile
Re: Gallery Pro Delete Image
« Reply #10 on: August 01, 2021, 03:19:54 pm »
Haven't been able to recreate that issue.
Try this attached Gallery2.php code to your sources folder
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline Anmer

  • SMF Gallery Pro Customer
  • Jr. Member
  • *****
  • Posts: 54
    • View Profile
Re: Gallery Pro Delete Image
« Reply #11 on: August 02, 2021, 02:44:59 am »
Downloaded and replaced Gallery2.php.

Unfortunately same issue as before.

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15662
    • View Profile
Re: Gallery Pro Delete Image
« Reply #12 on: August 02, 2021, 05:40:53 am »
Odd, i can't seem to recreate that issue.
I tried with topic id.  Doing multiple uploads to that same topic. Then adding replies in between. Then deleting an image from the gallery.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline Anmer

  • SMF Gallery Pro Customer
  • Jr. Member
  • *****
  • Posts: 54
    • View Profile
Re: Gallery Pro Delete Image
« Reply #13 on: August 02, 2021, 06:15:17 am »
I tried with topic id.  Doing multiple uploads to that same topic. Then adding replies in between.

I thought there's a clue.  I'd selected "Lock Topic" in the Category setup.  But removing the lock didn't make any difference.

Then I made a reply to the topic and deleted an image.  Still the same error message and the message remains.

This is the category setup if it helps.

Offline Anmer

  • SMF Gallery Pro Customer
  • Jr. Member
  • *****
  • Posts: 54
    • View Profile
Re: Gallery Pro Delete Image
« Reply #14 on: August 02, 2021, 09:44:26 am »
I think I've narrowed this issue to non-Admin users.

If I add an image as Admin, deleting works as expected, no error message and the relevant message is deleted from the topic.

If the image is added by a forum member with Gallery image Add, Approve and Delete rights, the error message appears and the message remains in the topic.

Which, maybe, is why you can't replicate the issue?
« Last Edit: August 02, 2021, 09:54:51 am by Anmer »

 

Related Topics

  Subject / Started by Replies Last post
10 Replies
5072 Views
Last post January 09, 2014, 10:19:12 am
by HAL9000
4 Replies
1895 Views
Last post December 03, 2012, 10:21:35 am
by The Wizard
1 Replies
2400 Views
Last post January 23, 2013, 02:27:14 pm
by SMFHacks
2 Replies
3777 Views
Last post August 18, 2013, 11:22:21 am
by CWVRV
7 Replies
4409 Views
Last post February 17, 2014, 06:36:26 pm
by shuban

+- Recent Topics

Import downloads by mickjav
September 25, 2021, 04:47:13 am

Errors with 5.0.6 version by Hatshepsut
September 24, 2021, 10:21:24 pm

Forum ToolBox by mickjav
September 23, 2021, 03:20:07 pm

Ads Description is running into Ad Location by Shades
September 23, 2021, 09:56:42 am

S3 System For SMF Attachments by SMFHacks
September 21, 2021, 05:46:38 pm

Boards Icon by mickjav
September 18, 2021, 02:13:43 pm

Search Word Limit by SMFHacks
September 17, 2021, 08:41:01 pm

Item not appearing in category by SMFHacks
September 17, 2021, 08:39:45 pm

Undefined index: gallery_ad_seller by Shades
September 17, 2021, 01:23:10 pm

What happens if? by SMFHacks
September 14, 2021, 10:25:07 pm

Powered by EzPortal