Facebook  Twitter 

SMFHacks.com

+-

SMFHacks.com

+- User Information

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Forum Stats

Members
Total Members: 11832
Latest: balasahu
New This Month: 7
New This Week: 1
New Today: 1
Stats
Total Posts: 42228
Total Topics: 7368
Most Online Today: 51
Most Online Ever: 2482
(April 09, 2011, 07:02:45 pm)
Users Online
Members: 1
Guests: 44
Total: 45

Author Topic: New Photos Won't Upload - Gallery Pro 8.0 or 9.0b - Old Photos Still Visible  (Read 317 times)

0 Members and 1 Guest are viewing this topic.

Offline Michael Vail

  • SMF Gallery Pro Customer
  • Member
  • *****
  • Posts: 31
    • View Profile
    • Sonoma County DSA
FORUM INFO
Link to my forum: https://sonomacountydsa.org/forums
SMF version: SMF ver. 2.0.19
Tiny Portal version: TP ver. 2.1.0
Default Forum Language: English
Theme name and version: Default (Curve)
Browser Name and Version: Chrome, Firefox, Edge - All Current Versions
Mods installed: See attached image of package manager
Related Error messages: SEE BELOW....
Current Server PHP Version: 7.4.27

Good evening,

I've been having a problem with my install of SMF Gallery Pro. It's been a very long time since I uploaded any photos to the gallery. All the previously uploaded photos display fine, however any new photos I attempt to upload do not display after the upload process completes. The thumbnail area is blank but all the image details appear as though everyone worked fine during the upload process (see attached image).

I have made the following attempts to resolve the issue:
  • Confirmed all Gallery folders on the webserver have 775 writable Permissions
  • Confirmed the folder and link settings in the gallery settings are correct for the webserver
  • Tried all the versions of PHP available on the server (see image below with these options)
  • Tried various pictures
  • Tried various different users including Admin
  • Upgraded SMF from 2.0.18 to 2.0.19
  • Upgraded to Gallery 9.0b from 8
  • Tried uninstalling Gallery completely but there were numerous errors shown by the uninstaller so I couldn't
  • Triple-checked many of the above things

Everything else on the forum works fine including uploading pictures in the SMF Store, it's just the SMF Gallery that doesn't allow the photos. I have a suspicion it's related to the PHP versions I'm forced to run, but of course that's only a guess. I don't possess the the knowledge to figure that out.

The only errors I'm seeing in the SMF logs are as follows:

Code: [Select]
https://www.sonomacountydsa.org/forums/index.php action=admin;area=logs;fa7f23df175b=b5018eb60a1385baff571c4f71eb36eb
Undefined index: gallery_txt_moderationcenter
File: /home/customer/www/sonomacountydsa.org/public_html/forums/Sources/Admin.php
Line: 291

I hate coming here asking for help, but I'm stuck at this point and don't know what else to check.

Any help to resolve this would be greatly appreciated.

Happy New Year!
Mike Vail

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 16003
    • View Profile
When clicking on the broken thumbnail going to main gallery image display page. Can you see the medium image or the fullsized image?
I would check if any of those files exist in the gallery folder on the server.

The gallery path url in settings make sure it ends /  should normally be of the form /home/username/public_html/gallery/ 
Check that GD is installed with PHP you can find that on the phpinfo page. That is required for thumbnails both for the gallery and SMF.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline Michael Vail

  • SMF Gallery Pro Customer
  • Member
  • *****
  • Posts: 31
    • View Profile
    • Sonoma County DSA
The url variable doesn't have an ending "/". I tried to add it nd get the below error that won't let me proceed when saving the settings.

Quote
Fatal error: Cannot redeclare GalleryMemberUnviewedItems() (previously declared in /home/customer/www/sonomacountydsa.org/public_html/forums/Sources/Subs.php:4556) in /home/customer/www/sonomacountydsa.org/public_html/forums/Sources/Subs.php on line 4903

Ironically, I posted a question about the url in another post just now. Amazing!

I attached the subs.php file if you wouldn't mind looking at it?
« Last Edit: January 03, 2022, 12:55:27 am by scso1502 »

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 16003
    • View Profile
Strange didn't see anything on line  4903
Added code to make sure it is not included twice.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline Michael Vail

  • SMF Gallery Pro Customer
  • Member
  • *****
  • Posts: 31
    • View Profile
    • Sonoma County DSA
Thank you for the help. At least now when I add the / to the end of the Gallery link in settings I no longer get the error page. Also when doing this, the thumbnail of the images I upload appears as it should. The only problem is, all the previous images disappear when I change that link and add the / at the end. I if I remove the / the previously uploaded picture thumbnails reappear but the new ones don't. Any idea how to fix it so all the images work correctly with the gallery link set correctly with the / at the end?

One other question. I would like all my images in one gallery folder not in multiple folders. Can that setting be changed and the files moved without having to redo the entire thing or am I stuck?

Thank you!
Mike V.

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 16003
    • View Profile
Is it possible to create me an admin login to check it out?


Multiple folders you would be stuck you can turn off the setting and new ones would go back the main folder. But old ones would remain where they are.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline Michael Vail

  • SMF Gallery Pro Customer
  • Member
  • *****
  • Posts: 31
    • View Profile
    • Sonoma County DSA
Thank you for that. I sent you a PM with the info you requested. Thank you for taking the time to help me with this. I will pay you for your time.

Warmest Regards,
Mike Vail
« Last Edit: January 05, 2022, 03:43:11 pm by scso1502 »

 

Related Topics

  Subject / Started by Replies Last post
21 Replies
9915 Views
Last post August 02, 2017, 05:07:03 pm
by SMFHacks
1 Replies
2541 Views
Last post February 03, 2008, 07:28:33 pm
by SMFHacks
18 Replies
8513 Views
Last post December 24, 2011, 10:41:25 pm
by RollingRock
10 Replies
7678 Views
Last post September 09, 2014, 08:56:53 am
by Jonas1975
2 Replies
1050 Views
Last post February 13, 2019, 11:15:56 am
by 10341mouse

+- Recent Topics

Dark background text color help needed by Shades
May 22, 2022, 04:51:25 pm

Database Error During Store Purchase After SMF 2.1 and Store 5.0 Beta Upgrades by Michael Vail
May 20, 2022, 08:58:15 pm

Default License Agreement by SMFHacks
May 18, 2022, 08:18:15 pm

Email Note - Included in order purchase by Shades
May 18, 2022, 02:54:54 pm

[Feature Request] Keywords by Shades
May 18, 2022, 02:20:19 pm

Undefined index: down_path by Shades
May 18, 2022, 10:19:09 am

Delete custom rating and change default icons/change icons back to default? by SMFHacks
May 18, 2022, 10:06:01 am

Thumbnails on topic page not resizing correctly by SMFHacks
May 14, 2022, 10:45:34 pm

Server Issues by PapaFrizArcade
May 12, 2022, 11:50:04 am

Funky Pagination by SMFHacks
May 11, 2022, 11:38:24 pm

Powered by EzPortal