Facebook  Twitter 

SMFHacks.com

+- +-

SMFHacks.com

+- User Information

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Forum Stats

Members
Total Members: 12382
Latest: ImportedPotato
New This Month: 1
New This Week: 1
New Today: 0
Stats
Total Posts: 40238
Total Topics: 7088
Most Online Today: 97
Most Online Ever: 2482
(April 09, 2011, 07:02:45 pm)
Users Online
Members: 0
Guests: 27
Total: 27

Author Topic: Registration Mod  (Read 2930 times)

0 Members and 1 Guest are viewing this topic.

Offline ghosttr

  • Newbie
  • *
  • Posts: 1
    • View Profile
Registration Mod
« on: March 06, 2008, 10:42:08 pm »
I have been working on a mod that will allow users to register outside of the board itself.

Code: [Select]
<?php

if (substr($_SERVER['HTTP_USER_AGENT'], 015) == "EVE-minibrowser")
{
        if ($_SERVER['HTTP_EVE_TRUSTED'] == 'no')
{
//update your site url here
header('eve.trustMe:http://forums.ark-corp.com/::Please trust me, I\'m nice');
print 
'<html><body>';
print 
'<h1>Trust Required</h1>';
print 
'I need to be trusted to work properly';

}

$vars1 $_SERVER['HTTP_EVE_CHARNAME'];
$vars2 $_SERVER['HTTP_EVE_CORPNAME'];
echo 
'
<form action="'
$scripturl'?action=Register2" method="post" name="creator" id="creator">

Username <input type="text" name="user" size="30" maxlength="25" value=' 
$vars2 $vars1 ' />
Email    <input type="text" name="email" size="30" /><br />
Password <input type="password" name="passwrd1" size="30" />
Confirm Password <input type="password" name="passwrd2" size="30" /><br />

<input type="checkbox" name="regagree" class="check" />I agree to Registration Agreement

<div align="center">
<input type="submit" name="regSubmit" value="Register" /></div>

</form>'
;
}
else
{
include(
'index2.php');
}


?>

I have renamed the regular index.php to index2, and made it so that if someone visits the page with the specified browser it asks them to register. The registration form comes up fine and that data this is supposed to be automatically entered into it enters fine. But it just refuses to register >:(



The only code that i left out was this
Code: [Select]
if ($context['user']['is_guest'])
{
loadLanguage('Login');
maybe i have to fix this somehow?

 

Related Topics

  Subject / Started by Replies Last post
1 Replies
3459 Views
Last post October 24, 2009, 12:15:06 pm
by SMFHacks
1 Replies
2852 Views
Last post October 27, 2010, 09:38:20 am
by SMFHacks
1 Replies
7741 Views
Last post February 28, 2011, 08:59:46 am
by SMFHacks
3 Replies
1855 Views
Last post June 17, 2012, 08:37:02 am
by SMFHacks
1 Replies
3146 Views
Last post August 01, 2016, 07:40:07 am
by SMFHacks

+- Recent Topics

Call to undefined function mysql_num_rows() by SMFHacks
July 30, 2020, 07:45:29 am

Problem with one videosite embedding by Hatshepsut
July 24, 2020, 01:25:08 am

Download System Lite by Rock Lee
June 03, 2020, 07:34:24 pm

Font question by SMFHacks
May 27, 2020, 08:15:26 am

Error message with latest SMF 2.1 Github build by Hatshepsut
May 25, 2020, 01:43:26 am

smfblog not working on 2.0.17 by tech9
May 20, 2020, 01:44:34 pm

Copyright removal by stbc
May 18, 2020, 01:27:57 am

Mod Verified User i can't square the image by Rock Lee
May 07, 2020, 07:56:10 pm

SMF4Mobile 2.0 released for SMF 2.0.x by SMFHacks
May 06, 2020, 12:13:14 pm

SMF Social Login Pro - Discontinued? by Nicole
May 02, 2020, 05:47:04 pm

Powered by EzPortal