Facebook  Twitter 

SMFHacks.com

+- +-

SMFHacks.com

+- User Information

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Forum Stats

Members
Total Members: 12399
Latest: SizofErsin
New This Month: 4
New This Week: 3
New Today: 0
Stats
Total Posts: 40587
Total Topics: 7131
Most Online Today: 128
Most Online Ever: 2482
(April 09, 2011, 07:02:45 pm)
Users Online
Members: 1
Guests: 73
Total: 74

Author Topic: Registration Mod  (Read 3010 times)

0 Members and 1 Guest are viewing this topic.

Offline ghosttr

  • Newbie
  • *
  • Posts: 1
    • View Profile
Registration Mod
« on: March 06, 2008, 10:42:08 pm »
I have been working on a mod that will allow users to register outside of the board itself.

Code: [Select]
<?php

if (substr($_SERVER['HTTP_USER_AGENT'], 015) == "EVE-minibrowser")
{
        if ($_SERVER['HTTP_EVE_TRUSTED'] == 'no')
{
//update your site url here
header('eve.trustMe:http://forums.ark-corp.com/::Please trust me, I\'m nice');
print 
'<html><body>';
print 
'<h1>Trust Required</h1>';
print 
'I need to be trusted to work properly';

}

$vars1 $_SERVER['HTTP_EVE_CHARNAME'];
$vars2 $_SERVER['HTTP_EVE_CORPNAME'];
echo 
'
<form action="'
$scripturl'?action=Register2" method="post" name="creator" id="creator">

Username <input type="text" name="user" size="30" maxlength="25" value=' 
$vars2 $vars1 ' />
Email    <input type="text" name="email" size="30" /><br />
Password <input type="password" name="passwrd1" size="30" />
Confirm Password <input type="password" name="passwrd2" size="30" /><br />

<input type="checkbox" name="regagree" class="check" />I agree to Registration Agreement

<div align="center">
<input type="submit" name="regSubmit" value="Register" /></div>

</form>'
;
}
else
{
include(
'index2.php');
}


?>

I have renamed the regular index.php to index2, and made it so that if someone visits the page with the specified browser it asks them to register. The registration form comes up fine and that data this is supposed to be automatically entered into it enters fine. But it just refuses to register >:(



The only code that i left out was this
Code: [Select]
if ($context['user']['is_guest'])
{
loadLanguage('Login');
maybe i have to fix this somehow?

 

Related Topics

  Subject / Started by Replies Last post
1 Replies
3545 Views
Last post October 24, 2009, 12:15:06 pm
by SMFHacks
1 Replies
2902 Views
Last post October 27, 2010, 09:38:20 am
by SMFHacks
1 Replies
7820 Views
Last post February 28, 2011, 08:59:46 am
by SMFHacks
3 Replies
1951 Views
Last post June 17, 2012, 08:37:02 am
by SMFHacks
1 Replies
3225 Views
Last post August 01, 2016, 07:40:07 am
by SMFHacks

+- Recent Topics

Forum ToolBox by Monocero
Today at 01:33:13 am

[Mod] Tagging System by SMFHacks
January 13, 2021, 08:43:33 pm

Using Alternate PayPal Address by KKOG
January 13, 2021, 07:24:46 pm

Assigning a BuyNow Button to a product by SMFHacks
January 12, 2021, 04:59:32 pm

SMF Links by Nicole
January 10, 2021, 12:02:39 pm

Error on the latest version by davejo
January 06, 2021, 08:04:05 am

Recent topics on board index by eugen
January 01, 2021, 11:08:16 am

Parser by swayforth
December 31, 2020, 12:24:23 am

Show Gallery in Users Profile by swayforth
December 29, 2020, 10:37:17 pm

Hang after upgrade MariaDB to version 10.5 by SMFHacks
December 27, 2020, 12:56:07 pm

Powered by EzPortal