Facebook  Twitter 

SMFHacks.com

+-

SMFHacks.com

+- User Information

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Forum Stats

Members
Total Members: 4260
Latest: Verrick
New This Month: 3
New This Week: 0
New Today: 0
Stats
Total Posts: 43301
Total Topics: 7525
Most Online Today: 105
Most Online Ever: 2482
(April 09, 2011, 07:02:45 pm)
Users Online
Members: 0
Guests: 90
Total: 90

Author Topic: image uploading but thumbnail not created  (Read 4620 times)

0 Members and 1 Guest are viewing this topic.

Offline clive

  • Jr. Member
  • **
  • Posts: 76
    • View Profile
image uploading but thumbnail not created
« on: March 12, 2008, 07:42:46 am »
HI,

Up to yesterday the gallery was working perfectly.

Now this morning I see that when an image is uploaded and the screen refreshes the thumbnail is not there and no clickable link to the image. My hosts have done something to the server that has made the gallery unusable I think...

Is it something to do with the image manager on the server?

There are a lot of error messages as well.

Thanks in advance for any help...

2: rename(/home/iberian/public_html/gallery/0/23_12_03_08_8_47_31.jpg_thumb,/home/iberian/public_html/gallery/0/thumb_23_12_03_08_8_47_31.jpg) [<a href='function.rename'>function.rename</a>]: No such file or directory
File: /home/iberian/public_html/Sources/Gallery.php
Line: 1830

2: getimagesize(/home/iberian/public_html/gallery/0/23_12_03_08_8_47_31.jpg) [<a href='function.getimagesize'>function.getimagesize</a>]: failed to open stream: No such file or directory
File: /home/iberian/public_html/Sources/Subs-Graphics.php
Line: 242
   
2: move_uploaded_file() [<a href='function.move-uploaded-file'>function.move-uploaded-file</a>]: Unable to move '/tmp/phpZZ6CIS' to '/home/iberian/public_html/gallery/0/23_12_03_08_8_47_31.jpg'
File: /home/iberian/public_html/Sources/Gallery.php
Line: 1824

2: move_uploaded_file(/home/iberian/public_html/gallery/0/23_12_03_08_8_47_31.jpg) [<a href='function.move-uploaded-file'>function.move-uploaded-file</a>]: failed to open stream: Permission denied
File: /home/iberian/public_html/Sources/Gallery.php
Line: 1824

2: imagettftext() expects parameter 1 to be resource, string given
File: /home/iberian/public_html/Sources/Gallery.php
Line: 5156

2: imagecolorallocate(): supplied argument is not a valid Image resource
File: /home/iberian/public_html/Sources/Gallery.php
Line: 5125

8: Undefined index:
File: /home/iberian/public_html/Sources/Gallery.php
Line: 5106

Offline clive

  • Jr. Member
  • **
  • Posts: 76
    • View Profile
Re: image uploading but thumbnail not created
« Reply #1 on: March 12, 2008, 07:54:23 am »
HI,

as an update I just looked at the gallery files through cpanel and see that the directory named "0" is marked as an invalid file.

I thought that maybe my problem was one of permissions but I can't change the permissions of this directory whilst the server thinks it is invalid.

Also looking at the gallery directory I see there are around a hundred images in the gallery directory and the rest are in the directory named "0"

thanks for any help, I am going to have to turn off the gallery on my forum untill i get this sorted out.

Clive

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 16455
    • View Profile
Re: image uploading but thumbnail not created
« Reply #2 on: March 12, 2008, 07:33:58 pm »
Sounds like a permission issue with
Enable multiple folders for picture storage setting.

Try to disable that setting under Gallery Configuration settings and then try to upload an image and see if the thumbnail is generated.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline clive

  • Jr. Member
  • **
  • Posts: 76
    • View Profile
Re: image uploading but thumbnail not created
« Reply #3 on: March 18, 2008, 01:14:14 pm »
Hi,

Thanks for the reply. Yes it was a permissions problem that happened after my host upgraded the PHP version on the server.

That was a very good tip to check the multiple folders setting.

Thank you very much for an excellent gallery system :)

Clive

 

Related Topics

  Subject / Started by Replies Last post
0 Replies
4451 Views
Last post December 02, 2007, 07:46:28 pm
by Lil Puppy
1 Replies
4232 Views
Last post May 31, 2009, 08:45:20 pm
by SMFHacks
Fatal error uploading image

Started by guest3817 Support

6 Replies
5301 Views
Last post September 23, 2009, 06:02:42 pm
by SMFHacks
0 Replies
2470 Views
Last post August 16, 2011, 07:38:55 am
by cosmicx
0 Replies
3772 Views
Last post March 06, 2013, 10:26:47 pm
by jackjack

+- Recent Topics

Pretty Urls extras by SMFHacks
May 13, 2024, 10:28:54 am

Mod question by Verrick
May 11, 2024, 02:42:50 pm

i have paid but cant download ad pro. by SMFHacks
May 02, 2024, 11:29:38 pm

Please Help! by SMFHacks
April 17, 2024, 08:04:55 am

Rate own images by fvlog19
April 11, 2024, 10:56:53 am

Tidy Child Boards on 2.1.4 by SMFHacks
April 04, 2024, 03:54:12 pm

Problems SMF 2.0.19 > 2.1.4 SMF Gallery Pro - Recents Images to overall header by Michel68
March 30, 2024, 12:41:08 pm

Can't DROP 'id_member'; check that column/key exists Datei: by SMFHacks
March 30, 2024, 11:58:20 am

No thumbnails on new uploads by Tonyvic
March 29, 2024, 06:26:18 am

Display the Contact Page for guests by SMFHacks
March 27, 2024, 10:55:43 am

Powered by EzPortal