Facebook  Twitter 

SMFHacks.com

+-

SMFHacks.com

+- User Information

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Forum Stats

Members
Total Members: 11833
Latest: playwyourlifenotme
New This Month: 1
New This Week: 1
New Today: 1
Stats
Total Posts: 42303
Total Topics: 7379
Most Online Today: 116
Most Online Ever: 2482
(April 09, 2011, 07:02:45 pm)
Users Online
Members: 0
Guests: 31
Total: 31

Author Topic: Undefined Index - Error Messages in Forum Error log  (Read 6856 times)

0 Members and 1 Guest are viewing this topic.

Offline RoFus

  • Member
  • *
  • Posts: 2
    • View Profile
Undefined Index - Error Messages in Forum Error log
« on: May 07, 2008, 01:22:42 pm »
Hi,

I installed Gallery Pro and it works fine appart of some issue that fills the Forum Error log with error messages of the type:

8: Undefined index: smfgallery_menu
Datei: /var/www/html/smf/Themes/default/Display.template.php (eval?)
Zeile: 578


I found a similar topic on this here: http://www.smfhacks.com/index.php/topic,545.0.html - checked the Subs.php file for the line:

$context['allow_smfgallery_view'] = allowedTo('smfgallery_view');, which I found to be present.

I am using SMF 1.1.5 - with Mods: SMF Gallery Pro 1.3.21. + User Email System 1.3. + German Language Pack

Thanks
Romain

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 16037
    • View Profile
Re: Undefined Index - Error Messages in Forum Error log
« Reply #1 on: May 07, 2008, 06:58:38 pm »
It is most likely caused by your language make sure it is defined in

Themes/default/languages/modifications.yourlanguage.php

Something like
Code: [Select]
$txt['smfgallery_menu'] = 'Gallery';
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline RoFus

  • Member
  • *
  • Posts: 2
    • View Profile
Re: Undefined Index - Error Messages in Forum Error log
« Reply #2 on: May 09, 2008, 02:33:12 pm »
great   :D

I copied the content related to Gallery from the english file version into the german file version. that solved it.

thank's for your help

 

Related Topics

  Subject / Started by Replies Last post
1 Replies
4626 Views
Last post March 27, 2008, 07:08:11 pm
by SMFHacks
2 Replies
6251 Views
Last post November 02, 2009, 07:56:57 am
by Vincent Volmer
4 Replies
3574 Views
Last post February 15, 2013, 01:06:23 pm
by CWVRV
2 Replies
3582 Views
Last post June 03, 2014, 12:11:06 pm
by spikeweb
6 Replies
2584 Views
Last post November 21, 2017, 04:13:18 pm
by eliot

+- Recent Topics

Trying to access array offset on value of type null by SMFHacks
Today at 03:58:54 pm

SMF forum by davejo
June 27, 2022, 01:16:25 am

Quick-moderation checkboxes by davejo
June 22, 2022, 09:27:24 am

Add option to Main Menu bar by Shades
June 21, 2022, 12:23:00 am

Logo and Category? by SMFHacks
June 12, 2022, 03:43:31 pm

prettyurls - TroubleShooting.wiki by GhostHunting
June 12, 2022, 02:52:57 pm

[Mod]Modification Update Version Checker by SMFHacks
June 06, 2022, 09:25:39 pm

Profile Gallery Link by SMFHacks
June 02, 2022, 05:17:45 pm

SMF Store 5.0 Beta Errors - Trying to access array offset on value of type null by Michael Vail
June 01, 2022, 12:48:48 pm

Upgrade Issues? by SMFHacks
May 30, 2022, 06:24:03 pm

Powered by EzPortal