Facebook  Twitter 

SMFHacks.com

+-

SMFHacks.com

+- User Information

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Forum Stats

Members
Total Members: 4260
Latest: Verrick
New This Month: 3
New This Week: 0
New Today: 0
Stats
Total Posts: 43301
Total Topics: 7525
Most Online Today: 119
Most Online Ever: 2482
(April 09, 2011, 07:02:45 pm)
Users Online
Members: 0
Guests: 189
Total: 189

Author Topic: Undefined Index - Error Messages in Forum Error log  (Read 16634 times)

0 Members and 1 Guest are viewing this topic.

Offline RoFus

  • Member
  • *
  • Posts: 2
    • View Profile
Undefined Index - Error Messages in Forum Error log
« on: May 07, 2008, 01:22:42 pm »
Hi,

I installed Gallery Pro and it works fine appart of some issue that fills the Forum Error log with error messages of the type:

8: Undefined index: smfgallery_menu
Datei: /var/www/html/smf/Themes/default/Display.template.php (eval?)
Zeile: 578


I found a similar topic on this here: http://www.smfhacks.com/index.php/topic,545.0.html - checked the Subs.php file for the line:

$context['allow_smfgallery_view'] = allowedTo('smfgallery_view');, which I found to be present.

I am using SMF 1.1.5 - with Mods: SMF Gallery Pro 1.3.21. + User Email System 1.3. + German Language Pack

Thanks
Romain

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 16455
    • View Profile
Re: Undefined Index - Error Messages in Forum Error log
« Reply #1 on: May 07, 2008, 06:58:38 pm »
It is most likely caused by your language make sure it is defined in

Themes/default/languages/modifications.yourlanguage.php

Something like
Code: [Select]
$txt['smfgallery_menu'] = 'Gallery';
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline RoFus

  • Member
  • *
  • Posts: 2
    • View Profile
Re: Undefined Index - Error Messages in Forum Error log
« Reply #2 on: May 09, 2008, 02:33:12 pm »
great   :D

I copied the content related to Gallery from the english file version into the german file version. that solved it.

thank's for your help

 

Related Topics

  Subject / Started by Replies Last post
1 Replies
5758 Views
Last post March 27, 2008, 07:08:11 pm
by SMFHacks
2 Replies
7372 Views
Last post November 02, 2009, 07:56:57 am
by Vincent Volmer
4 Replies
4838 Views
Last post February 15, 2013, 01:06:23 pm
by CWVRV
2 Replies
4909 Views
Last post June 03, 2014, 12:11:06 pm
by spikeweb
6 Replies
4744 Views
Last post November 21, 2017, 04:13:18 pm
by eliot

+- Recent Topics

Pretty Urls extras by SMFHacks
May 13, 2024, 10:28:54 am

Mod question by Verrick
May 11, 2024, 02:42:50 pm

i have paid but cant download ad pro. by SMFHacks
May 02, 2024, 11:29:38 pm

Please Help! by SMFHacks
April 17, 2024, 08:04:55 am

Rate own images by fvlog19
April 11, 2024, 10:56:53 am

Tidy Child Boards on 2.1.4 by SMFHacks
April 04, 2024, 03:54:12 pm

Problems SMF 2.0.19 > 2.1.4 SMF Gallery Pro - Recents Images to overall header by Michel68
March 30, 2024, 12:41:08 pm

Can't DROP 'id_member'; check that column/key exists Datei: by SMFHacks
March 30, 2024, 11:58:20 am

No thumbnails on new uploads by Tonyvic
March 29, 2024, 06:26:18 am

Display the Contact Page for guests by SMFHacks
March 27, 2024, 10:55:43 am

Powered by EzPortal