Facebook  Twitter 

SMFHacks.com

+- +-

SMFHacks.com

+- User Information

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Forum Stats

Members
Total Members: 12375
Latest: scuzzy
New This Month: 2
New This Week: 1
New Today: 0
Stats
Total Posts: 40218
Total Topics: 7083
Most Online Today: 85
Most Online Ever: 2482
(April 09, 2011, 07:02:45 pm)
Users Online
Members: 0
Guests: 23
Total: 23

Author Topic: Problem opening links from newsletter  (Read 6551 times)

0 Members and 1 Guest are viewing this topic.

Offline hughsmm

  • Bad Emails DO NOT EMAIL
  • Newbie
  • *
  • Posts: 5
    • View Profile
    • Windows into Mystery
Problem opening links from newsletter
« on: July 16, 2008, 05:24:07 pm »
I have been quite impressed with how easy this mod has been to configure and use.  Newsletter composition has been a fairly straightforward and pleasant task.

However, in my test runs at composing and sending sample newsletters I've found myself unable to successfully open links that have been included in the newsletter.  When a link is clicked, it opens an error page on my host's server.  The error is as follows:

Quote
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, -n- and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Any insight on how to resolve this would be greatly appreciated.  I am running SMF 1.1.5 with TP installed as well as SMFGallery Pro and NewsletterPro.



A Quick Edit - The links I have been trying to open are links back to my SMF installation.  I have not yet tried links to external sites.
« Last Edit: July 16, 2008, 05:50:53 pm by hughsmm »

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15109
    • View Profile
Re: Problem opening links from newsletter
« Reply #1 on: July 16, 2008, 07:57:09 pm »
I would need to see a couple sample links from the mail itself.

One idea for the "Internal Server Error" is to check the permission on
newstracking.php  which is located in the root folder of your forum and make sure the permission is at least 755
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline hughsmm

  • Bad Emails DO NOT EMAIL
  • Newbie
  • *
  • Posts: 5
    • View Profile
    • Windows into Mystery
Re: Problem opening links from newsletter
« Reply #2 on: July 17, 2008, 04:48:18 pm »
Thank you for the prompt reply.  A quick look at the permissions revealed that newstracker.php was set to 644.  I've changed the permissions to 755 and will try to send out another test newsletter later this evening to see if that solves the problem.

Offline hughsmm

  • Bad Emails DO NOT EMAIL
  • Newbie
  • *
  • Posts: 5
    • View Profile
    • Windows into Mystery
Re: Problem opening links from newsletter
« Reply #3 on: July 17, 2008, 08:53:28 pm »
Follow Up - A quick test resulted in my being able to successfully open a link back to the site.  It looks like changing the permissions did the trick.

Thank you very much for the help.

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15109
    • View Profile
Re: Problem opening links from newsletter
« Reply #4 on: July 17, 2008, 09:25:26 pm »
Thanks good to know that the permissions fixed it.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

 

Related Topics

  Subject / Started by Replies Last post
0 Replies
3419 Views
Last post October 30, 2006, 07:01:36 pm
by wisebryce
5 Replies
9580 Views
Last post September 10, 2011, 06:42:19 pm
by SMFHacks
2 Replies
3087 Views
Last post April 18, 2013, 08:08:35 pm
by MaryLou
1 Replies
2194 Views
Last post April 13, 2015, 04:26:13 pm
by SMFHacks
19 Replies
5860 Views
Last post April 03, 2016, 09:26:03 pm
by SMFHacks

+- Recent Topics

Download System Lite by Rock Lee
June 03, 2020, 07:34:24 pm

Font question by SMFHacks
May 27, 2020, 08:15:26 am

Error message with latest SMF 2.1 Github build by Hatshepsut
May 25, 2020, 01:43:26 am

smfblog not working on 2.0.17 by tech9
May 20, 2020, 01:44:34 pm

Copyright removal by stbc
May 18, 2020, 01:27:57 am

Mod Verified User i can't square the image by Rock Lee
May 07, 2020, 07:56:10 pm

SMF4Mobile 2.0 released for SMF 2.0.x by SMFHacks
May 06, 2020, 12:13:14 pm

SMF Social Login Pro - Discontinued? by Nicole
May 02, 2020, 05:47:04 pm

Likes by SMFHacks
April 30, 2020, 09:50:35 pm

Upgrade Issue - by SMFHacks
April 28, 2020, 12:40:13 pm

Powered by EzPortal