Facebook  Twitter 

SMFHacks.com

+- +-

SMFHacks.com

+- User Information

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Forum Stats

Members
Total Members: 11795
Latest: LaurieluvsGH
New This Month: 1
New This Week: 0
New Today: 0
Stats
Total Posts: 41468
Total Topics: 7262
Most Online Today: 79
Most Online Ever: 2482
(April 09, 2011, 07:02:45 pm)
Users Online
Members: 0
Guests: 31
Total: 31

Author Topic: Board structure corrupt: unable to find parent board  (Read 3841 times)

0 Members and 1 Guest are viewing this topic.

Offline timandrew

  • Member
  • *
  • Posts: 8
    • View Profile
Board structure corrupt: unable to find parent board
« on: February 22, 2009, 09:29:33 am »
Hi - following on from this old topic which described the problem but doesn't fix it for me
http://www.smfhacks.com/index.php/topic,2960.0.html
Quote
Edit that category and check to make sure that board parent still exists.
Mostly like you had posting enabled to a forum on an upload and then that board was deleted which resulted in that error.

I have a similar problem, but just with the standard Pro setup (v 1.3.10 on SMF 1.1.7 )

" Board structure corrupt: unable to find parent board "

My gallery is very simple: I have 6 categories (1 of which has a sub-catagory) and user galleries (2 only so far!)

if I edit each category to find the parent board I have to choose "none" in the drop down menu as most are on top level. I just can't remember if I started with a parent and then changed my mind, thus causing the problem!

How do I fix the problem without starting from scratch or messing up the links to images from messageboard posts? Thanks

ps I can access the database via Navicat app if necessary

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15689
    • View Profile
Re: Board structure corrupt: unable to find parent board
« Reply #1 on: February 22, 2009, 09:53:09 am »
When does this error appear and on what page?

Trying running admin -> forum maintenance -> find and repair any errors.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline timandrew

  • Member
  • *
  • Posts: 8
    • View Profile
Re: Board structure corrupt: unable to find parent board
« Reply #2 on: February 22, 2009, 10:32:13 am »
Thanks for prompt reply
Running "find and repair any errors" didn't fix it

I click on "add a picture" on all main categories, fill in boxes and browse for photo, then click "add picture" and get the error warning on a new error page. If I add a photo from a member gallery or a subcategory then I don't get an error. I suspect that I might have originally installed the gallery, and put all the categories under one main category, then decided change this to having all the categories at top level, but i just can't remember!

Interestingly, despite the error, photos DO get added, but the images total doesn't increase/increment ( this must put off users). If I use the "Bulk add pictures" option photos don't seem to go on and I get the same error message. What else could I try?


Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15689
    • View Profile
Re: Board structure corrupt: unable to find parent board
« Reply #3 on: February 22, 2009, 01:17:36 pm »
Ok. I think I know what it is double check by editing each category and see if you are posting new pictures to a forum as a topic. If so check that forum still exists or if you do not want it to post just set to blank.

This is probably causing the error since you are trying to post a topic to a board that no longer exists.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline timandrew

  • Member
  • *
  • Posts: 8
    • View Profile
Re: Board structure corrupt: unable to find parent board
« Reply #4 on: February 22, 2009, 02:51:49 pm »
Bingo! I'm not posting a topic to boards, but after your suggestion I tried unchecking "Show link to main image page" + " image in posted topic" and that solved the error problem. re-checking it did not make the error return. I still have incorrect totals of images but it is incrementing the total. I'm not going to lose any sleep over that though!

 

Related Topics

  Subject / Started by Replies Last post
1 Replies
2695 Views
Last post April 20, 2008, 09:49:07 am
by SMFHacks
5 Replies
5104 Views
Last post September 09, 2008, 08:16:27 am
by RAPPING CAPTAIN
1 Replies
3539 Views
Last post June 05, 2009, 10:58:43 pm
by Giovan
1 Replies
3340 Views
Last post February 21, 2011, 07:25:49 pm
by SMFHacks
15 Replies
6697 Views
Last post August 19, 2012, 06:11:22 am
by BSD2000

+- Recent Topics

Question (Gallery Pro) by mickjav
Today at 11:59:10 am

Image View by SMFHacks
October 14, 2021, 11:55:21 am

From SMF Gallery Lite to SMF Gallery Pro by SMFHacks
October 11, 2021, 08:00:29 am

Picture Orientation by mickjav
October 09, 2021, 01:25:54 pm

4. Global Headers and Footers by mickjav
October 07, 2021, 12:22:09 am

S3 System For SMF Attachments by shuban
October 06, 2021, 07:58:50 am

Download Page images by mickjav
October 04, 2021, 01:28:07 pm

Agree To Licence by mickjav
October 03, 2021, 10:00:27 am

Install Problems by mickjav
October 01, 2021, 01:33:14 pm

Can SMF2WPBridge bridge SMF membergroups into WP? by SMFHacks
September 30, 2021, 02:07:34 pm

Powered by EzPortal