Facebook  Twitter 

SMFHacks.com

+- +-

SMFHacks.com

+- User Information

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Forum Stats

Members
Total Members: 12404
Latest: azaratir
New This Month: 10
New This Week: 0
New Today: 0
Stats
Total Posts: 39925
Total Topics: 7028
Most Online Today: 35
Most Online Ever: 2482
(April 09, 2011, 07:02:45 pm)
Users Online
Members: 0
Guests: 31
Total: 31

Author Topic: Image attachment problem  (Read 12866 times)

0 Members and 1 Guest are viewing this topic.

Offline Paddleducks Forum - Damien

  • Full Member
  • ***
  • Posts: 161
    • View Profile
Image attachment problem
« on: May 08, 2009, 01:48:04 am »
I've tried and tried to get an image to attach to a file in Downloads Pro, but the image is never shown.... It's an image that is less than 40Kb, so it should be fine - No error is generated, it's just that the image is never shown, and I cannot find it stored anywhere when I check the directories.

The file was uploaded using FTP and I then edited the upload to attach the image, mybe a bug if the file was FTP'd??

This is using Downloads Pro v1.0.1

Has anyone else had a problem with attached images?

regards
Eddy

Offline propyl

  • Full Member
  • ***
  • Posts: 154
    • View Profile
Re: Image attachment problem
« Reply #1 on: May 08, 2009, 08:10:57 am »
update to 1.0.2 no troubles.

Offline Paddleducks Forum - Damien

  • Full Member
  • ***
  • Posts: 161
    • View Profile
Re: Image attachment problem
« Reply #2 on: May 08, 2009, 12:21:57 pm »
update to 1.0.2 no troubles.

Nope, exactly the same problem Propyl - No image is attached to the download :(

Something to do with mod_security maybe? There is no error generated, so I'm just grasping at straws!

Regards
Eddy

Offline propyl

  • Full Member
  • ***
  • Posts: 154
    • View Profile
Re: Image attachment problem
« Reply #3 on: May 08, 2009, 02:07:06 pm »
ahhh could be ,bud.

I dont have the mod security installed myself but I do know that it does normally work under 1.0.2 for certain so you're probably very right.

Hopefully hacks can get ya squared away.

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 14969
    • View Profile
Re: Image attachment problem
« Reply #4 on: May 08, 2009, 07:40:59 pm »
Fixed for 1.0.3
!Fixed when editing a download if there is an error with the image that is uploaded redirects to image error page with the reason why it failed after the upload is edited.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline Paddleducks Forum - Damien

  • Full Member
  • ***
  • Posts: 161
    • View Profile
Re: Image attachment problem
« Reply #5 on: May 09, 2009, 02:33:59 am »
I now get an error saying "Unable to load the 'main' template" after trying to upload an image......

Having said that, there is an error when I install Download Pro, it's unable to edit the index.template file within SMF - Could that be the cause? I ignored it as I don't want it to add a button to the SMF index page, I prefer to have a seperate link within MKPortal to access Download Pro.... Hope that makes sense?

If you think the error is related to the index.template file, what changes can I make manually to correct the problem?

Regards
Eddy

Offline Vincent Volmer

  • Hero Member
  • *****
  • Posts: 505
  • SMF 2.0.1
    • View Profile
    • Digiscrap.nl
Re: Image attachment problem
« Reply #6 on: May 09, 2009, 07:08:34 am »
I now get an error saying "Unable to load the 'main' template" after trying to upload an image......


If the dimensions of the image are bigger than the maximum, as declared in the Downloads settings, you get the same error. Don't know if we're talking about the same issue? See this topic: http://www.smfhacks.com/index.php/topic,3518.0.html

Vincent

Offline Paddleducks Forum - Damien

  • Full Member
  • ***
  • Posts: 161
    • View Profile
Re: Image attachment problem
« Reply #7 on: May 09, 2009, 08:30:43 am »
That's it Vincent!!

Many thanks....

Though it's still a bug as the settings say that an image larger than the maximum height/width should be resized, so obviously Downloads pro isn't resizing images as it's supposed to?

Regards
Eddy

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 14969
    • View Profile
Re: Image attachment problem
« Reply #8 on: May 09, 2009, 09:29:02 am »
I believed fixed both issues redirection to the error page and attempting to resize an uploaded image fixed in 1.0.3.1
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline Vincent Volmer

  • Hero Member
  • *****
  • Posts: 505
  • SMF 2.0.1
    • View Profile
    • Digiscrap.nl
Re: Image attachment problem
« Reply #9 on: May 09, 2009, 10:05:24 am »
I believed fixed both issues redirection to the error page and attempting to resize an uploaded image fixed in 1.0.3.1

It isn't fixed I'm afraid..... but the error message in the log has changed:

Code: [Select]
URL  http://digiscrap.nl/index.php?action=downloads&sa=add2
Kan template 'main' niet laden. ("Unable to load the 'main' template")

Original post: http://www.smfhacks.com/index.php/topic,3518.0.html

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 14969
    • View Profile
Re: Image attachment problem
« Reply #10 on: May 09, 2009, 10:58:48 am »
Fixed in 1.0.3.2
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline Vincent Volmer

  • Hero Member
  • *****
  • Posts: 505
  • SMF 2.0.1
    • View Profile
    • Digiscrap.nl
Re: Image attachment problem
« Reply #11 on: May 09, 2009, 11:18:13 am »
Fixed in 1.0.3.2

Thank you!
All is working fine now:  ;D

Quote
Errors with Image Uploaded
Image exceeds size requirements. Your height was: 768 Your width was: 1024

Thanks for the great downloads system!

Vincent

Offline Yannick95

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Image attachment problem
« Reply #12 on: May 31, 2011, 10:59:12 am »
Probleem is opgelost!
« Last Edit: May 31, 2011, 01:37:22 pm by Yannick95 »

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 14969
    • View Profile
Re: Image attachment problem
« Reply #13 on: May 31, 2011, 11:55:58 am »
Link to a page or site that the issue it occurs on
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline Yannick95

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Image attachment problem
« Reply #14 on: May 31, 2011, 12:25:39 pm »
Hello,

Probleem is opgelost!
« Last Edit: May 31, 2011, 01:37:07 pm by Yannick95 »

 

Related Topics

  Subject / Started by Replies Last post
1 Replies
6046 Views
Last post September 25, 2006, 08:11:46 am
by SMFHacks
1 Replies
4079 Views
Last post January 27, 2010, 06:56:57 pm
by SMFHacks
0 Replies
5318 Views
Last post April 12, 2010, 04:08:45 pm
by madman71
2 Replies
2982 Views
Last post August 18, 2014, 03:21:52 pm
by Michel68
0 Replies
1366 Views
Last post January 30, 2016, 11:25:29 pm
by SMFHacks

+- Recent Topics

Update detect mobile mode PHP5 to PHP7 by Rock Lee
November 16, 2019, 07:18:13 pm

PHP error by davejo
November 12, 2019, 12:09:47 pm

Message Editor Pro Issues by SMFHacks
November 06, 2019, 09:58:33 pm

most popular categories doesnt work by fussilet
November 02, 2019, 02:51:42 pm

Change colors of Halloween theme by SMFHacks
October 24, 2019, 11:44:59 am

prettyurls - TroubleShooting.wiki by Rock Lee
October 10, 2019, 11:37:09 am

Some issues with adding and editing a listing by ajac63
October 07, 2019, 04:16:40 am

Problem update 1.1.21 to 2.0.15 by Rock Lee
October 06, 2019, 06:09:16 pm

[Mod]SMF 2.0.x PHP 7.2 Support by sah62
October 04, 2019, 01:46:00 pm

Ideas by shuban
October 03, 2019, 10:19:06 pm

Powered by EzPortal