Facebook  Twitter 

SMFHacks.com

+- +-

SMFHacks.com

+- User Information

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Forum Stats

Members
Total Members: 11981
Latest: SaturnCeleste
New This Month: 7
New This Week: 2
New Today: 2
Stats
Total Posts: 38096
Total Topics: 6706
Most Online Today: 281
Most Online Ever: 2482
(April 09, 2011, 07:02:45 pm)
Users Online
Members: 0
Guests: 78
Total: 78

Author Topic: Cannot Move Pictures New Gallery Pro Beta and other issues  (Read 7775 times)

0 Members and 1 Guest are viewing this topic.

Offline filipina

  • Jr. Member
  • **
  • Posts: 94
    • View Profile
Hey hacks I have some problems and really hope you can assist.

1) When someone uploads a picture which is pending approval I cannot move it to another gallery. I click "edit" and get the new look you have, but when i choose the correct gallery with the arrow it jumps immediately back to the gallery I am trying to move it from and will not let me move the pic.

2) When I try to unapprove an image I get this

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'SELECTp.ID_MEMBER
FROM smf_gallery_pic AS p

WHERE p.ID_PICTURE = 10835 LI' at line 1
File: /xxxxx/xxxxx/public_html/penpal-community/Sources/Gallery.php
Line: 3363

Note: It appears that your database may require an upgrade. Your forum's files are currently at version SMF 1.1.9, while your database is at version 1.1.7. The above error might possibly go away if you execute the latest version of upgrade.php.


3) My error logs are filling up fast with these

Code: [Select]
8: Undefined index: smfgalleryprofile_viewall
File: /home/melin4/public_html/penpal-community/Themes/default/languages/Gallery.english.php (summary sub template - eval?)
Line: 444

8: Undefined index: smfgalleryprofile_title
File: /home/melin4/public_html/penpal-community/Themes/default/languages/Gallery.english.php (summary sub template - eval?)
Line: 433

2: Invalid argument supplied for foreach()
File: /home/melin4/public_html/penpal-community/Themes/default/Gallery.template.php (view_picture sub template - eval?)
Line: 881

8: Undefined index: buttons_set
File: /home/melin4/public_html/penpal-community/Themes/default/Gallery.template.php (view_picture sub template - eval?)
Line: 1898

8: Undefined index: buttons_set
File: /home/melin4/public_html/penpal-community/Themes/default/Gallery.template.php (view_picture sub template - eval?)
Line: 1265

4) The gallery main page is now taking about 10 seconds to open.

5) The video gallery has lost all the videos. I thought maybe I had to unistall and reinstall but when I go to unistall I see this and afraid to proceed

Execute Modification ./Themes/default/languages/Modifications.english.php Test failed
2. Execute Modification ./Themes/default/languages/Gallery.english.php Test successful
3. Execute Modification ./Sources/Gallery.php Test failed
4. Execute Modification ./Sources/Gallery.php Test failed
5. Execute Modification ./Themes/default/Gallery.template.php Test failed
6. Execute Modification ./Sources/ManagePermissions.php Test failed

Thanks for any assistance please :)
« Last Edit: July 10, 2009, 06:46:49 pm by filipina »

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 14116
    • View Profile
Re: Cannot Move Pictures New Gallery Pro Beta and other issues
« Reply #1 on: July 10, 2009, 08:00:37 pm »
I would uninstall and just install the official release for now. It will take me a while to fix any issues that poped up above.
Get your Forum Ranked! at http://www.forumrankings.net - find out how your forum compares with others! Also contests/promotions for verified sites.

Offline filipina

  • Jr. Member
  • **
  • Posts: 94
    • View Profile
Re: Cannot Move Pictures New Gallery Pro Beta and other issues
« Reply #2 on: July 10, 2009, 08:13:27 pm »
I would uninstall and just install the official release for now. It will take me a while to fix any issues that poped up above.

thanks hacks but I need to make sure I don't screw this up :) ... uninstall the upgrade and then install what official release? The last thing i see in my package manager is this below?

46. SMF Gallery Pro Upgrade 1.4.5         [ List Files ] [ Delete ]

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 14116
    • View Profile
Re: Cannot Move Pictures New Gallery Pro Beta and other issues
« Reply #3 on: July 10, 2009, 08:14:37 pm »
1.4.5  is the last one for SMF 1.1.x
Get your Forum Ranked! at http://www.forumrankings.net - find out how your forum compares with others! Also contests/promotions for verified sites.

Offline filipina

  • Jr. Member
  • **
  • Posts: 94
    • View Profile
Re: Cannot Move Pictures New Gallery Pro Beta and other issues
« Reply #4 on: July 10, 2009, 08:51:18 pm »
1.4.5  is the last one for SMF 1.1.x

ok thanks but one more thing please... i have rolled it back but my gallery button is gone... cannot see it as guest, member, or ADMIN, yet when I go to my index.template file and look inside it is showing in the code?

http://www.melindaspenpals.com/penpal-community/index.php?action=forum

Code: [Select]
// The [GoogleTagged] Button
echo ($current_action == 'tagged' || $context['browser']['is_ie4']) ? '<td class="maintab_active_' . $first . '">&nbsp;</td>' : '' , '
<td valign="top" class="maintab_' , $current_action == 'tagged' ? 'active_back' : 'back' , '">
<a href="', $scripturl, '?action=tagged">Tags</a>
</td>' , $current_action == 'tagged' ? '<td class="maintab_active_' . $last . '">&nbsp;</td>' : '';

// the [SMF Gallery] button
if ($context['allow_smfgallery_view'])
echo ($current_action == 'gallery' || $context['browser']['is_ie4']) ? '<td class="maintab_active_' . $first . '">&nbsp;</td>' : '' , '
<td valign="top" class="maintab_' , $current_action == 'gallery' ? 'active_back' : 'back' , '">
<a href="', $scripturl, '?action=gallery"><b>Gallery</b></a>
</td>' , $current_action == 'forum' ? '<td class="maintab_active_' . $last . '">&nbsp;</td>' : '';

// the [chat] button
if (!empty($modSettings['chatPopUp']))
echo '    <script type="text/javascript">
            function openWindow(url,width,height,options,name) {
                width = width ? width : 800;

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 14116
    • View Profile
Re: Cannot Move Pictures New Gallery Pro Beta and other issues
« Reply #5 on: July 10, 2009, 09:06:58 pm »
That looks good. Double check that is the correct file on the site.
Should be Themes/default/index.template.php
Get your Forum Ranked! at http://www.forumrankings.net - find out how your forum compares with others! Also contests/promotions for verified sites.

Offline filipina

  • Jr. Member
  • **
  • Posts: 94
    • View Profile
Re: Cannot Move Pictures New Gallery Pro Beta and other issues
« Reply #6 on: July 10, 2009, 09:27:00 pm »
hey hacks that is the bizzare thing.. it is showing in the Themes/default/index.template file, the code is there yet it has disappeared off my forum. I thought maybe it was a permissions issue but even as ADMIN the button is not showing since I uninstalled that beta  ???

i attached the file it is in there but not showing up anymore
« Last Edit: July 10, 2009, 09:29:44 pm by filipina »

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 14116
    • View Profile
Re: Cannot Move Pictures New Gallery Pro Beta and other issues
« Reply #7 on: July 10, 2009, 10:01:20 pm »
1. Fixed for next beta update
2. Fixed for next beta update
3 Looks like the profile images addon was uninstalled which resulted in those errors.
5. The video addon will need to be reinstalled after the beta upgrade.
« Last Edit: July 10, 2009, 10:35:43 pm by SMFHacks »
Get your Forum Ranked! at http://www.forumrankings.net - find out how your forum compares with others! Also contests/promotions for verified sites.

Offline filipina

  • Jr. Member
  • **
  • Posts: 94
    • View Profile
Re: Cannot Move Pictures New Gallery Pro Beta and other issues
« Reply #8 on: July 10, 2009, 10:12:39 pm »
Sounds great!  Now if my members could reach my gallery again I will be all set  ;D  So if the code for the button is obviously in the correct file, yet the gallery button does not appear anymore, then some problem must have happened... either that or I am over medicated  ;D

I am no expert here but could this be a language file, something went wrong with a permissions file, clueless here. 

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 14116
    • View Profile
Re: Cannot Move Pictures New Gallery Pro Beta and other issues
« Reply #9 on: July 10, 2009, 10:18:54 pm »
Try this file took out the permission check I think you are missing some code in Subs.php that does the context check
Get your Forum Ranked! at http://www.forumrankings.net - find out how your forum compares with others! Also contests/promotions for verified sites.

Offline filipina

  • Jr. Member
  • **
  • Posts: 94
    • View Profile
Re: Cannot Move Pictures New Gallery Pro Beta and other issues
« Reply #10 on: July 11, 2009, 12:47:04 am »
Try this file took out the permission check I think you are missing some code in Subs.php that does the context check

I found the problem in the Subs.php file as you thought it was missing

Code: [Select]
$context['allow_smfgallery_view'] = allowedTo('smfgallery_view');
Thanks Hacks... well I feel like I still have things out of wack because now it is showing the 1.3 version unistalled on the package manager and I am afraid to touch anything else. Maybe when this is out of beta if you have a few free minutes you could help me make sure I get this thing installed right. Thanks Hacks   


 

Related Topics

  Subject / Started by Replies Last post
3 Replies
3706 Views
Last post September 15, 2007, 10:30:22 pm
by rumboogy
1 Replies
2824 Views
Last post June 23, 2008, 07:10:29 pm
by SMFHacks
3 Replies
1669 Views
Last post June 13, 2011, 09:45:01 pm
by SMFHacks
6 Replies
1793 Views
Last post January 27, 2014, 10:12:16 am
by SMFHacks
1 Replies
2458 Views
Last post March 11, 2014, 11:50:29 pm
by SMFHacks

+- Recent Topics

Purchase Notification Email to Store Admins by scso1502
August 18, 2017, 05:22:42 pm

Won't install in ShelfLife theme. No code matching "Find" code. by ted245
August 11, 2017, 10:12:59 am

Image Linking Codes section missing after install by ted245
August 11, 2017, 08:31:52 am

please i need a programmer who can build this exact forum using smf by horlique
August 07, 2017, 09:03:25 am

Are SMFHack mods compatible with SMF 2.1? by SMFHacks
August 06, 2017, 07:56:38 am

Allow user to customize username and password by SMFHacks
August 04, 2017, 12:22:53 pm

Reset gallery by SMFHacks
August 03, 2017, 11:04:39 am

Members Can't create a Category to upload photos to by SMFHacks
August 02, 2017, 05:07:03 pm

Only post in own galleries by SMFHacks
August 01, 2017, 12:12:36 pm

Related Downloads by assemblytube
August 01, 2017, 09:55:23 am

Powered by EzPortal