Facebook  Twitter 

SMFHacks.com

+- +-

SMFHacks.com

+- User Information

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Forum Stats

Members
Total Members: 12370
Latest: laurieb
New This Month: 1
New This Week: 1
New Today: 0
Stats
Total Posts: 40210
Total Topics: 7081
Most Online Today: 162
Most Online Ever: 2482
(April 09, 2011, 07:02:45 pm)
Users Online
Members: 0
Guests: 29
Total: 29

Author Topic: Lighbox not working {Solved}  (Read 4927 times)

0 Members and 1 Guest are viewing this topic.

Offline Sweetwater

  • Full Member
  • ***
  • Posts: 128
    • View Profile
    • Sweetwater Fishing Australia
Lighbox not working {Solved}
« on: July 23, 2009, 07:43:12 am »
My light box in Store & also Classifieds is stalling half way thru openning up the image. Am getting complaints from customers about it. Have turned off the lightbox in the Store (not the most desirable option). There is no option to turn it off in SMF Classifieds.

Can SMF Hacks offer any assistance or advice on how to fix this??

THanks for any replies or assistance.

Sweetwater
« Last Edit: August 05, 2009, 09:09:08 am by Sweetwater »
SMF 2.0.9 | SMF Store 2.5.5 | SMF Classifieds 4.0.1 | SMF Gallery Pro + Video Add On
Home Page - http://sweetwaterfishing.com.au
Forum - http://sweetwaterfishing.com.au/Forum
Australian Lure Shop - http://australianlureshop.com.au
Australian Lure Fly & Outdoors Expo http://lureshow.com.au

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15105
    • View Profile
Re: Lighbox not working
« Reply #1 on: July 23, 2009, 07:56:01 am »
This is an issue with TinyPortal they are using another script on that page to cause

If that code is removed from tiny portal then the highslide will work again
Code: [Select]
<script type="text/javascript" src="http://www.sweetwaterfishing.com.au/Forum/tp-files/tp-plugins/javascript/mootools.js"></script>
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline Sweetwater

  • Full Member
  • ***
  • Posts: 128
    • View Profile
    • Sweetwater Fishing Australia
Re: Lighbox not working
« Reply #2 on: July 25, 2009, 03:49:14 am »
 I deleted the file & the problem with the images in Store & Classifieds is now solved.

Thankyou SMF Hacks.  ;D
 
Sweetwater...
SMF 2.0.9 | SMF Store 2.5.5 | SMF Classifieds 4.0.1 | SMF Gallery Pro + Video Add On
Home Page - http://sweetwaterfishing.com.au
Forum - http://sweetwaterfishing.com.au/Forum
Australian Lure Shop - http://australianlureshop.com.au
Australian Lure Fly & Outdoors Expo http://lureshow.com.au

Offline treasurenet

  • Newbie
  • *
  • Posts: 42
    • View Profile
Re: Lighbox not working
« Reply #3 on: July 25, 2009, 11:09:47 am »
Can someone tell me what the lightbox is supposed to do?  When I select it, and I click on an image, i just opens the image by itself...  I see no features.

Thanks.
Using SMF 1.1.10, Gallery Pro 2.5

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15105
    • View Profile
Re: Lighbox not working
« Reply #4 on: July 25, 2009, 11:31:31 am »
That's all it is meant to do really. Just show the enlarged image. Lightbox adds a black background.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline treasurenet

  • Newbie
  • *
  • Posts: 42
    • View Profile
Re: Lighbox not working
« Reply #5 on: July 26, 2009, 01:05:27 am »
Well, I think there's something wrong with 2.5's implementation.

When I select Lightbox, it does nothing...  the image is not centered, there's no black background...  nothing.  Just the image in a new window.

Looking at the source with Lightbox selected, I see that the lightbbox .js files are using the gallery path, not the gallery url to the .js files.

in other words....  in my case, it should be.... 

Code: [Select]
<script type="text/javascript" src="/gallery/js/scriptaculous.js?load=effects"></script>
<script type="text/javascript" src="/gallery/js/lightbox.js"></script>
<link rel="stylesheet" href="/gallery/css/lightbox.css" type="text/css" media="screen" />

and not how it currently is.....

Code: [Select]
<script type="text/javascript" src="/users/gallery/js/scriptaculous.js?load=effects"></script>
<script type="text/javascript" src="/users/gallery/js/lightbox.js"></script>
<link rel="stylesheet" href="/users/gallery/css/lightbox.css" type="text/css" media="screen" />

Where can I fix that?

Thanks.

Using SMF 1.1.10, Gallery Pro 2.5

Offline treasurenet

  • Newbie
  • *
  • Posts: 42
    • View Profile
Re: Lighbox not working
« Reply #6 on: July 26, 2009, 01:16:26 am »
Ah, found it myself.... 

In Gallery2.php  find....

Code: [Select]
// Using Lighbox
if ($modSettings['gallery_set_nohighslide'] == 2)
$context['html_headers'] .= '<script type="text/javascript" src="' . $modSettings['gallery_path'] . 'js/prototype.js"></script>
<script type="text/javascript" src="' . $modSettings['gallery_path'] . 'js/scriptaculous.js?load=effects"></script>
<script type="text/javascript" src="' . $modSettings['gallery_path'] . 'js/lightbox.js"></script>
<link rel="stylesheet" href="' . $modSettings['gallery_path'] . 'css/lightbox.css" type="text/css" media="screen" />';
   
Replace with....

Code: [Select]
// Using Lighbox
if ($modSettings['gallery_set_nohighslide'] == 2)
$context['html_headers'] .= '<script type="text/javascript" src="' . $modSettings['gallery_url'] . 'js/prototype.js"></script>
<script type="text/javascript" src="' . $modSettings['gallery_url'] . 'js/scriptaculous.js?load=effects"></script>
<script type="text/javascript" src="' . $modSettings['gallery_url'] . 'js/lightbox.js"></script>
<link rel="stylesheet" href="' . $modSettings['gallery_url'] . 'css/lightbox.css" type="text/css" media="screen" />';
   
      

In Gallery.php  find....   
      
Code: [Select]
// Using Lighbox
if ($modSettings['gallery_set_nohighslide'] == 2)
$context['html_headers'] .= '<script type="text/javascript" src="' . $modSettings['gallery_path'] . 'js/prototype.js"></script>
<script type="text/javascript" src="' . $modSettings['gallery_path'] . 'js/scriptaculous.js?load=effects"></script>
<script type="text/javascript" src="' . $modSettings['gallery_path'] . 'js/lightbox.js"></script>
<link rel="stylesheet" href="' . $modSettings['gallery_path']. 'css/lightbox.css" type="text/css" media="screen" />';

Replace with....

Code: [Select]
// Using Lighbox
if ($modSettings['gallery_set_nohighslide'] == 2)
$context['html_headers'] .= '<script type="text/javascript" src="' . $modSettings['gallery_url'] . 'js/prototype.js"></script>
<script type="text/javascript" src="' . $modSettings['gallery_url'] . 'js/scriptaculous.js?load=effects"></script>
<script type="text/javascript" src="' . $modSettings['gallery_url'] . 'js/lightbox.js"></script>
<link rel="stylesheet" href="' . $modSettings['gallery_url']. 'css/lightbox.css" type="text/css" media="screen" />';
Using SMF 1.1.10, Gallery Pro 2.5

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15105
    • View Profile
Re: Lighbox not working
« Reply #7 on: July 26, 2009, 08:50:53 am »
Nice catch fixed for next release
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

 

Related Topics

  Subject / Started by Replies Last post
3 Replies
4002 Views
Last post May 12, 2008, 10:25:18 pm
by SMFHacks
2 Replies
2528 Views
Last post March 28, 2010, 06:17:00 pm
by jacci
4 Replies
2396 Views
Last post December 24, 2010, 10:03:23 am
by G1
3 Replies
1818 Views
Last post May 29, 2011, 09:10:46 pm
by SMFHacks
0 Replies
644 Views
Last post January 14, 2019, 09:45:27 am
by Hurkulez

+- Recent Topics

Download System Lite by Rock Lee
June 03, 2020, 07:34:24 pm

Font question by SMFHacks
May 27, 2020, 08:15:26 am

Error message with latest SMF 2.1 Github build by Hatshepsut
May 25, 2020, 01:43:26 am

smfblog not working on 2.0.17 by tech9
May 20, 2020, 01:44:34 pm

Copyright removal by stbc
May 18, 2020, 01:27:57 am

Mod Verified User i can't square the image by Rock Lee
May 07, 2020, 07:56:10 pm

SMF4Mobile 2.0 released for SMF 2.0.x by SMFHacks
May 06, 2020, 12:13:14 pm

SMF Social Login Pro - Discontinued? by Nicole
May 02, 2020, 05:47:04 pm

Likes by SMFHacks
April 30, 2020, 09:50:35 pm

Upgrade Issue - by SMFHacks
April 28, 2020, 12:40:13 pm

Powered by EzPortal