Facebook  Twitter 

SMFHacks.com

+- +-

SMFHacks.com

+- User Information

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Forum Stats

Members
Total Members: 12374
Latest: LevelLord
New This Month: 1
New This Week: 0
New Today: 0
Stats
Total Posts: 40213
Total Topics: 7083
Most Online Today: 122
Most Online Ever: 2482
(April 09, 2011, 07:02:45 pm)
Users Online
Members: 0
Guests: 45
Total: 45

Author Topic: [Mod] RSS Feed Poster  (Read 198410 times)

0 Members and 1 Guest are viewing this topic.

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15106
    • View Profile
Re: [Mod] RSS Feed Poster
« Reply #180 on: January 28, 2012, 10:08:42 am »
You have to change permissions on the cronrss.php file to 755
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline edlogic

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: [Mod] RSS Feed Poster
« Reply #181 on: February 15, 2012, 07:38:51 pm »
thanks a lot !

i set up the mod and got everything working

a tip for cron job troubles - i used wget and the url of the feed and that worked in cpanel -
for my windows machine i got a gnu wget for windows and set it up in task scheduler to do the same thing

i just grabbed some test links and they all work fine but this one

http://www.npr.org/rss/rss.php?id=2

looks ok in web browser but when i try to set it into the edit feed

i get this error
XML error: syntax error at line 1

funny - if i put a space in front of the url - then it pauses for a few seconds then finishes without error but i get no feed from that url when the cron fires - i do not see any errors in the logs

is the edit attempting to verify the feed at the time i submit it and it is showing this error from trying to parse the return data ?  if so i wonder why browsers can retrieve with this url with no trouble

double funny - i have this set up on two web hosts using cpanel and on both of those i have this error - but i have it set up on my home windows 2008 computer and the url works fine as it is -

i have tried uninstalling and reinstalling the feed poster mod

i changed the field in the database and now it should be right - problem is - if i try to edit that feed - without making any change to it - i get the error again

the field in the db has the right url in it but the mod is not retrieving the feed for that url on the two web host smf installs - it is retrieving the other urls though

the smf install on my local windows machine is retrieving the feed with the same url and i don't get error when i edit that url

i don't see any errors in the log - maybe there is a different log somewhere

i can't figure why i would get the error on the two smf installs on the web host but not on the local  windows install -

i am a c++ and c# programmer but ii don't know how to debug php so i am stuck for now

i looked at the code a little bit and decided to try different download methods

i found that ONLY if i choose curl then i don't get any error when i edit that feed

i am getting feed posts on other url items so it is working for that but i haven't gotten one for the one item in question yet

i just got version 3.0.4 and still
i am not getting feeds for those two urls that are on the web hosts site
still getting xml error when i edit them
« Last Edit: February 23, 2012, 06:04:03 am by edlogic »

Offline Pertsa

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: [Mod] RSS Feed Poster
« Reply #182 on: March 04, 2012, 02:46:25 pm »
I have a problem with this mod.

Sometimes it posts only blank content, and there is no link or no HEADER. Sometimes it works fine.

http://salibandyforum.fi/index.php/board,11.0.html?PHPSESSID=6b039f4299885afebac7db75f4471663

What is the problem and how you would solve it?

Offline TheMortician4

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: [Mod] RSS Feed Poster
« Reply #183 on: June 13, 2012, 04:18:43 am »
I have been trying to get this mod to work since I began running SMF version 1.1.10. No matter what I do, I always seen to get this error:

XML error: Not well-formed (invalid token) at line 1

Feed Title:  TheMortician4's KickAss Torrents
Feed Url:  http://www.bbiclan.com/forum/index.php?type=rss;action=.xml
Forum:  Techie Corner > The Mortician4's Torrent Feed
Message Icon:   Standard
Poster Name   TheMortician4
Topic Prefix   
Update every x minutes   360
Number of items to import each update   20
Footer Append Text   
x   Feed Enabled
x   HTML Enabled
   Topic Locked




What am I doing wrong. There is now documentation thatr I have found or are aware of regarding the setup and troubleshooting of this mod.  Please help????
« Last Edit: June 13, 2012, 06:00:04 am by TheMortician4 »

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15106
    • View Profile
Re: [Mod] RSS Feed Poster
« Reply #184 on: June 13, 2012, 08:12:27 am »
The rss feed will need to be cleaned. I think you can clean it using http://feedburner.google.com

Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline graaywolf

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: [Mod] RSS Feed Poster
« Reply #185 on: June 13, 2012, 10:42:11 am »
ok 2 problems with the latest version...

#1. it doesn't post the latest feed which i talked about in another thread.
#2.  one of the feeds is posting backwards

besides that it's working ok...

graaywolf
-=(GW)=-
« Last Edit: June 13, 2012, 10:48:50 am by graaywolf »

Offline MrWizard

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: [Mod] RSS Feed Poster
« Reply #186 on: July 25, 2012, 10:24:20 pm »
Trying to get this mod up and running ..

I have a simple text file which I add RSS headers
when I manually run the cronrss.php script from within a webbrowser I get the following output

   Feed Poster Configuration

and nothing posts into the forum.   No errors, no nothing ...

SMF 1.1.16 ...

Where to start looking?

Offline gz06

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: [Mod] RSS Feed Poster
« Reply #187 on: December 07, 2012, 12:51:57 am »
Hi,
Installed rss feed poster version V 3.0 on smf 1.1.16 utf-8 (russian).
imported feeds from other utf-8 (russian) sites are not readable. it's comming unreadable letterd as "? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ?"
is any ways to help and how can i fix such problem?

##############

I see last post was July 25, 2012
anybody alive?? :)
« Last Edit: December 07, 2012, 10:03:29 am by gz06 »

Offline brel

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: [Mod] RSS Feed Poster
« Reply #188 on: December 26, 2012, 01:46:34 am »
I've just manually installed RSS Feed Poster by following instructions under http://custom.simplemachines.org/mods/index.php?mod=624 (Manual Install Instructions) for my SMF 1.1.2.  Now where can I access the interface to manage the feeds?  I can't seem to find RSS Feed Poster in my SMF Admin area.
« Last Edit: December 26, 2012, 01:48:57 am by brel »

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15106
    • View Profile
Re: [Mod] RSS Feed Poster
« Reply #189 on: December 26, 2012, 10:30:25 am »
It would be in the main admin sidebar on the left under RSS Feed Poster Configuration
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline bombnet

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: [Mod] RSS Feed Poster
« Reply #190 on: December 27, 2012, 03:45:03 am »
Hi,

this mode works great, but i got plenty of error logs from some feeds who doens't want to post.

version of smf 2.03 and rssfeedposter 3.04

it seems its a problem with port number 80 on some feeds

all the error logs are reffering to subs-rrs2.php line 435

$fp = fsockopen($url_array['host'], 80, $errno, $errstr, 30);
      if (!$fp)


first i thought it was a url problem so i try to change it

like this : the real url is without "http://" and without "www." i tried with "http://www." with "http://" and without and it doens't change anything

this is the error log i get:

http://www.powerfullinfo.com/index.php?wwwRedirect;news40=2900;PHPSESSID=bcea9525461d522623d463b66ff93261
Apply Filter: Only show the errors with the same message
2: fsockopen() [<a href='function.fsockopen'>function.fsockopen</a>]: unable to connect to :80 (php_network_getaddresses: getaddrinfo failed: No address associated with hostname)
Apply Filter: Only show the errors from this file
/Sources/Subs-RSS2.php
Line: 435

every error log is the same

any idea ?




Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15106
    • View Profile
Re: [Mod] RSS Feed Poster
« Reply #191 on: December 27, 2012, 08:41:34 am »
What is the feed url?
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline gz06

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: [Mod] RSS Feed Poster
« Reply #192 on: December 28, 2012, 01:06:20 pm »

Offline david_meyer24

  • Newbie
  • *
  • Posts: 19
    • View Profile
Re: [Mod] RSS Feed Poster
« Reply #193 on: November 12, 2014, 02:11:41 pm »
I get this error when I want to change something.

XML error: not well-formed (invalid token) at line 128

How do I get it just right.

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15106
    • View Profile
Re: [Mod] RSS Feed Poster
« Reply #194 on: November 12, 2014, 02:15:21 pm »
You have to clean the xml feed it is not well formed. Might look into https://pipes.yahoo.com/pipes/
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

 

Related Topics

  Subject / Started by Replies Last post
1 Replies
3051 Views
Last post February 28, 2013, 07:14:10 am
by simple_joe
2 Replies
3374 Views
Last post June 12, 2012, 12:37:28 pm
by graaywolf
0 Replies
6717 Views
Last post March 26, 2013, 03:18:47 am
by PyroTech03
3 Replies
3944 Views
Last post July 15, 2013, 01:21:24 pm
by SMFHacks
1 Replies
1398 Views
Last post February 03, 2016, 07:34:50 pm
by SMFHacks

+- Recent Topics

Download System Lite by Rock Lee
June 03, 2020, 07:34:24 pm

Font question by SMFHacks
May 27, 2020, 08:15:26 am

Error message with latest SMF 2.1 Github build by Hatshepsut
May 25, 2020, 01:43:26 am

smfblog not working on 2.0.17 by tech9
May 20, 2020, 01:44:34 pm

Copyright removal by stbc
May 18, 2020, 01:27:57 am

Mod Verified User i can't square the image by Rock Lee
May 07, 2020, 07:56:10 pm

SMF4Mobile 2.0 released for SMF 2.0.x by SMFHacks
May 06, 2020, 12:13:14 pm

SMF Social Login Pro - Discontinued? by Nicole
May 02, 2020, 05:47:04 pm

Likes by SMFHacks
April 30, 2020, 09:50:35 pm

Upgrade Issue - by SMFHacks
April 28, 2020, 12:40:13 pm

Powered by EzPortal