Facebook  Twitter 

SMFHacks.com

+- +-

SMFHacks.com

+- User Information

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Forum Stats

Members
Total Members: 12406
Latest: WesleyMathis
New This Month: 12
New This Week: 2
New Today: 2
Stats
Total Posts: 39931
Total Topics: 7030
Most Online Today: 120
Most Online Ever: 2482
(April 09, 2011, 07:02:45 pm)
Users Online
Members: 1
Guests: 101
Total: 102

Author Topic: Three errors 1.0.2 (Impressions link and more)  (Read 7009 times)

0 Members and 1 Guest are viewing this topic.

Offline Black Viper

  • Jr. Member
  • **
  • Posts: 50
    • View Profile
Three errors 1.0.2 (Impressions link and more)
« on: January 30, 2010, 01:55:02 pm »
This happens when I click the impressions link (with only click tracking checked):

hxxp://example.com/index.php?action=adpro;sa=viewviews&id=5
Undefined index: admin_menu_name
R:/Forum/Location/Edited/Sources/adseller2.php
Line: 2315

This is rolling errors that I am getting showing up. Two pages worth (30 errors) in 8 minutes, a set of three (for ID 3, 4, 5 for the three ads on each SSI main domain page) for each page access:

hxxp://example.com/index.php?action=adpro;sa=v&id=5&t=1264879950
Undefined index: l
File: R:/Location/Edited/Sources/adseller2.php
Line: 1880

This is the first in 12 minutes of the template errors (repeats 3 times per page for three different ad ID's on page) notice URL states "di" again:

Today at 12:10:40 pm
Type of error: Template
hxxp://example.com/index.php?action=adpro;sa=v&di=5&l=1002&m=0&t=1264882236
Unable to load the 'main' template.
« Last Edit: January 30, 2010, 02:14:20 pm by Black Viper »

Offline Black Viper

  • Jr. Member
  • **
  • Posts: 50
    • View Profile
Re: Three errors 1.0.2 (Impressions link and more)
« Reply #1 on: January 30, 2010, 02:25:34 pm »
25 minutes, 181 errors...
Not all page views.
In fact, I cannot duplicate anything but the first one (with me logged in as admin).
I cannot duplicate the 2nd and third with laptop running IE8 (no errors generated and ads display fine...
Will dig deeper if I don't fall asleep at keyboard.
Thanks.


Offline Black Viper

  • Jr. Member
  • **
  • Posts: 50
    • View Profile
Re: Three errors 1.0.2 (Impressions link and more)
« Reply #2 on: January 30, 2010, 02:41:35 pm »
The SSI call is like this:
Code: [Select]
<?php
require("r:\Forum\Path\SSI.php");
// Begin Ad Seller Pro Location - domain Top

global $sourcedir;
include_once 
$sourcedir "/adseller2.php";

$adSellerAdData =  ShowAdLocation(1000);
if (
$adSellerAdData != false)
{
echo 
'<div class="nagi">';
echo $adSellerAdData;
echo 
'<br /></div>';
}

// End Ad Seller Pro Location - domain Top
?>

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 14972
    • View Profile
Re: Three errors 1.0.2 (Impressions link and more)
« Reply #3 on: January 30, 2010, 10:42:39 pm »
1st minor fixed to ignore for next update
2nd added a check for that. That is used for location logging. That should always be passed no matter unless a search engine or bot got an old link or something.

3rd. That error is the mystery one it appears that something is rewriting the urls and for some reason sometimes it renames id= to di= instead....

Last the SSI looks fine the errors are all generated by the Sources/Adseller2.php area
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline Black Viper

  • Jr. Member
  • **
  • Posts: 50
    • View Profile
Re: Three errors 1.0.2 (Impressions link and more)
« Reply #4 on: January 30, 2010, 11:44:59 pm »
Only 14 template errors in the last 9 hours.
All with "di" in the URL.

BV EDIT: the second error is over a thousand

Offline Black Viper

  • Jr. Member
  • **
  • Posts: 50
    • View Profile
Re: Three errors 1.0.2 (Impressions link and more)
« Reply #5 on: January 31, 2010, 04:32:11 am »
In conjunction with the "di" in the urls, each has a matching template error stated above. Yet another example:

<IP> - - [31/Jan/2010:01:43:09 -0800] "GET /index.php?<PHPSESSIONIDHERE>&action=adpro;sa=v&di=4&l=1001&m=0&t=1264930985 HTTP/1.1" 200 2161 "<MY WEBSITE>" "Mozilla/5.0 (iPod; U; CPU iPhone OS 3_0 like Mac OS X; en-us) AppleWebKit/528.18 (KHTML, like Gecko) Version/4.0 Mobile/7A341 Safari/528.16"
<IP> - - [31/Jan/2010:01:43:12 -0800] "GET /index.php?<PHPSESSIONIDHERE>&action=adpro;sa=v&id=4&l=1001&m=0&t=1264930985 HTTP/1.1" 200 44 "<MY WEBSITE>" "Mozilla/5.0 (iPod; U; CPU iPhone OS 3_0 like Mac OS X; en-us) AppleWebKit/528.18 (KHTML, like Gecko) Version/4.0 Mobile/7A341 Safari/528.16"

The template error maybe generated because of the bad URL, but the referer is always my web site and not, say, a URL that is cached someplace.
Still could be a bad browser code or detection code,but I cannot figure out why it is being bad to begin with.
It may be on my end... but at least the generated errors for this particular issue is low.
Will investigate further and thanks for your time.

Offline Black Viper

  • Jr. Member
  • **
  • Posts: 50
    • View Profile
Re: Three errors 1.0.2 (Impressions link and more)
« Reply #6 on: January 31, 2010, 04:37:17 am »
I had "disable evaluation of templates" checked, so now I have it unchecked and will wait for another template error to see what happens. May be a few hours, though.

BV EDIT: I am pretty convinced that it may be a javascript browser detection issue or something on my part. Just ignore the "di" issue for now until I investigate further... I just need to find a way to replicate it on my end and see what happens. The undefined index is more of an issue for me right now anyway. Thanks again.
« Last Edit: January 31, 2010, 04:47:28 am by Black Viper »

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 14972
    • View Profile
Re: Three errors 1.0.2 (Impressions link and more)
« Reply #7 on: February 02, 2010, 01:07:26 pm »
I have the Undefined index: l fixed for next update as well so that should help a little
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline Black Viper

  • Jr. Member
  • **
  • Posts: 50
    • View Profile
Re: Three errors 1.0.2 (Impressions link and more)
« Reply #8 on: February 03, 2010, 04:16:52 am »
I have the Undefined index: l fixed for next update as well so that should help a little
Oddly enough, the index errors have went away. I cannot report exactly what I did to do this, but I am not complaining. :)
Thanks again!

Offline Black Viper

  • Jr. Member
  • **
  • Posts: 50
    • View Profile
Re: Three errors 1.0.2 (Impressions link and more)
« Reply #9 on: February 03, 2010, 09:26:25 am »
I have the Undefined index: l fixed for next update as well so that should help a little
Oddly enough, the index errors have went away. I cannot report exactly what I did to do this, but I am not complaining. :)
Thanks again!
I may have unchecked location tracking for this particular error to go away.

 

Related Topics

  Subject / Started by Replies Last post
18 Replies
11750 Views
Last post February 13, 2007, 07:31:20 pm
by wrcline
4 Replies
3839 Views
Last post December 04, 2007, 09:27:54 pm
by SMFHacks
2 Replies
3433 Views
Last post January 26, 2010, 11:41:56 am
by Black Viper
5 Replies
6684 Views
Last post February 03, 2010, 09:50:06 am
by Black Viper
2 Replies
2100 Views
Last post February 11, 2013, 10:42:46 am
by amwebby

+- Recent Topics

Responsive Layout by SMFHacks
November 19, 2019, 03:32:39 pm

German Translation missing in SMF 2.1R1 by SMFHacks
November 19, 2019, 02:38:42 pm

Unread items issue by SMFHacks
November 19, 2019, 10:07:32 am

Update detect mobile mode PHP5 to PHP7 by Rock Lee
November 16, 2019, 07:18:13 pm

PHP error by davejo
November 12, 2019, 12:09:47 pm

Message Editor Pro Issues by SMFHacks
November 06, 2019, 09:58:33 pm

most popular categories doesnt work by fussilet
November 02, 2019, 02:51:42 pm

Change colors of Halloween theme by SMFHacks
October 24, 2019, 11:44:59 am

prettyurls - TroubleShooting.wiki by Rock Lee
October 10, 2019, 11:37:09 am

Some issues with adding and editing a listing by ajac63
October 07, 2019, 04:16:40 am

Powered by EzPortal