Facebook  Twitter 

SMFHacks.com

+- +-

SMFHacks.com

+- User Information

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Forum Stats

Members
Total Members: 12358
Latest: KekoWorld
New This Month: 1
New This Week: 2
New Today: 0
Stats
Total Posts: 40085
Total Topics: 7058
Most Online Today: 59
Most Online Ever: 2482
(April 09, 2011, 07:02:45 pm)
Users Online
Members: 2
Guests: 41
Total: 43

Author Topic: Link Mod  (Read 6125 times)

0 Members and 1 Guest are viewing this topic.

Offline jacci

  • Jr. Member
  • **
  • Posts: 59
    • View Profile
    • maths made easy
Link Mod
« on: February 02, 2007, 07:47:16 am »
I have just installed the link mod and noticed that the link option only displays if your are logged in.

is there a way i can get this to show for guests as well?

I have copied the mod into my theme and not sure if i stuffed it up or that is just the way it is written.

http://www.pretendercentre.com/pretenderforum/index.php

tahnks

jacci

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15044
    • View Profile
Re: Link Mod
« Reply #1 on: February 02, 2007, 09:40:18 am »
Which option? Check permissions for the links mod. Admin -> Permissions they need to be set for every group.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline jacci

  • Jr. Member
  • **
  • Posts: 59
    • View Profile
    • maths made easy
Re: Link Mod
« Reply #2 on: February 02, 2007, 09:55:30 am »
Okay, i am not sure if i am just doign this wrong, just installed it and not all that familiar with mods.

I have set all the categories wiht all groups defined permissions, basically allowing everything except for guests to post a link.

Everything seems to be working very well, but if you go to the index page, in my row of buttons: Home, profile, gallery etc etc
the Link button only shows up when you are logged in. So no guests can actually get to the links.

the coding i used in my skin index.template.php, which seems to work fine for gallery (that button is showing up when not logged in) is:

Code: [Select]
// the [links] button
if ($context['allow_view_smflinks'])
echo '
<a href="', $scripturl, '?action=links">' , ($settings['use_image_buttons'] ? '<img src="' . $settings['images_url'] . '/' . $context['user']['language'] . '/links.gif" alt="' . $txt['smflinks_menu'] . '" style="margin: 2px 0;" border="0" />' : $txt['smflinks_menu']), '</a>', $context['menu_separator'];

for the gallery:
Code: [Select]
// the [SMF Gallery] button
if ($context['allow_smfgallery_view'])
echo '
<a href="', $scripturl, '?action=gallery">' , ($settings['use_image_buttons'] ? '<img src="' . $settings['images_url'] . '/' . $context['user']['language'] . '/gallery.gif" alt="' . $txt['smfgallery_menu'] . '" style="margin: 2px 0;" border="0" />' : $txt['smfgallery_menu']), '</a>', $context['menu_separator'];

thanks your help is greatly appreciated
jacci

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15044
    • View Profile
Re: Link Mod
« Reply #3 on: February 02, 2007, 09:57:31 am »
You need to give guests permissions to view the links and gallery.
Goto Admin -> Permissions Then modify each group and give them View Links and View Gallery permissions.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline jacci

  • Jr. Member
  • **
  • Posts: 59
    • View Profile
    • maths made easy
Re: Link Mod
« Reply #4 on: February 02, 2007, 10:13:53 am »
LMAO, *head desk*
thanks

now i feel like a complete idiot....  didnt even think to check in that permission setting area

that fixed it just fine

my excuse, poor as it is, is it is about 3am here and i have been doing this WAY too long today.

thank you sooooo much for your help.

Offline avidum

  • Newbie
  • *
  • Posts: 28
    • View Profile
Re: Link Mod
« Reply #5 on: February 14, 2007, 02:36:31 pm »
oops ignore.
« Last Edit: February 14, 2007, 02:38:38 pm by avidum »

 

Related Topics

  Subject / Started by Replies Last post
No link?

Started by Marshall « 1 2 » Support

16 Replies
7773 Views
Last post September 02, 2011, 03:19:32 pm
by Erik Hansen
2 Replies
2386 Views
Last post February 08, 2012, 03:46:49 am
by chinaren
3 Replies
3904 Views
Last post April 01, 2013, 10:57:38 am
by SMFHacks
9 Replies
7771 Views
Last post November 18, 2016, 01:51:12 pm
by elbeer
5 Replies
2759 Views
Last post March 28, 2017, 06:37:41 pm
by Darkshadow

+- Recent Topics

[Mod]SMF2WPBridge - Wordpress Login Bridge by SMFHacks
Today at 11:37:44 am

BUG Message Editor Pro1.0.5 by SMFHacks
Today at 09:18:50 am

Only variables should be passed by reference by Zaphod
April 02, 2020, 11:19:11 am

Cannot install Gallery Pro on SMF 2.1 RC2 by Hatshepsut
March 19, 2020, 12:55:00 am

Newbie questions by SMFHacks
March 08, 2020, 09:28:17 am

Update detect mobile mode PHP5 to PHP7 by Plus
March 05, 2020, 11:19:05 am

Just a hello by Plus
March 05, 2020, 11:05:56 am

Enotify Copyright Problem by SMFHacks
March 04, 2020, 09:21:09 pm

Cannot import by shawnb
March 02, 2020, 12:17:00 pm

Error message with latest SMF 2.1 Github build by Hatshepsut
March 01, 2020, 10:06:10 am

Powered by EzPortal