Facebook  Twitter 

SMFHacks.com

+-

SMFHacks.com

+- User Information

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Forum Stats

Members
Total Members: 4229
Latest: Ghost
New This Month: 0
New This Week: 0
New Today: 0
Stats
Total Posts: 43080
Total Topics: 7493
Most Online Today: 57
Most Online Ever: 2482
(April 09, 2011, 07:02:45 pm)
Users Online
Members: 1
Guests: 32
Total: 33

Author Topic: just installed and testing, this error came up  (Read 5701 times)

0 Members and 1 Guest are viewing this topic.

Offline bundabgergrum

  • Member
  • *
  • Posts: 12
    • View Profile
just installed and testing, this error came up
« on: July 12, 2011, 01:09:20 pm »
i get this error when trying to view a listing


Method Not Implemented

GET to /forum/index.php not supported.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


im sure my host has all the features to make classifieds work, can anyone help

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 16356
    • View Profile
Re: just installed and testing, this error came up
« Reply #1 on: July 12, 2011, 01:18:42 pm »
Issue may occur with mod_security if you can first contact your host to disable mod_security or check out this topic http://www.simplemachines.org/community/index.php?topic=34270.0 and follow the instructions.


If that does not work let me know have another workaround.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline bundabgergrum

  • Member
  • *
  • Posts: 12
    • View Profile
Re: just installed and testing, this error came up
« Reply #2 on: July 12, 2011, 01:24:06 pm »
thanks will give it a try when i get back from work.

will let you know how i go

Offline bundabgergrum

  • Member
  • *
  • Posts: 12
    • View Profile
Re: just installed and testing, this error came up
« Reply #3 on: July 13, 2011, 12:48:18 am »
just got back home and have now done one of the things in that link you suggested

did the phpinfo.php  file and checked it, no sign of mod_security in there so it musnt be turned on.


any other suggestions

screenshot below is the page just before i click on 1 of the items and then it goes to the error page. Everything in my forum works perfectly except this
« Last Edit: July 13, 2011, 12:52:04 am by bundabgergrum »

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 16356
    • View Profile
Re: just installed and testing, this error came up
« Reply #4 on: July 13, 2011, 08:36:55 am »
It's not part of php. If you want to a manually fix do the following:

Open Sources/Classifieds2.php
Find
Code: [Select]
;id=
Replace with
Code: [Select]
&id=

And

Open Themes/default/Classifieds2.template.php
Find
Code: [Select]
;id=
Replace with
Code: [Select]
&id=
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline bundabgergrum

  • Member
  • *
  • Posts: 12
    • View Profile
Re: just installed and testing, this error came up
« Reply #5 on: July 13, 2011, 01:08:29 pm »
works !!!!!!

thanks a lot

Offline pymenweb

  • Member
  • *
  • Posts: 3
    • View Profile
Same error in Store
« Reply #6 on: August 10, 2011, 11:00:34 am »
My problem was with the Store, I just change the same ;id by &id in default tamplate, works perfect.
Here is the hack: find all ;id occurrences at Themes/default/Store2.template.default and replace with &id

Cheers!  ;)

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 16356
    • View Profile
Re: just installed and testing, this error came up
« Reply #7 on: August 10, 2011, 12:29:11 pm »
And also your Sources/Store2.php

This is a mod_security issue though best way is to disable it if you can.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline darlenetruetta

  • Member
  • *
  • Posts: 1
    • View Profile
Re: just installed and testing, this error came up
« Reply #8 on: August 11, 2011, 08:35:37 am »
nice. i went through the same thing and disabled as suggested. cool.

Offline pymenweb

  • Member
  • *
  • Posts: 3
    • View Profile
Re: just installed and testing, this error came up
« Reply #9 on: August 16, 2011, 10:52:24 am »
Yes, I also checked it but Store2.php has already &id code, that's the reason I didn't mention on previous post... but you never now, if anyone else need this hack check both files in order to fix it all.

I take this option vs mod_security because some other apps could be affected, any way, every thing is ok with store!
Thanks!

And also your Sources/Store2.php

This is a mod_security issue though best way is to disable it if you can.

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 16356
    • View Profile
Re: just installed and testing, this error came up
« Reply #10 on: August 16, 2011, 11:13:51 am »
Yeah mod_security has a rule where they don't like ;id= in the url
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

 

Related Topics

  Subject / Started by Replies Last post
17 Replies
15104 Views
Last post January 23, 2007, 09:20:12 am
by ksshane
4 Replies
5832 Views
Last post March 10, 2007, 11:24:42 pm
by bsmity
0 Replies
11687 Views
Last post May 28, 2007, 05:06:15 pm
by SMFHacks
2 Replies
7999 Views
Last post May 14, 2008, 07:28:49 pm
by iturner5150
1 Replies
3675 Views
Last post September 06, 2008, 12:34:01 am
by SMFHacks

+- Recent Topics

Version 6.1.6 issues by SMFHacks
September 30, 2023, 07:54:52 am

Follow / Follower Mod? by SMFHacks
September 23, 2023, 08:44:44 am

Looking for a good video player by replayuk
September 23, 2023, 12:17:39 am

[Mod]Discord Web Hooks by SMFHacks
September 22, 2023, 03:57:28 pm

SMF 2.1.4 Search by Anmer
September 22, 2023, 01:55:15 pm

Error in thise mode by Ghost
September 15, 2023, 08:42:24 am

Gallery Selection List Order by mickjav
September 07, 2023, 12:46:31 pm

[Mod]Tidy Child Boards 2.0 by Norwinjose
September 02, 2023, 11:42:54 am

PrettyUrls SEO Pro: Unable to submit sitemap to google search conmsole by SMFHacks
August 31, 2023, 10:55:22 am

PrettyURL - SEO4SMF Rewrites? by SMFHacks
August 28, 2023, 06:35:33 pm

Powered by EzPortal