Facebook  Twitter 

SMFHacks.com

+-

SMFHacks.com

+- User Information

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Forum Stats

Members
Total Members: 4260
Latest: Verrick
New This Month: 3
New This Week: 0
New Today: 0
Stats
Total Posts: 43301
Total Topics: 7525
Most Online Today: 102
Most Online Ever: 2482
(April 09, 2011, 07:02:45 pm)
Users Online
Members: 0
Guests: 73
Total: 73

Author Topic: SMF Gallery Pro and tinyportal 1.0RC1  (Read 8180 times)

0 Members and 1 Guest are viewing this topic.

Offline marcabra

  • Member
  • *
  • Posts: 1
    • View Profile
SMF Gallery Pro and tinyportal 1.0RC1
« on: April 30, 2011, 03:18:10 am »
Hi

My problem is that all my panels in tinyportal disappears when i go into a category.
When i am still in main gallery page and when i look at pictures the panels is visible.
I want them to show always. Is there any settings to fix this?

regards

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 16455
    • View Profile
Re: SMF Gallery Pro and tinyportal 1.0RC1
« Reply #1 on: April 30, 2011, 03:57:44 pm »
Not sure I use an older version of Tiny Portal on this site. I would try asking on tiny portal support if they have any settings that may need to be changed or how it determines when panels or show or not.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline wildenborch

  • Member
  • *
  • Posts: 22
    • View Profile
Re: SMF Gallery Pro and tinyportal 1.0RC1
« Reply #2 on: July 13, 2011, 12:14:40 am »
I just noticed that this behaviour only appears when you are logged in!
As guest all panels are visable,

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 16455
    • View Profile
Re: SMF Gallery Pro and tinyportal 1.0RC1
« Reply #3 on: July 13, 2011, 08:16:32 pm »
It might be a permission you have to setup in tiny portal to make sure all panels are always visible. I think I had to the same on this site just check each membergroup has permission to view all panels.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline Lum-chan

  • Member
  • *
  • Posts: 8
  • Lum-chan is cute!
    • View Profile
    • The World of Urusei Yatsura's Lum
Re: SMF Gallery Pro and tinyportal 1.0RC1
« Reply #4 on: July 18, 2011, 04:53:30 pm »
This happens with SMF Gallery Lite (latest version) and TinyPortal 1.0RC2 too. I did check all settings but were unable to find something like mentioned before. The same goes for SMF Links but when logged-off the left panel stays hidden.

There are some settings to enable panels for options such as Search and Memberlist, but I'm unable to add things like Gallery, Links and such.

I'll see if I can find some useful info on Tinyportal.net and point them to this topic. Maybe over there thet may have a clue on how to fix this.
Lum-chan


Offline Lum-chan

  • Member
  • *
  • Posts: 8
  • Lum-chan is cute!
    • View Profile
    • The World of Urusei Yatsura's Lum
Re: SMF Gallery Pro and tinyportal 1.0RC1
« Reply #5 on: July 21, 2011, 08:56:20 am »
This is the thread on tinyportal.net I started.
http://www.tinyportal.net/index.php?topic=34242.0

I hope we can get somewhere to get this fixed (keeps fingers crossed)
Lum-chan


Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 16455
    • View Profile
Re: SMF Gallery Pro and tinyportal 1.0RC1
« Reply #6 on: July 21, 2011, 09:02:23 am »
Thanks for posting on TinyPortal will be good to know the solution!
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline Lum-chan

  • Member
  • *
  • Posts: 8
  • Lum-chan is cute!
    • View Profile
    • The World of Urusei Yatsura's Lum
Re: SMF Gallery Pro and tinyportal 1.0RC1
« Reply #7 on: September 22, 2011, 04:09:54 am »
At this moment no solution or reply form the team in that topic. I tried to add some new categories but it looks like it's doing this at random. I have no idea what is causing this. Is it possible for you to get in touch with the TP team as well? None of this happens when using SMF 1.x.x but only when using SMF 2.x.x

I just can't get my hands on this...

[edit]
I might have some extra info on this. I'll post the info here and at TP. But I'm not sure it's related but might give us and those at TP what might be causing this.
I'll be back after doing some testing with SMF Gallery Lite and SMF Links. Will give SMF Classifieds a go as well as it uses categories too.
[/edit]
« Last Edit: September 22, 2011, 06:08:09 am by Lum-chan »
Lum-chan


Offline Lum-chan

  • Member
  • *
  • Posts: 8
  • Lum-chan is cute!
    • View Profile
    • The World of Urusei Yatsura's Lum
Re: SMF Gallery Pro and tinyportal 1.0RC1
« Reply #8 on: September 23, 2011, 11:52:22 am »
It took me a complete afternoon to get my fingers at a temp solution. No I'm hoping the TP-Team can do something with this. As far as I know and can see, this would be a bug in TP but odd enough only with SMF Gallery/Links and probably Classifieds and Store as well. I didn't get this odd problem with other mods nor did I find anything useful which was related to this problem.

Anyway, I have found a workaround which did work for me an I hope it works for you guys too. It's now up to TP to find the what's and how's on this.

Explanation and temp solution here: http://www.tinyportal.net/index.php?topic=34242.msg275064#msg275064
Lum-chan


Offline Lum-chan

  • Member
  • *
  • Posts: 8
  • Lum-chan is cute!
    • View Profile
    • The World of Urusei Yatsura's Lum
Re: SMF Gallery Pro and tinyportal 1.0RC1
« Reply #9 on: January 17, 2012, 02:58:27 am »
Found a solution after all. The main problem (at least for me) is the defination of the panels shown in the Category. When you don't select the panels to be visible in the category (in TP) this will cause random missing panels in the output of each gallery category itself (in Gallery Lite).

So selecting the panels you want to be visible in the TP Categories is very important. Still I don;t know why this only happens with SMF Gallery (Lite/Pro) and your SMF Links mod. The above just might be the solution to all these problems (and perhaps for other mods which work with categories too).

This works for SMF 2.x.x and TP 1.0RCx. There never was a problem with SMF 1.1.x with any TP1.0RCx, thou.
Lum-chan


Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 16455
    • View Profile
Re: SMF Gallery Pro and tinyportal 1.0RC1
« Reply #10 on: January 17, 2012, 09:20:19 am »
Thanks for looking into the issue. This should be really helpful for anyone who also uses TinyPortal and runs into the same issue.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline Lum-chan

  • Member
  • *
  • Posts: 8
  • Lum-chan is cute!
    • View Profile
    • The World of Urusei Yatsura's Lum
Re: SMF Gallery Pro and tinyportal 1.0RC1
« Reply #11 on: January 19, 2012, 05:43:58 am »
Link below shows a fix in TP for use with SMF gallery

http://www.tinyportal.net/index.php?topic=34242.msg276667#msg276667

For the lazy people I have posted these fixes here below:

In TPortal.php find this:
Code: [Select]
function doTPcat()
{
//return if not quite a category
if(isset($_GET['action']) && $_GET['action'] == 'manageboards')
return;

Add after this:
Code: [Select]
if(isset($_GET['action']) && $_GET['action'] == 'gallery' && isset($_GET['cat']))
return;
if(isset($_GET['action']) && $_GET['action'] == 'links' && isset($_GET['cat']))
return;

This should do the trick!

Of course with thanks to IchBin of TinyPortal.net
Lum-chan


 

Related Topics

  Subject / Started by Replies Last post
11 Replies
15538 Views
Last post March 19, 2009, 05:21:59 pm
by Marian
2 Replies
5914 Views
Last post December 02, 2006, 08:25:09 pm
by Raven
12 Replies
33646 Views
Last post May 12, 2007, 12:06:23 pm
by brianjw
1 Replies
4612 Views
Last post September 04, 2007, 06:59:49 pm
by rumboogy
8 Replies
11535 Views
Last post May 31, 2009, 07:57:13 pm
by Cowboy Logic

+- Recent Topics

Pretty Urls extras by SMFHacks
May 13, 2024, 10:28:54 am

Mod question by Verrick
May 11, 2024, 02:42:50 pm

i have paid but cant download ad pro. by SMFHacks
May 02, 2024, 11:29:38 pm

Please Help! by SMFHacks
April 17, 2024, 08:04:55 am

Rate own images by fvlog19
April 11, 2024, 10:56:53 am

Tidy Child Boards on 2.1.4 by SMFHacks
April 04, 2024, 03:54:12 pm

Problems SMF 2.0.19 > 2.1.4 SMF Gallery Pro - Recents Images to overall header by Michel68
March 30, 2024, 12:41:08 pm

Can't DROP 'id_member'; check that column/key exists Datei: by SMFHacks
March 30, 2024, 11:58:20 am

No thumbnails on new uploads by Tonyvic
March 29, 2024, 06:26:18 am

Display the Contact Page for guests by SMFHacks
March 27, 2024, 10:55:43 am

Powered by EzPortal