Facebook  Twitter 

SMFHacks.com

+-

SMFHacks.com

+- User Information

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Forum Stats

Members
Total Members: 11803
Latest: VXP
New This Month: 2
New This Week: 0
New Today: 0
Stats
Total Posts: 41605
Total Topics: 7273
Most Online Today: 98
Most Online Ever: 2482
(April 09, 2011, 07:02:45 pm)
Users Online
Members: 0
Guests: 52
Total: 52

Author Topic: Undefined Index  (Read 11153 times)

0 Members and 1 Guest are viewing this topic.

Offline assemblytube

  • Member
  • *
  • Posts: 24
    • View Profile
    • AssemblyTube
Undefined Index
« on: November 30, 2012, 08:05:28 am »
I have just installed Badge Awards and like it a lot. Thank you.

Since the installation I have started getting lots of "Undefined Index" errors in the Error log of my forum.

A lot are like this and refer to Subs-Post.php

8: Undefined index: utf8
/forum/Sources/Subs-Post.php

But some refer to other files e.g.
8: Undefined index:
/forum/Themes/default/languages/PersonalMessage.english.php

I am relatively new to working with SMF and php files.

I cannot create the errors myself when I log in and use the forum as a regular member, but when some members log in they create up to 30 errors.
Is it likely that the installation of Badge Awards is linked to these new errors?
Any thoughts on where I should start looking to resolve the errors?
Thank you for any advice.

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15752
    • View Profile
Re: Undefined Index
« Reply #1 on: November 30, 2012, 10:30:16 am »
First thing we need to figure out is what line the error is on

Check out this topic on how to enable finding the correct line numbers
http://www.simplemachines.org/community/index.php?topic=290186.0
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline assemblytube

  • Member
  • *
  • Posts: 24
    • View Profile
    • AssemblyTube
Re: Undefined Index
« Reply #2 on: November 30, 2012, 11:14:50 am »
Thanks for the link to the post on Disabling Eval.

Just wondering.
I am using SMF 2.02. Does this set of instructions in the post you linked to, do the same as the following?

SMF Admin Server settings "Disable evaluation of templates" where there is a tick box.

I had this box ticked, and I get the errors stated on the original post.


Do I still need to use phpmyadmin and run a query on the database, or is ticking this box sufficient?
Thanks for your help.


Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15752
    • View Profile
Re: Undefined Index
« Reply #3 on: November 30, 2012, 11:22:24 am »
Not sure.

What I am looking for is the line number and filename so we can track where the exact errors are from.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline assemblytube

  • Member
  • *
  • Posts: 24
    • View Profile
    • AssemblyTube
Re: Undefined Index
« Reply #4 on: November 30, 2012, 11:57:56 am »
The error messages in detail are like this:

http://assemblytube.com/forum/index.php?action=forum
8: Undefined index: forum_name
File: /public_html/assemblytube.com/forum/Themes/default/languages/PersonalMessage.english.php
Line: 25

http://assemblytube.com/forum/index.php?action=forum
8: Undefined index: utf8
File: /public_html/assemblytube.com/forum/Sources/Subs-Post.php
Line: 217

http://assemblytube.com/forum/index.php?action=forum
8: Undefined index: utf8
File: /public_html/assemblytube.com/forum/Sources/Subs-Post.php
Line: 265

http://assemblytube.com/forum/index.php?action=forum
8: Undefined index: utf8
File: /public_html/assemblytube.com/forum/Sources/Subs-Post.php
Line: 267

Then another 13 similar to these

Next comes
http://assemblytube.com/forum/index.php?action=forum
8: Undefined index: forum_name
File: /public_html/assemblytube.com/forum/Themes/default/languages/index.english.php
Line: 113

and lots more.


Is this the sort of information you needed to advise me?

Thank you.

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15752
    • View Profile
Re: Undefined Index
« Reply #5 on: November 30, 2012, 12:03:33 pm »
Could you attach those two files. I want to see what it is from
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline assemblytube

  • Member
  • *
  • Posts: 24
    • View Profile
    • AssemblyTube
Re: Undefined Index
« Reply #6 on: November 30, 2012, 12:16:32 pm »
Here are the 3 files referred to in my previous posting.
Thanks.

Offline assemblytube

  • Member
  • *
  • Posts: 24
    • View Profile
    • AssemblyTube
Re: Undefined Index
« Reply #7 on: December 04, 2012, 03:11:24 am »
Any more thoughts on these errors?

This might help narrow it down.
I registered a new dummy member and they got 37 unidentified index error messages once they log in.
When they log in a second time they don't generate error messages.

By logging in the first time they receive badges and personal messages telling them this.
When they log back in they obviously don't get badges nor personal messages.

If they just send a personal message this does not generate errors.

I logged them back in using an Ipad which gives them an Apple User badge. Immediately get 37 error messages.
So the errors are being generated in some way by the Award System mod. Possibly when it generates the personal message.

This error is repeatable if I set up a user.
Also exactly the same if a member who has previously joined logs in. 37 unidentifed index error messages.

Any ideas on where I might look to try to fix this?

Thanks for your help.

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15752
    • View Profile
Re: Undefined Index
« Reply #8 on: December 04, 2012, 08:45:52 pm »
I did look at the files not sure what is causing it yet looks like $context is not being called yet so far.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

 

Related Topics

  Subject / Started by Replies Last post
0 Replies
2917 Views
Last post March 27, 2009, 02:52:42 pm
by dry3210
7 Replies
4582 Views
Last post February 02, 2012, 08:06:17 pm
by SMFHacks
0 Replies
1818 Views
Last post January 08, 2012, 09:00:04 am
by clothahump
4 Replies
3406 Views
Last post February 15, 2013, 01:06:23 pm
by CWVRV
2 Replies
3395 Views
Last post June 03, 2014, 12:11:06 pm
by spikeweb

+- Recent Topics

How to change the font on a photo in SMF Gallery Pro? by SMFHacks
November 18, 2021, 09:28:11 am

Bulk Upload Many Pictures - File Name by SMFHacks
November 17, 2021, 08:58:50 am

Schedule or direct download link by SMFHacks
November 16, 2021, 10:57:33 am

Download Expire by Vincent Volmer
November 16, 2021, 02:40:47 am

prettyurls - TroubleShooting.wiki by SMFHacks
November 14, 2021, 02:18:59 pm

Error With Delete Download by mickjav
November 10, 2021, 04:49:12 pm

No ads on left or right by coyote
November 08, 2021, 04:57:13 pm

Now accepting Cryptocurrency by SMFHacks
November 05, 2021, 05:33:27 pm

Latest Version Pretty Urls SEO Pro by SMFHacks
November 04, 2021, 03:46:53 pm

Downloads Pro 6.0 Released by mickjav
November 03, 2021, 05:13:47 pm

Powered by EzPortal