Facebook  Twitter 

SMFHacks.com

+-

SMFHacks.com

+- User Information

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Forum Stats

Members
Total Members: 4252
Latest: Jwatson_785
New This Month: 0
New This Week: 0
New Today: 0
Stats
Total Posts: 43228
Total Topics: 7514
Most Online Today: 113
Most Online Ever: 2482
(April 09, 2011, 07:02:45 pm)
Users Online
Members: 0
Guests: 91
Total: 91

Author Topic: Links don't work correctly  (Read 14536 times)

0 Members and 1 Guest are viewing this topic.

Offline lemontwist

  • Member
  • *
  • Posts: 27
    • View Profile
    • Talk Faux
Links don't work correctly
« on: February 09, 2010, 07:10:41 am »
I sent out newsletters yesterday for the first time and woke up to several people telling me none of the links in my newsletter work.

For instance the one I had for www.talkfaux.com when clicked went to http://talkfaux.com/forum/newstracking.php?a=l&c=17&i=271&l=91

wth?

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 16422
    • View Profile
Re: Links don't work correctly
« Reply #1 on: February 09, 2010, 09:16:52 am »
Appears to be a permission issue on newstracking.php chmod that file to 755
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline lemontwist

  • Member
  • *
  • Posts: 27
    • View Profile
    • Talk Faux
Re: Links don't work correctly
« Reply #2 on: February 09, 2010, 01:46:18 pm »
I have no idea what that means.

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 16422
    • View Profile
Re: Links don't work correctly
« Reply #3 on: February 09, 2010, 01:52:01 pm »
You have to change the file permissions on the newstracking.php in your the root of your forum directory. Make it writable, readable and exectuable you should be able to this either via ftp or the control panel with your webhosting account.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline yol

  • Member
  • *
  • Posts: 22
    • View Profile
Re: Links don't work correctly
« Reply #4 on: January 10, 2014, 08:05:54 pm »
Hello,

I have got same problem. newstracking2.php is 755 and reinstalled package but links are not working correctly.

opening white blank page (http 500 internal error) when I click links in mail

links looks like this;
http://www.domain.com/newstracking2.php?a=l&c=26&i=141818&l=69

Regards,
Sedat
SEDAT AÇIL

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 16422
    • View Profile
Re: Links don't work correctly
« Reply #5 on: January 10, 2014, 08:15:58 pm »
500 internal error is a permission chmod the file to 644 or double check you forum's error log and apache error log if you have access it.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline yol

  • Member
  • *
  • Posts: 22
    • View Profile
Re: Links don't work correctly
« Reply #6 on: January 11, 2014, 12:19:54 pm »
in error log file;

PHP Parse error:  syntax error, unexpected T_STRING in /home/domain/public_html/newstracking2.php on line 536

what can I do?
« Last Edit: January 11, 2014, 12:38:32 pm by yol »
SEDAT AÇIL

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 16422
    • View Profile
Re: Links don't work correctly
« Reply #7 on: January 11, 2014, 01:06:43 pm »
Attach your newstracking2.php and I will take a look at the issue.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline yol

  • Member
  • *
  • Posts: 22
    • View Profile
Re: Links don't work correctly
« Reply #8 on: January 11, 2014, 01:29:48 pm »
Thank you :)

But I cant see attached files?
SEDAT AÇIL

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 16422
    • View Profile
Re: Links don't work correctly
« Reply #9 on: January 11, 2014, 01:32:19 pm »
Put your license information under http://www.smfhacks.com/index.php?action=license to gain access
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 16422
    • View Profile
Re: Links don't work correctly
« Reply #10 on: January 11, 2014, 01:35:06 pm »
I am not seeing any errors in that file. You can try removing the code around line 536 and see if it helps
Code: [Select]
    $shareUrl = urlencode($boardurl . '/newstracking2.php?a=share&c=' . $c. '&i=' . $i);
    $campaignRow['message'] = str_replace("{FACEBOOK}","<a href=\"http://www.facebook.com/sharer.php?u=" . $shareUrl . "\"><img src=\"" . $boardurl . "/images/facebook.png\" alt=\"" . $txt['newspro_txt_share_facebook'] . "\" border=\"0\"/></a>",$campaignRow['message']);
    $campaignRow['message'] = str_replace("{TWITTER}","<a href=\"http://twitter.com/share?text=Currently%20reading%20" . $shareUrl . "\"><img src=\"" . $boardurl . "/images/twitter.png\" alt=\"" . $txt['newspro_txt_share_twitter'] . "\" border=\"0\"/></a>",$campaignRow['message']);
    $campaignRow['message'] = str_replace("{LINKEDIN}","<a href=\"http://www.linkedin.com/shareArticle?mini=true&url=" . $shareUrl . "\"><img src=\"" . $boardurl . "/images/linkedin.png\" alt=\"" . $txt['newspro_txt_share_linkedin'] . "\" border=\"0\"/></a>",$campaignRow['message']);
    $campaignRow['message'] = str_replace("{GOOGLE}","<a href=\"https://plus.google.com/share?url=" . $shareUrl . "\"><img src=\"". $boardurl . "/images/google-plus.png\" alt=\"" . $txt['newspro_txt_share_googleplus'] . "\" border=\"0\"/></a>",$campaignRow['message']);
   
    $campaignRow['message'] = str_replace("{FORWARDFRIEND}",'<a href="' . $boardurl . '/newstracking2.php?a=forward&c=' . $c. '&i=' . $i . '">' . $txt['newspro_txt_forwardtoafriend'] . '</a>',$campaignRow['message']);
    $campaignRow['message'] = str_replace("{VIEWWEBPAGE}",'<a href="' . $boardurl . '/newstracking2.php?a=webpage&c=' . $c. '&i=' . $i . '">' . $txt['newspro_txt_viewasawebpage']. '</a>', $campaignRow['message']);
   
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline yol

  • Member
  • *
  • Posts: 22
    • View Profile
Re: Links don't work correctly
« Reply #11 on: January 11, 2014, 04:08:34 pm »
Doesnt work...

How can I cancel link tracking option? I want to bypass recoding the links...
SEDAT AÇIL

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 16422
    • View Profile
Re: Links don't work correctly
« Reply #12 on: January 11, 2014, 10:12:29 pm »
Same error in the log?" Same line number?

No easy way since it also does view tracking and unsubscribe links.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline yol

  • Member
  • *
  • Posts: 22
    • View Profile
Re: Links don't work correctly
« Reply #13 on: April 02, 2014, 07:38:34 pm »
Hello again friend,

I found some error logs about this happen in server. Can you understand anything about the problem? :)


[Thu Apr 03 03:19:46 2014] [error] [client 66] SoftException in Application.cpp:249: File "/home/domain/public_html/newstracking2.php" is writeable by group
[Thu Apr 03 03:19:46 2014] [error] [client 66] Premature end of script headers: newstracking2.php

[Thu Apr 03 03:20:13 2014] [error] [client 176] SoftException in Application.cpp:249: File "/home/domain/public_html/newstracking2.php" is writeable by group, referer: http://www.domain.com/newstracking2.php?a=l&c=30&i=2&l=111

[Thu Apr 03 03:20:13 2014] [error] [client 176] Premature end of script headers: newstracking2.php, referer: http://www.domain.com/newstracking2.php?a=l&c=30&i=2&l=111
SEDAT AÇIL

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 16422
    • View Profile
Re: Links don't work correctly
« Reply #14 on: April 02, 2014, 08:04:07 pm »
Just looks like some kind of permission error from what it is saying.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

 

Related Topics

  Subject / Started by Replies Last post
1 Replies
4044 Views
Last post March 09, 2007, 05:37:31 pm
by SMFHacks
4 Replies
5373 Views
Last post February 06, 2009, 01:01:52 pm
by Menard9
12 Replies
9282 Views
Last post February 07, 2012, 06:09:23 pm
by SMFHacks
2 Replies
662 Views
Last post May 14, 2022, 10:45:34 pm
by SMFHacks
7 Replies
1513 Views
Last post January 10, 2023, 05:56:21 pm
by SMFHacks

+- Recent Topics

an idea for new mod (( content type with different display )) by SMFHacks
February 27, 2024, 01:36:27 pm

[Mod] RSS Feed Poster by SMFHacks
February 27, 2024, 11:57:18 am

find duplicate pictures by fvlog19
February 14, 2024, 02:22:40 pm

Error uploading video. by SMFHacks
February 08, 2024, 02:04:16 pm

Request for admin notification by davejo
February 06, 2024, 09:02:12 am

Gallery icon as last added image by fvlog19
February 01, 2024, 01:04:56 pm

User Gallery Feature: move / bulk move images by SMFHacks
January 30, 2024, 05:48:25 pm

In the future it may be for smf 2.1.x? by smithloo
January 30, 2024, 12:55:34 am

Clipboard image support for the editor by SMFHacks
January 29, 2024, 11:22:17 am

Release date? by SMFHacks
January 26, 2024, 02:00:45 pm

Powered by EzPortal