Facebook  Twitter 

SMFHacks.com

+- +-

SMFHacks.com

+- User Information

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Forum Stats

Members
Total Members: 12376
Latest: Printablecalendars
New This Month: 3
New This Week: 0
New Today: 0
Stats
Total Posts: 40220
Total Topics: 7084
Most Online Today: 83
Most Online Ever: 2482
(April 09, 2011, 07:02:45 pm)
Users Online
Members: 0
Guests: 26
Total: 26

Author Topic: Problem with image naming  (Read 6694 times)

0 Members and 1 Guest are viewing this topic.

Offline AlecDurbervilles

  • Newbie
  • *
  • Posts: 10
    • View Profile
Problem with image naming
« on: February 14, 2015, 04:10:52 pm »
I used the basic free version for over a year and liked it. Today, I bought and installed SMF Gallery Pro and I love the new features. However, something is wrong. When I upload a photo into the gallery it shows up like this: as if it can't understand the name.

Before, all my image names looked like this (without the spaces): http: // 64shadesofgrey.net//gallery/2_03_02_15_9_37_03.jpeg

Now they look like this: http: // 64shadesofgrey.net//gallery/2140215134527.jpeg

Does anyone know what I've done wrong or if there's some tweak in the settings that will fix it?

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15109
    • View Profile
Re: Problem with image naming
« Reply #1 on: February 14, 2015, 04:14:31 pm »
Is it breaking anything?  How were the new images added?
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline AlecDurbervilles

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Problem with image naming
« Reply #2 on: February 14, 2015, 04:18:00 pm »
It hasn't affected old images. They're still fine. But anything new that I upload from my computer using the standard "Add Picture" method names them without the underscores. Neither the thumbnails nor the enlarged images show up.

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15109
    • View Profile
Re: Problem with image naming
« Reply #3 on: February 14, 2015, 04:22:54 pm »
That is the standard new format the filenames. Check folder level permissions in gallery folder you might have folders called 0 1 etc
If you enabled multifolder support uncheck that as well
Last  check your forum's error log.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline AlecDurbervilles

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Problem with image naming
« Reply #4 on: February 14, 2015, 04:26:54 pm »
Thanks. I'll give those a try and let you know how it worked.

Offline AlecDurbervilles

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Problem with image naming
« Reply #5 on: February 14, 2015, 05:09:29 pm »
I checked my error log and didn't see anything out of the ordinary. I checked permissions. They are all set for each membergroup. However, I haven't found where multifolder support is enabled/disabled.

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15109
    • View Profile
Re: Problem with image naming
« Reply #6 on: February 14, 2015, 05:11:48 pm »
On gallery configuration -> settings  "Enable multiple folders for picture storage"
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline AlecDurbervilles

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Problem with image naming
« Reply #7 on: February 14, 2015, 05:21:36 pm »
Yes, I see it. But it wasn't checked.

The only thing I did outside of installing the Gallery Pro is that this morning I did a version check of FrontPage extensions. It told me that an .htaccess file might be reverted back to an original version. Does Gallery Pro have anything to do with FrontPage? I didn't think much of it at the time but that's the only thing I can thing of that is different.

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15109
    • View Profile
Re: Problem with image naming
« Reply #8 on: February 14, 2015, 05:34:01 pm »
Gallery Pro does not touch anything with frontpage. If you are still having an issue link me to example image in your gallery not the picture but the page where you can view the image.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline AlecDurbervilles

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Problem with image naming
« Reply #9 on: February 14, 2015, 05:41:00 pm »
I have permissions set so that guests can see everything here. http://64shadesofgrey.net//index.php?action=gallery;cat=19

The most recent image is one that I just tried to upload. Everything else was uploaded with the free version.

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15109
    • View Profile
Re: Problem with image naming
« Reply #10 on: February 14, 2015, 11:28:34 pm »
Can you upload an image to that category? Last one I can see in there is feb 3 and seems to work ok
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline AlecDurbervilles

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Problem with image naming
« Reply #11 on: February 14, 2015, 11:44:47 pm »
Yes, sorry. I was trying different things - uninstalling and reinstalling - and I deleted it the newest one. But look again. I've tried it again and it's still giving me problems.

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15109
    • View Profile
Re: Problem with image naming
« Reply #12 on: February 15, 2015, 04:27:45 pm »
Whats your gallery path and url settings set to?
The url looks odd I see two // in http://64shadesofgrey.net//gallery/2-140215214237.jpeg
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline AlecDurbervilles

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Problem with image naming
« Reply #13 on: February 15, 2015, 07:27:38 pm »
Argh. This is exasperating. Yes, somehow an extra forward slash got put into the path but even after fixing it, the problem remains. I went into my server to look at the files in the path and that newest image is there with all the rest and I can even highlight it and hit "view" and see the image. But somehow, SMF is not letting it display on the site.

If I "copy image url" and paste it into an address bar, I get an "Error 404 page not found."

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15109
    • View Profile
Re: Problem with image naming
« Reply #14 on: February 15, 2015, 07:45:52 pm »
Check your gallery folder area any files getting added to it at all when you are uploading an image?

Did you change servers? Since the gallery url was wrong the gallery path could be wrong as well.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

 

Related Topics

  Subject / Started by Replies Last post
14 Replies
13116 Views
Last post May 31, 2011, 12:25:39 pm
by Yannick95
2 Replies
2820 Views
Last post August 16, 2009, 12:57:37 am
by Vincent Volmer
2 Replies
2461 Views
Last post October 13, 2009, 08:04:28 am
by SMFHacks
5 Replies
3218 Views
Last post March 08, 2015, 02:13:23 pm
by dan4ever
1 Replies
1858 Views
Last post June 06, 2016, 07:59:08 am
by SMFHacks

+- Recent Topics

Download System Lite by Rock Lee
June 03, 2020, 07:34:24 pm

Font question by SMFHacks
May 27, 2020, 08:15:26 am

Error message with latest SMF 2.1 Github build by Hatshepsut
May 25, 2020, 01:43:26 am

smfblog not working on 2.0.17 by tech9
May 20, 2020, 01:44:34 pm

Copyright removal by stbc
May 18, 2020, 01:27:57 am

Mod Verified User i can't square the image by Rock Lee
May 07, 2020, 07:56:10 pm

SMF4Mobile 2.0 released for SMF 2.0.x by SMFHacks
May 06, 2020, 12:13:14 pm

SMF Social Login Pro - Discontinued? by Nicole
May 02, 2020, 05:47:04 pm

Likes by SMFHacks
April 30, 2020, 09:50:35 pm

Upgrade Issue - by SMFHacks
April 28, 2020, 12:40:13 pm

Powered by EzPortal