Facebook  Twitter 

SMFHacks.com

+- +-

SMFHacks.com

+- User Information

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Forum Stats

Members
Total Members: 12411
Latest: PabloWatts
New This Month: 1
New This Week: 1
New Today: 0
Stats
Total Posts: 39948
Total Topics: 7033
Most Online Today: 67
Most Online Ever: 2482
(April 09, 2011, 07:02:45 pm)
Users Online
Members: 0
Guests: 27
Total: 27

Author Topic: Menu Editor Pro with Simple Portal Home Page  (Read 14612 times)

0 Members and 1 Guest are viewing this topic.

Offline LukeZ

  • Newbie
  • *
  • Posts: 22
    • View Profile
Menu Editor Pro with Simple Portal Home Page
« on: September 23, 2015, 07:13:12 pm »
Hi, I bought the Pro version of this specifically because it said it was compatible with Simple Portal, which the Lite version is not. I'm using SMF 2.0.11 and Simple Portal 2.3.6. I have Simple Portal set to Standalone mode with the standalone URL being the root of my domain. I renamed StandalonePortal.php to index.php and put this at the root. Worked fine until I installed Menu Editor Pro.

If I try to add a menu button with internal action to Portal Home, it lets me do it but I can't set "Is Active" to yes. Instead it gives me a message: "The portal button can only be set to non-active if the Portal Front Page setting is not on."

I've tried changing Simple Portal to "Front Page" mode from "Standalone" and it makes no difference.

Then I thought, ok, maybe I can create a menu button to an external link and have that go to index.php in my domain root. This does work, sort of, but I get tons of "Strict Standards" errors at the top of the page whenever I visit that link. Also, when I go to that link, the menu item isn't highlighted, the highlighting remains on the forum menu item.

There are also bugs in the menu editor admin interface. For example, when I add a menu item and let's say I select "Internal Action" from the Type dropdown - the drop down for selecting the internal action doesn't appear. I can click the "Modify Button" command at the bottom of the page, then it will give me an error because of course Internal Action wasn't specified, and when the page reloads then the internal actions list will appear - but only sometimes, and sometimes not. The same behavior is observed with the other dynamic show/hide elements of a similar nature. I've tried two browsers (Chrome 45.0.2454.99 and Firefox 40.0.3) and both have Java enabled and seem to work fine in other respects.



« Last Edit: April 28, 2016, 02:54:59 pm by LukeZ »

Offline LukeZ

  • Newbie
  • *
  • Posts: 22
    • View Profile
Re: Menu Editor Pro with Simple Portal Home Page
« Reply #1 on: September 28, 2015, 04:03:06 pm »
A friendly bump.

I'd hate to think SMFHacks is still charging people for a mod that isn't being maintained or supported, but some of the issues I am seeing were brought up in this forum over two years ago.

I'm hoping these turn out to be simple fixes rather than something approaching a scam. But the silence here is not a good sign. 

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 14978
    • View Profile
Re: Menu Editor Pro with Simple Portal Home Page
« Reply #2 on: September 28, 2015, 04:08:29 pm »
Please pm Labradoodle-360
http://www.smfhacks.com/index.php?action=profile;u=10606
It is a third party mod made by a friend of mine.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline Labradoodle-360

  • Moderator
  • Full Member
  • *****
  • Posts: 156
    • View Profile
Re: Menu Editor Pro with Simple Portal Home Page
« Reply #3 on: September 28, 2015, 06:18:12 pm »
I'll look into this for you here shortly. What other modifications do you have installed? There seem to be a lot of jQuery conflicts with other mods.

Offline LukeZ

  • Newbie
  • *
  • Posts: 22
    • View Profile
Re: Menu Editor Pro with Simple Portal Home Page
« Reply #4 on: September 29, 2015, 11:38:53 am »
Aside from Simple Portal, I'm using Ohara YouTube Embed, Highslide Image Viewer, and Custom View of Attachments.

However I just uninstalled all of them and it makes no difference. I will leave them uninstalled for now if it helps you test.

For what it's worth, the very first mod I installed after Simple Portal was Menu Editor Lite, so there would have been no other conflicts. It had pretty much the same problems as I'm seeing now with the Pro version. I assumed Lite was no longer supported which is why I purchased Pro, but I guess the issues are deeper than that.

The theme I'm running is Redsy by SMF Tricks. I don't know if that could be a conflict as well or not.

PHP version is 5.4. Hosting is GoDaddy shared.

Offline Labradoodle-360

  • Moderator
  • Full Member
  • *****
  • Posts: 156
    • View Profile
Re: Menu Editor Pro with Simple Portal Home Page
« Reply #5 on: September 29, 2015, 12:03:05 pm »
I don't appreciate the snide comments about lack of support.

I assume you completely uninstalled Menu Editor Lite, right? And checked the box to remove all data associated with the mod?

I'm releasing a huge update to this mod as soon as SMF 2.1 is released in RC or stable. It'll be smart enough to import or delete Lite data while installing pro. Hopefully I can also clear up issues with the built-in caching system I wrote. Also since 2.1 has jQuery, all jQuery will work correctly.

Offline LukeZ

  • Newbie
  • *
  • Posts: 22
    • View Profile
Re: Menu Editor Pro with Simple Portal Home Page
« Reply #6 on: September 29, 2015, 12:17:19 pm »
Yes, I completely uninstalled/deleted Lite. It doesn't even show in the Package Manager list anymore.

Although an update to coincide with a future SMF 2.1 will be great, I really need to get this working with the existing forum version.

Offline LukeZ

  • Newbie
  • *
  • Posts: 22
    • View Profile
Re: Menu Editor Pro with Simple Portal Home Page
« Reply #7 on: October 02, 2015, 03:56:03 pm »
Is there anything else I can do to help you with this?

Offline Labradoodle-360

  • Moderator
  • Full Member
  • *****
  • Posts: 156
    • View Profile
Re: Menu Editor Pro with Simple Portal Home Page
« Reply #8 on: October 02, 2015, 04:03:00 pm »
Send me a link to your forum, along with admin login details in a PM. FTP would also be helpful.

Offline LukeZ

  • Newbie
  • *
  • Posts: 22
    • View Profile
Re: Menu Editor Pro with Simple Portal Home Page
« Reply #9 on: October 02, 2015, 10:06:59 pm »
PM sent.

Offline Labradoodle-360

  • Moderator
  • Full Member
  • *****
  • Posts: 156
    • View Profile
Re: Menu Editor Pro with Simple Portal Home Page
« Reply #10 on: October 05, 2015, 07:38:03 pm »
Looking into this now for you. Thanks for the patience.

Offline Labradoodle-360

  • Moderator
  • Full Member
  • *****
  • Posts: 156
    • View Profile
Re: Menu Editor Pro with Simple Portal Home Page
« Reply #11 on: October 05, 2015, 08:19:46 pm »
Okay, I have discovered the issues with the expanding and collapsing of permissions and membergroups is a conflict with your custom theme.

Offline Labradoodle-360

  • Moderator
  • Full Member
  • *****
  • Posts: 156
    • View Profile
Re: Menu Editor Pro with Simple Portal Home Page
« Reply #12 on: October 05, 2015, 08:58:18 pm »
I was also able to look at your error logs, and find an error in Menu Editor Pro (minor, not breaking anything, just PHP strict) that I resolved on your website, and recorded for the next patch.

Can't replicate your issue that you're having with your portal to me, it looks like SimplePortal isn't even being standalone when it's set to it.

Offline LukeZ

  • Newbie
  • *
  • Posts: 22
    • View Profile
Re: Menu Editor Pro with Simple Portal Home Page
« Reply #13 on: October 05, 2015, 09:02:42 pm »
Okay, I have discovered the issues with the expanding and collapsing of permissions and membergroups is a conflict with your custom theme.
Ok - anything that can be done about that? Maybe just keep the options visible all the time instead?

If not, it's probably not a deal-breaker since as I say, with the correct sequence of clicks and curses I can often get the menus to appear. The main thing is to get Simple Portal to play nice.


Offline Labradoodle-360

  • Moderator
  • Full Member
  • *****
  • Posts: 156
    • View Profile
Re: Menu Editor Pro with Simple Portal Home Page
« Reply #14 on: October 05, 2015, 09:12:19 pm »
If you read my last few posts, I fixed all of the issues that your theme were causing. I can't replicate the SimplePortal issue on your site.

 

Related Topics

  Subject / Started by Replies Last post
0 Replies
2643 Views
Last post May 04, 2008, 08:57:46 am
by newguyatthis
0 Replies
3247 Views
Last post November 30, 2009, 04:30:30 am
by Mr.Pyscho
49 Replies
24612 Views
Last post October 13, 2016, 09:17:52 am
by grim
16 Replies
5765 Views
Last post December 30, 2014, 02:53:45 pm
by dan4ever
1 Replies
2730 Views
Last post October 23, 2015, 06:23:41 pm
by Labradoodle-360

+- Recent Topics

hashTags only used by admins, but visible to everyone? by SMFHacks
December 04, 2019, 11:08:35 am

Responsive Layout by Matthias
November 30, 2019, 03:05:57 pm

Secure connection failed Pretty Url Pro by Rock Lee
November 26, 2019, 10:44:23 am

Black Friday Sale Week 2019 by SMFHacks
November 23, 2019, 04:47:56 pm

German Translation missing in SMF 2.1R1 by SMFHacks
November 19, 2019, 02:38:42 pm

Unread items issue by SMFHacks
November 19, 2019, 10:07:32 am

Update detect mobile mode PHP5 to PHP7 by Rock Lee
November 16, 2019, 07:18:13 pm

PHP error by davejo
November 12, 2019, 12:09:47 pm

Message Editor Pro Issues by SMFHacks
November 06, 2019, 09:58:33 pm

most popular categories doesnt work by fussilet
November 02, 2019, 02:51:42 pm

Powered by EzPortal