Facebook  Twitter 

SMFHacks.com

+- +-

SMFHacks.com

+- User Information

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Forum Stats

Members
Total Members: 12369
Latest: r0sem4rie
New This Month: 5
New This Week: 0
New Today: 0
Stats
Total Posts: 39810
Total Topics: 7016
Most Online Today: 39
Most Online Ever: 2482
(April 09, 2011, 07:02:45 pm)
Users Online
Members: 0
Guests: 44
Total: 44

Author Topic: Menu Editor Pro with Simple Portal Home Page  (Read 14059 times)

0 Members and 1 Guest are viewing this topic.

Offline LukeZ

  • Newbie
  • *
  • Posts: 22
    • View Profile
Re: Menu Editor Pro with Simple Portal Home Page
« Reply #15 on: October 05, 2015, 09:22:07 pm »
Ok, I thought you had just "discovered" the issue, not necessarily fixed it. I see that the expanding/collapsing options are now working, that's great. Thanks for doing that.

As for the PHP strict stuff, I still see a bunch of error messages on the index page (My Home 2 in the menu). Of course, My Home 2 was just a plan B to work around the primary issue...

Which is Simple Portal - what is it that you're trying to replicate, and can't? The fact that Menu Editor Pro won't let me activate a menu internal action to Portal Home is the issue. Prior to installing MEP, Simple Portal was set to Standalone mode and the Standalone URL set to my index.php page in the root of my site (Simple Portal is still set to those settings). A "Home" and "Forum" button appeared on my menu, and they worked as expected.

After installing Menu Editor Pro that functionality broke - Menu Editor Pro will not permit the creation of a menu item set to Portal Home. It will let me create a menu item to an external link, but then when you go to that link, it shows the PHP strict errors...

Offline Labradoodle-360

  • Moderator
  • Full Member
  • *****
  • Posts: 156
    • View Profile
Re: Menu Editor Pro with Simple Portal Home Page
« Reply #16 on: October 06, 2015, 12:05:38 pm »
Nope, I fixed them for you. Can you send me a screenshot of those errors? I didn't see them when I was working on it for you.

I don't even see that SimplePortal is in Standalone mode in the first place. If it were, the menu item would likely show up, but even though it says it's in Standalone mode in the portal settings, it doesn't appear to me that it is?

Offline LukeZ

  • Newbie
  • *
  • Posts: 22
    • View Profile
Re: Menu Editor Pro with Simple Portal Home Page
« Reply #17 on: October 06, 2015, 12:19:50 pm »
Here is a screenshot of the strict standards messages I get on index.php.

Regarding Simple Portal, you say "If it were [in Standalone mode], the menu item would likely show up." The menu item does show up, as you can see in the second screenshot. You can see this when you edit the My Home button in Menu Editor. The menu item for internal-action -> Simple Portal Home shows up and is selected. The issue is that Menu Editor will not let me activate that button.

If you still think this is a problem with Simple Portal, can you give me some specific, technical details about the statement that "Simple Portal does not appear to be in standalone mode"? Basically I need something that I can take to the Simple Portal forum and have them look at the error.

Offline LukeZ

  • Newbie
  • *
  • Posts: 22
    • View Profile
Re: Menu Editor Pro with Simple Portal Home Page
« Reply #18 on: October 06, 2015, 12:21:16 pm »
I attached the images but for some reason they get stripped when I post. Maybe we have to have a minimum number of posts before we can attach?

I will try them again here... Nope, still doesn't work.

If you PM me an email I will send them to you that way.

In the case of the strict standards, this is the actual text that appears:
Code: [Select]
Strict Standards: Only variables should be passed by reference in /home/mysite/public_html/forum/Sources/menu-editor-pro/resources/integrate.php on line 132

Strict Standards: Only variables should be passed by reference in /home/mysite/public_html/forum/Sources/menu-editor-pro/resources/integrate.php on line 132

Strict Standards: Only variables should be passed by reference in /home/mysite/public_html/forum/Sources/menu-editor-pro/resources/integrate.php on line 169

Strict Standards: Only variables should be passed by reference in /home/mysite/public_html/forum/Sources/menu-editor-pro/resources/integrate.php on line 169

Strict Standards: Only variables should be passed by reference in /home/mysite/public_html/forum/Sources/menu-editor-pro/resources/integrate.php on line 169

Strict Standards: Only variables should be passed by reference in /home/mysite/public_html/forum/Sources/menu-editor-pro/resources/integrate.php on line 169

Strict Standards: Only variables should be passed by reference in /home/mysite/public_html/forum/Sources/menu-editor-pro/resources/integrate.php on line 169

Strict Standards: Only variables should be passed by reference in /home/mysite/public_html/forum/Sources/menu-editor-pro/resources/integrate.php on line 169

Strict Standards: Only variables should be passed by reference in /home/mysite/public_html/forum/Sources/menu-editor-pro/resources/integrate.php on line 169

Strict Standards: Only variables should be passed by reference in /home/mysite/public_html/forum/Sources/menu-editor-pro/resources/integrate.php on line 169

Strict Standards: Only variables should be passed by reference in /home/mysite/public_html/forum/Sources/menu-editor-pro/resources/integrate.php on line 169

Strict Standards: Only variables should be passed by reference in /home/mysite/public_html/forum/Sources/menu-editor-pro/resources/integrate.php on line 169
« Last Edit: April 28, 2016, 02:55:58 pm by LukeZ »

Offline Labradoodle-360

  • Moderator
  • Full Member
  • *****
  • Posts: 156
    • View Profile
Re: Menu Editor Pro with Simple Portal Home Page
« Reply #19 on: October 06, 2015, 02:52:13 pm »
They got uploaded, might have just been a slight delay. Gotcha, I can fix that error for you.

Offline Labradoodle-360

  • Moderator
  • Full Member
  • *****
  • Posts: 156
    • View Profile
Re: Menu Editor Pro with Simple Portal Home Page
« Reply #20 on: October 06, 2015, 03:16:44 pm »
Hello Luke,

I just wanted to let you know that I fixed the bug in the code on your site, and then also set it up for you how I believe that you want it.

Best Regards

Offline LukeZ

  • Newbie
  • *
  • Posts: 22
    • View Profile
Re: Menu Editor Pro with Simple Portal Home Page
« Reply #21 on: October 06, 2015, 03:47:39 pm »
Holy moly, that is absolutely precisely how I want it. I'm not entirely sure how you did it, I see Simple Portal is set to "Front Page" rather than standalone, but index.php (at the root) is set to Standalone.

Is there anything I need to keep in mind as I'm editing and adding stuff? The strange thing is that if I go to mysite/index.php I am on a slightly different page than what I get to if I click on "Home", which takes me to mysite/forum/index.php. However they both end up with the same content so I guess it doesn't matter!

The only other glitch that I will bring to your attention, but which I don't need fixed, is that I believe sometimes MEP will give a brief notification message at the top of the page. For example, if I add a button to the menu a green line will expand slightly at the top of the page and then after a moment disappear. I'm assuming there is some kind of confirmation message that is supposed to appear there, but for me it isn't visible. No doubt it is a similar issue to the expanding/collapsing options. I don't personally need this fixed, you've done enough for me already. It's probably just a conflict with my particular theme. I only mention it in case it is a global conflict you want to address in your next release.

Thank you very much for the personalized support, it is greatly appreciated. I rescind my earlier skepticism and will definitely look forward to an SMF 2.1 version.

Thanks again. I'm now going to take a backup of the entire site!
« Last Edit: April 28, 2016, 02:56:50 pm by LukeZ »

Offline Labradoodle-360

  • Moderator
  • Full Member
  • *****
  • Posts: 156
    • View Profile
Re: Menu Editor Pro with Simple Portal Home Page
« Reply #22 on: October 06, 2015, 03:50:02 pm »
Hey Luke,

You're very welcome for the help, it's nice to see everything working for you smoothly. I would recommend using SimplePortal with the homepage (not standalone), and then moving your forum from /forum to the root of your website. Menu Editor Pro will work best that way, and it looks like that might be exactly what you're looking for anyway.

Yeah, the notification at the top just let's you know that the action was completed, with a specified success message. It's again an issue related to your theme, but I appreciate your pointing it out.

Best Regards

Offline LukeZ

  • Newbie
  • *
  • Posts: 22
    • View Profile
Re: Menu Editor Pro with Simple Portal Home Page
« Reply #23 on: October 06, 2015, 04:40:35 pm »
Ha, I don't dare breathe on it now, let alone move the entire thing! :D Actually, I stuck the forum in its own folder for a reason -  the site is more than just a forum, we have a wiki, a web-shop, etc... None of those other applications integrate with SMF so I am putting everything into its own folder (site) to avoid conflicts.

But it's working now so all's well that ends well. Thanks again.

Offline LukeZ

  • Newbie
  • *
  • Posts: 22
    • View Profile
Re: Menu Editor Pro with Simple Portal Home Page
« Reply #24 on: October 06, 2015, 09:58:29 pm »
Sorry to mention another issue... When I am on the forum homepage the "Forum" menu item is highlighted, as it should be. But as soon as I enter any board page or thread, the highlighting reverts to the "Home" menu item, although it should remain on "Forum."

Could you take a look at your convenience?

I'm attaching another screen shot. I can't actually see my own attachments but I'm assuming you can.

Offline Labradoodle-360

  • Moderator
  • Full Member
  • *****
  • Posts: 156
    • View Profile
Re: Menu Editor Pro with Simple Portal Home Page
« Reply #25 on: October 07, 2015, 11:39:48 am »
Hey there Luke,

Thanks for reporting that. It does indeed appear to be a slight oversight on my part in terms of the code, I'm not sure I'll be able to push a fix for you immediately on that one, but I logged it in my issues for the next version, and am considering pushing out a patch shortly with some common bugfixes.

Best Regards,
Matthew P. Kerle

Offline LukeZ

  • Newbie
  • *
  • Posts: 22
    • View Profile
Re: Menu Editor Pro with Simple Portal Home Page
« Reply #26 on: October 07, 2015, 11:55:59 am »
Great, thanks. A patch would be great, I'll keep my eyes open for one. I can live with it for now.

Offline Labradoodle-360

  • Moderator
  • Full Member
  • *****
  • Posts: 156
    • View Profile
Re: Menu Editor Pro with Simple Portal Home Page
« Reply #27 on: October 07, 2015, 12:04:00 pm »
What's in the line-up for the patch: http://prntscr.com/8osmm7

Offline LukeZ

  • Newbie
  • *
  • Posts: 22
    • View Profile
Re: Menu Editor Pro with Simple Portal Home Page
« Reply #28 on: March 12, 2016, 12:24:49 pm »
Sorry to mention another issue... When I am on the forum homepage the "Forum" menu item is highlighted, as it should be. But as soon as I enter any board page or thread, the highlighting reverts to the "Home" menu item, although it should remain on "Forum."

Sorry to revive this thread, but our site is going live shortly and I really need this last bug fixed. In addition to the behavior mentioned above, there is actually another probably-related bug.

In Menu Editor Pro I created a new tab called "Downloads." This points to a portal page that I created. When I visit the Downloads page, both the "Home" and "Downloads" tabs are highlighted along the top. This looks really bad.

I'm posting a screenshot which as usual I actually can't see myself. I will also send you a PM with an admin login that you can use to access the forum.


Offline LukeZ

  • Newbie
  • *
  • Posts: 22
    • View Profile
Re: Menu Editor Pro with Simple Portal Home Page
« Reply #29 on: March 19, 2016, 08:12:21 pm »
Apologies again, but this is the one-week friendly nudge.

 

Related Topics

  Subject / Started by Replies Last post
0 Replies
2619 Views
Last post May 04, 2008, 08:57:46 am
by newguyatthis
0 Replies
3179 Views
Last post November 30, 2009, 04:30:30 am
by Mr.Pyscho
49 Replies
24232 Views
Last post October 13, 2016, 09:17:52 am
by grim
16 Replies
5677 Views
Last post December 30, 2014, 02:53:45 pm
by dan4ever
1 Replies
2655 Views
Last post October 23, 2015, 06:23:41 pm
by Labradoodle-360

+- Recent Topics

How to AVOID SEO Hit when Implementing PrettyURLs by SMFHacks
September 12, 2019, 08:50:42 pm

theme by SMFHacks
September 12, 2019, 07:10:51 am

Picture Edit by SMFHacks
August 27, 2019, 11:52:06 am

Getting an error while installing SMF Gallery Pro by SMFHacks
August 18, 2019, 06:54:37 pm

Hashtag Mod Install Error by SMFHacks
August 15, 2019, 08:17:45 am

Rotating Image URLs by SMFHacks
August 05, 2019, 04:26:57 pm

[Mod]Block Proxy VPN On Registration by SMFHacks
August 01, 2019, 10:42:37 pm

[Mod]Nofollow Signature Links by SMFHacks
July 30, 2019, 11:52:28 am

Thinking of getting Ad Seller Pro as well by ajac63
July 28, 2019, 04:46:34 am

Just some questions about Ad Management mod by ajac63
July 26, 2019, 12:12:26 pm

Powered by EzPortal