Facebook  Twitter 

SMFHacks.com

+- +-

SMFHacks.com

+- User Information

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Forum Stats

Members
Total Members: 12388
Latest: Rands
New This Month: 5
New This Week: 2
New Today: 0
Stats
Total Posts: 40308
Total Topics: 7099
Most Online Today: 91
Most Online Ever: 2482
(April 09, 2011, 07:02:45 pm)
Users Online
Members: 0
Guests: 61
Total: 61

Author Topic: It just does not send  (Read 2063 times)

0 Members and 1 Guest are viewing this topic.

Offline gama

  • Newbie
  • *
  • Posts: 12
    • View Profile
It just does not send
« on: August 16, 2018, 07:53:16 pm »
Hi, I ve installed, I created message, I created a list, I create a campaign, it appears in campaing pendings, after it appears in Reports, but with 'sent' in 0 and it does not send any mail. In my log errors I found this:

"http://consultor.net.uy/smf/index.php?scheduled=task;ts=1534466161
Error en la Base de Datos: Illegal mix of collations (utf8_unicode_ci,IMPLICIT) and (utf8_general_ci,IMPLICIT) for operation '='
Archivo: /home/consulto/public_html/smf/Sources/NewsPro2.php"

Offline gama

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: It just does not send
« Reply #1 on: August 16, 2018, 08:01:26 pm »
I forgot One more line in the log error:

"Línea: 1394"

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15147
    • View Profile
Re: It just does not send
« Reply #2 on: August 16, 2018, 08:14:58 pm »
The issue is the database collation type.
Do you have phpmyadmin access?

We need to make all the tables match the same type.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline gama

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: It just does not send
« Reply #3 on: August 16, 2018, 09:18:27 pm »
Yes I have

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15147
    • View Profile
Re: It just does not send
« Reply #4 on: August 16, 2018, 09:25:56 pm »
The colliation needs to match for all columns check screenshot below has to be the same.
so it is utf8 needs to be the same for all
Click operations tab on the TABLE!!!! TO change it


Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline gama

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: It just does not send
« Reply #5 on: August 16, 2018, 09:30:37 pm »
On which of the tables ? All the tables in my smf database ?

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15147
    • View Profile
Re: It just does not send
« Reply #6 on: August 16, 2018, 09:33:48 pm »
newspro_unsubscribe  and newspro_members must match.

Also make sure your default collation for your database matches newspro_unsubscribe and newspro_members
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline gama

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: It just does not send
« Reply #7 on: August 16, 2018, 09:40:39 pm »
I see newspro_unsubscribe, but I dont see any "newspro_members"

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15147
    • View Profile
Re: It just does not send
« Reply #8 on: August 16, 2018, 09:45:52 pm »
Oops i meant needs to match normal smf_members
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline gama

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: It just does not send
« Reply #9 on: August 16, 2018, 09:46:38 pm »

Offline gama

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: It just does not send
« Reply #10 on: August 16, 2018, 09:58:47 pm »
Sent is in 0. en error logs I have "8: Undefined index: list"
Línea: 1086

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15147
    • View Profile
Re: It just does not send
« Reply #11 on: August 16, 2018, 10:00:01 pm »
Make sure the collation matches and that should fix the error you are getting.

How are you sending is my next question are you using news and newsletters?
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline gama

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: It just does not send
« Reply #12 on: August 16, 2018, 10:04:57 pm »
Now I tried with Campaings, and it show sent 1 (I sent to a group of just me) but the mail has never come.

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15147
    • View Profile
Re: It just does not send
« Reply #13 on: August 16, 2018, 10:08:04 pm »
Use news and newsletters. Make sure you choose more than just admin group when doing a newsletter SMF has a bug if it is just admin

Campaigns require I belive setting up a cron job.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline gama

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: It just does not send
« Reply #14 on: August 16, 2018, 10:13:18 pm »
I ve just tried with just admin in news and newsletters and it worked.

But Campaing did not work, I ll retry with another group.

 

Related Topics

  Subject / Started by Replies Last post
1 Replies
3517 Views
Last post March 09, 2009, 07:18:38 pm
by SMFHacks
3 Replies
5064 Views
Last post June 01, 2009, 01:49:38 am
by Darkshadow
2 Replies
5617 Views
Last post January 25, 2012, 12:53:58 pm
by DimTwinkle
21 Replies
9329 Views
Last post July 03, 2012, 02:19:45 pm
by Rickardm
10 Replies
7429 Views
Last post November 27, 2015, 09:26:18 am
by SMFHacks

+- Recent Topics

Quality of images after import by SMFHacks
September 05, 2020, 10:21:44 am

How do I download gallery images? by CWVRV
August 30, 2020, 11:50:07 pm

Deleting Empty Galleries by SMFHacks
August 30, 2020, 11:43:32 am

PHP error by davejo
August 25, 2020, 07:35:13 am

Permissions to list ads and buy items by CWVRV
August 21, 2020, 05:19:45 pm

Doubt with download permissions. by Rock Lee
August 20, 2020, 08:23:24 pm

Attachment images Upsidedown or Sideways by SMFHacks
August 18, 2020, 05:41:07 pm

[Mod]Avatars Display Integration by Hatshepsut
August 17, 2020, 11:39:54 pm

Simple Portal Block - Classifieds by SMFHacks
August 16, 2020, 09:56:48 am

SMF Links by SMFHacks
August 16, 2020, 08:03:42 am

Powered by EzPortal