Facebook  Twitter 

SMFHacks.com

+- +-

SMFHacks.com

+- User Information

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Forum Stats

Members
Total Members: 12388
Latest: Rands
New This Month: 5
New This Week: 0
New Today: 0
Stats
Total Posts: 40309
Total Topics: 7100
Most Online Today: 97
Most Online Ever: 2482
(April 09, 2011, 07:02:45 pm)
Users Online
Members: 0
Guests: 37
Total: 37

Author Topic: [Mod] Simple Blog  (Read 169167 times)

0 Members and 1 Guest are viewing this topic.

Offline grodden

  • Newbie
  • *
  • Posts: 8
    • View Profile
This blog is currently set to private.
« Reply #105 on: December 29, 2006, 08:23:46 pm »
Could u please tell me where is the code to this option and how to display it so that the user can decide upon this?
All of my users have the blog set to public, but (I donīt know how)  a particular person has this message now, and even she doesnt know how did this happen. Any idea?
So I need to find this code to enable to the users :)
Thanks!

Offline imbibe

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: [Mod] Simple Blog
« Reply #106 on: December 30, 2006, 04:37:50 pm »
I have a few questions. I have installed this mod on my SMF 1.1.1 on Default Theme


1. When I log in as Admin Recent blogs in the Info Centre list is empty but when some user logs in that list isn't empty. Recent Blogs under Blog Menu is fine even for Admin.

2. Suppose Recent Blogs List has 3 blogs. Now 3 new blogs are created by users but are private then the Recent Blog list shows no enteries. This is a bug.

3. Every user is set to Public blog. I don't find a option anywhere from where a user can the whole of his Blog as private.

4. Also tell me how can add an RSS feed for the blog for every user.


Finally the interface for the blog is just too bad. So I have completly revamped the Interface of the Blog to meet the default theme of SMF 1.1.1. If u want I can zip back the files to u.

Offline woden

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: [Mod] Simple Blog
« Reply #107 on: December 31, 2006, 12:07:59 pm »
The public/private option is on the bottom of the form to post a blog entry, to te right of the submit button.

What needs to be done to allow attachments (additional options) like normal posts?

Offline xtremecruiser

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: [Mod] Simple Blog
« Reply #108 on: December 31, 2006, 12:59:38 pm »
Let me show with pictures what is missing with Blocs Alienation (1.1) theme, WOW-DK and PN-PN themes.

In your profile this is missing
Add New Blog Entry
View All Blog Entries

Under the Blogs area the
Blog Menu with its
Add New Blog Entry
View All Blog Entries
View Profile

Blog Stats headings ( all headings are not there )

and the ability to
[Add Comment] [Edit] [Delete]

Link to mod on smfhacks
http://www.smfhacks.com/index.php/topic,97.15.html







 
« Last Edit: December 31, 2006, 01:16:52 pm by xtremecruiser »

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15147
    • View Profile
Re: [Mod] Simple Blog
« Reply #109 on: December 31, 2006, 01:02:17 pm »
For custom themes you need to add the modifications manually.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline xtremecruiser

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: [Mod] Simple Blog
« Reply #110 on: December 31, 2006, 01:11:58 pm »
For custom themes you need to add the modifications manually.
Can you give me a quick hint to what area that is ?
Thanks

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15147
    • View Profile
Re: [Mod] Simple Blog
« Reply #111 on: December 31, 2006, 01:13:56 pm »
You will have to open up the .xml file not package-info.xml

Read over
http://docs.simplemachines.org/index.php?topic=402
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline xtremecruiser

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: [Mod] Simple Blog
« Reply #112 on: December 31, 2006, 01:18:11 pm »
So it seems many themes use the Themes/default/languages/Modifications.english.php file and alienation uses
Themes/alienation/languages/english.modifications.php
« Last Edit: December 31, 2006, 04:37:14 pm by xtremecruiser »

Offline Samwood

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: [Mod] Simple Blog
« Reply #113 on: January 01, 2007, 04:00:37 am »
Recent Blogs is showing fine but no to pageviews.
Open /Source/SimpleBlog.php
Find:
Code: [Select]
      if(!empty($id) && !$ID_MEMBER == $u && !$ID_MEMBER == 0)
      {
      db_query("UPDATE {$db_prefix}simple_blog SET count = count + 1 WHERE ID_BLOG = $id LIMIT 1", __FILE__, __LINE__);
      }
and replace it by:
Code: [Select]
      if(!empty($id) && $ID_MEMBER != $u && $ID_MEMBER != 0)
      {
      db_query("UPDATE {$db_prefix}simple_blog SET count = count + 1 WHERE ID_BLOG = $id LIMIT 1", __FILE__, __LINE__);
      }

Offline Adariel

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: [Mod] Simple Blog
« Reply #114 on: January 06, 2007, 11:43:57 pm »
I seem to have found some kind of incompatibility between Simple Blog and PayPal donations mod.  Each mod will install fine by itself, but neither will install WITH the other as they both edit ./Sources/ModSettings.php and installing one seems to throw things off.  I'm also posting on the Paypal Donations mod thread to see if there is something either author can do to make them play nice together.

FYI, I'm running 1.1.1 on the default theme.

http://www.raven-flight.com/community

Offline grodden

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: [Mod] Simple Blog
« Reply #115 on: January 08, 2007, 10:14:53 pm »
Thank you very much Woden!
Anyone know if it will be any bot for CB?
 ;D


Offline sawz

  • Newbie
  • *
  • Posts: 22
    • View Profile
Re: [Mod] Simple Blog
« Reply #116 on: January 13, 2007, 08:20:02 am »
everything about this mod is sweet, and everything seems to work as it should, except for:

page views. someone commented that i should disable that because the mod is too good to fret over a couple of things that don't work. good answer.

not good actually, thats like saying lets add a bunch of cool looking features that don't work, they look good but hey, who needs em.

has anyone figured why page view numbers don't increase as they should?

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15147
    • View Profile
Re: [Mod] Simple Blog
« Reply #117 on: January 13, 2007, 10:05:10 am »
I would hold off on this mod and wait till I make a new one. This one needs to be redone.
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline LeberMac

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: [Mod] Simple Blog
« Reply #118 on: January 16, 2007, 02:59:56 pm »
... and here I was about to ask if it's really compatible with SMF 1.1.1 and TP 0.9.7.x ...
Oh well, I can wait. I think.
:)

I get an installation error/alert anyway:
2.     Execute Modification     ./Themes/default/Profile.template.php     Test failed

Offline grodden

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: [Mod] Simple Blog
« Reply #119 on: January 24, 2007, 06:50:08 am »
Is there anyone here that made or is thinking of making a bot to Comunity builder/jommla on this module?
I really need this :)

 

Related Topics

  Subject / Started by Replies Last post
4 Replies
11427 Views
Last post September 19, 2006, 09:25:37 am
by lisah746
9 Replies
11474 Views
Last post January 28, 2007, 12:54:40 pm
by doctoreast
1 Replies
4708 Views
Last post February 19, 2007, 08:34:02 pm
by SlaveToThis
6 Replies
8697 Views
Last post May 11, 2007, 02:18:33 pm
by asklife
5 Replies
5118 Views
Last post July 17, 2007, 02:33:51 am
by KnightRobby

+- Recent Topics

Quality of images after import by SMFHacks
September 05, 2020, 10:21:44 am

How do I download gallery images? by CWVRV
August 30, 2020, 11:50:07 pm

Deleting Empty Galleries by SMFHacks
August 30, 2020, 11:43:32 am

PHP error by davejo
August 25, 2020, 07:35:13 am

Permissions to list ads and buy items by CWVRV
August 21, 2020, 05:19:45 pm

Doubt with download permissions. by Rock Lee
August 20, 2020, 08:23:24 pm

Attachment images Upsidedown or Sideways by SMFHacks
August 18, 2020, 05:41:07 pm

[Mod]Avatars Display Integration by Hatshepsut
August 17, 2020, 11:39:54 pm

Simple Portal Block - Classifieds by SMFHacks
August 16, 2020, 09:56:48 am

SMF Links by SMFHacks
August 16, 2020, 08:03:42 am

Powered by EzPortal