Facebook  Twitter 

SMFHacks.com

+- +-

SMFHacks.com

+- User Information

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+- Forum Stats

Members
Total Members: 11779
Latest: jeremycstrange@gmail.com
New This Month: 2
New This Week: 1
New Today: 0
Stats
Total Posts: 40981
Total Topics: 7173
Most Online Today: 97
Most Online Ever: 2482
(April 09, 2011, 07:02:45 pm)
Users Online
Members: 0
Guests: 27
Total: 27

Author Topic: Message Editor Pro Issues  (Read 1466 times)

0 Members and 1 Guest are viewing this topic.

Offline SeverityGaming

  • Newbie
  • *
  • Posts: 17
    • View Profile
Message Editor Pro Issues
« on: November 06, 2019, 12:04:36 am »
Pls move if this is the wrong location, couldn't find a boad on the site here.

After installing Message Editor Pro, I'm getting the following error when it's enabled: Call to undefined function addInlineCss()

And then when I disable it, and it and try to use the original 2.0.15 editor, it shows an edit box but no smileys or BBC buttons.

After doing a hard refresh of the browser (clearing cached etc.) seems like I'm still having the same issues.

Things I noticed, the editor.js that is included in the package is substantially smaller than the one I currently have. By copying that from source control to my dev website, and then clearing browser cache, it restore  BBC and smileys, although I do still see this error for a missing ) bracket somewhere.


Are you sure this is in a good state and works with 2.0.15 OOB?

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15464
    • View Profile
Re: Message Editor Pro Issues
« Reply #1 on: November 06, 2019, 12:51:17 am »
Posted an update to fix those issues. Odd didn't' notice before and I use it on this forum

1.0.5
!Fixed missing addinlinecss function
!Fixed javascript console error message
!Don't overwrite editor.js
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline SeverityGaming

  • Newbie
  • *
  • Posts: 17
    • View Profile
Re: Message Editor Pro Issues
« Reply #2 on: November 06, 2019, 08:13:10 am »
It also doesnt seem to clean up after itself well on uninstall. DB vars still present, and lots of css, js, and template files left behind.

Offline SeverityGaming

  • Newbie
  • *
  • Posts: 17
    • View Profile
Re: Message Editor Pro Issues
« Reply #3 on: November 06, 2019, 08:16:28 am »
Is there a way to turn on WYSIWYG by default? And during uninstall, I think you're shipping it with a few themes, is there a way in settings to change it (my use case is a forum with a dark background, so the default white is a pretty big contrast flip)

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15464
    • View Profile
Re: Message Editor Pro Issues
« Reply #4 on: November 06, 2019, 01:49:55 pm »
The built in  WYSIWYG  editor you can enable under Theme Settings -> Member options.

For the background are you talking about the editor? Highlighted below
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline SeverityGaming

  • Newbie
  • *
  • Posts: 17
    • View Profile
Re: Message Editor Pro Issues
« Reply #5 on: November 06, 2019, 06:53:01 pm »
yea, see ss example.

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15464
    • View Profile
Re: Message Editor Pro Issues
« Reply #6 on: November 06, 2019, 07:41:00 pm »
Hmm looks like requires right now an edit to themes/default/css/jquery.sceditor.php

around line 212 inside .sceditor-container textarea
Code: [Select]
  background: #fff;
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

Offline SeverityGaming

  • Newbie
  • *
  • Posts: 17
    • View Profile
Re: Message Editor Pro Issues
« Reply #7 on: November 06, 2019, 09:35:48 pm »
So nothing has been implemented from the /themes/default/scripts/themes that appears to be included with this?

Offline SMFHacks

  • Administrator
  • Hero Member
  • *****
  • Posts: 15464
    • View Profile
Re: Message Editor Pro Issues
« Reply #8 on: November 06, 2019, 09:58:33 pm »
It does not look like those are used. They don't change the background color of the textarea though. Mainly changes the buttons themselves.
https://www.sceditor.com/posts/themes-demo/
Get your Forum Ranked! at https://www.forumrankings.net - find out how your forum compares with others!

Like What I do? Support me at https://www.patreon.com/vbgamer45/

 

Related Topics

  Subject / Started by Replies Last post
27 Replies
19343 Views
Last post August 19, 2009, 08:01:01 am
by SMFHacks
7 Replies
5976 Views
Last post August 31, 2018, 02:03:34 am
by shuban
16 Replies
2680 Views
Last post October 19, 2018, 11:26:45 pm
by dan42101
7 Replies
1237 Views
Last post April 04, 2020, 09:01:21 am
by marcimila
0 Replies
1026 Views
Last post April 03, 2020, 07:54:07 pm
by SMFHacks

+- Recent Topics

Where are original uploaded files stored? by robgratt
June 20, 2021, 12:41:48 pm

Errors for nonexistent members by Krash
June 14, 2021, 09:51:47 pm

Error message: cannot access upload path by SMFHacks
June 08, 2021, 10:06:22 am

How to change order of the Classifieds board by SMFHacks
May 31, 2021, 09:57:36 am

Standard version of Downloads mod value missing by SMFHacks
May 25, 2021, 11:32:48 pm

Privacy Link by SMFHacks
May 14, 2021, 11:11:51 am

Gallery font by SMFHacks
May 13, 2021, 09:58:02 am

Mod Using Google App Script by T7i
May 09, 2021, 08:19:03 pm

Guest has high bid? by Shades
May 06, 2021, 01:36:08 pm

Simple Portal Block - Classifieds by Shades
May 06, 2021, 12:24:32 pm

Powered by EzPortal